LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-23-2010, 03:08 PM   #1
gkmills
LQ Newbie
 
Registered: Aug 2010
Posts: 2

Rep: Reputation: 0
make RDM available as mount point on Linux server


Newbie, so sorry if I don't use the correct terminology. I built a Suse Linux server on vmware. I attached an RDM to the server and can now see the drive as a "Mass Storage Drive" in Applications - computer. When I double click on the icon, I get an error message that indicates that the drive can not be mounted. I tried to mount in gnome terminal using: mount /dev/sdb and get "can't find .dev/sdb in /etc/fstab or /etc/mtab". I tried adding device that I would like to mount to fstab, but don't think I have the settings correct. I looking for any info that might step me through the process. Thanks!
 
Old 08-24-2010, 06:58 PM   #2
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Debian + Ubuntu
Posts: 4,358

Rep: Reputation: 57
Hi gkmills,

When you attach the RDM device to the machine, what device does it become? You should be able to find this by running "dmesg" a few moments after attaching the device.

When you know what the device is, you can see if it has been automounted somewhere: "cat /proc/mounts" and then look through for the device name (/dev/sdXx) you just mentioned. Incidentally, the device itself will be /dev/sdX but the partition (where the filesystem is, which is what gets mounted) should be /dev/sdX1 (where 1 will be a number, not necessarily 1).

Try these and then come back to us.

Thymox.
 
Old 08-25-2010, 03:42 PM   #3
gkmills
LQ Newbie
 
Registered: Aug 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Thymox,

Thanks for the reply. When I look in /dev the RDM shows up as sdb. I think my problem has some thing to do with formatting. I'm using cfdisk and have it setup as shown.

Disk Drive: sdb
Size: 241591910400 bytes, 241.5 GB
Heads: 255 Sectors per Track: 63 Cylinders: 29371

Name Flags Part Type FS Type [Label]
-----------------------------------------------------------------------
sdb1 Primary Linux


I ran dmesg as you suggested and found two references to sdb:

VFS: Can't find ext3 filesystem on dev sdb.
sd 0:0:1:0: [sdb] 471859200 512-byte hardware sectors: (241GB/225GiB)
sd 0:0:1:0: [sdb] Write Protect is off
sd 0:0:1:0: [sdb] Mode Sense: 87 00 00 08
sd 0:0:1:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
sdb: sdb1 < sdb5 >
sd 0:0:1:0: [sdb] 471859200 512-byte hardware sectors: (241GB/225GiB)
sd 0:0:1:0: [sdb] Write Protect is off
sd 0:0:1:0: [sdb] Mode Sense: 87 00 00 08
sd 0:0:1:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
sdb:
VFS: Can't find ext3 filesystem on dev sdb.

and:

ppa: Version 2.07 (for Linux 2.4.x)
sd 0:0:1:0: [sdb] 471859200 512-byte hardware sectors: (241GB/225GiB)
sd 0:0:1:0: [sdb] Write Protect is off
sd 0:0:1:0: [sdb] Mode Sense: 87 00 00 08
sd 0:0:1:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
sdb: sdb1
sd 0:0:1:0: [sdb] 471859200 512-byte hardware sectors: (241GB/225GiB)
sd 0:0:1:0: [sdb] Write Protect is off
sd 0:0:1:0: [sdb] Mode Sense: 87 00 00 08
sd 0:0:1:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
sdb: sdb1

The output from cat/proc/mounts is:

rootfs / rootfs rw 0 0
udev /dev tmpfs rw,mode=755 0 0
/dev/sda2 / ext3 rw,errors=continue,user_xattr,acl,barrier=1,data=ordered 0 0
/proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
debugfs /sys/kernel/debug debugfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
securityfs /sys/kernel/security securityfs rw 0 0
gvfs-fuse-daemon /root/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user_id=0,group_id=0 0 0

I have tried to manually mount the drive and got:

servername:/ # mount /dev/sdb1/dev
mount: can't find /dev/sdb1/dev in /etc/fstab or /etc/mtab
servername:/ # mount /dev/sdb1 /dev
mount: you must specify the filesystem type

I'm not sure what to enter for filesystem type.

I think that I'm almost there, but not sure what I am missing.

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Make removable USB hdd mount at fixed mount point ctkroeker Linux - General 13 08-11-2009 09:49 AM
Set up rsync to mirror mount on Windows Server to mount point on 2nd internal drive MoMule Linux - Server 4 04-13-2007 10:34 PM
make hdc the mount point for dvdd again? verbose Linux - Hardware 6 01-02-2006 02:49 PM
would it make sense to have 2 mount point for 1 device? sirpelidor Linux - Hardware 3 12-27-2003 01:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration