LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-04-2004, 12:57 AM   #1
theAntic
Member
 
Registered: Jul 2004
Location: Rexburg, ID
Distribution: Mandrakelinux 10.0
Posts: 34

Rep: Reputation: 15
Logitech 3 button mouse.. WHERE'S THE ROLLER BALL GONE?


I just recently installed Linux on my computer, and am trying to get my mouse to function like the 3-button, roller mouse default I chose on install. I get that my Windows drivers aren't probably going to work and that I'll have to make do with a default driver, but the rollerballing feature doesn't even activate.. I even tried running my mouse's driver CD (which of course wasn't made for Linux), and it won't read.

How can I switch default mouse drivers in Linux?

In reality, this is a 7 button mouse (left, right, rollerball, page up, page down, and two thumb buttons).. is there any way at all to get any of these buttons back, but most specifically the rollerball?

Thanks!

Last edited by theAntic; 07-04-2004 at 12:59 AM.
 
Old 07-04-2004, 01:07 AM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
What dist. are you using?
 
Old 07-04-2004, 01:08 AM   #3
theAntic
Member
 
Registered: Jul 2004
Location: Rexburg, ID
Distribution: Mandrakelinux 10.0
Posts: 34

Original Poster
Rep: Reputation: 15
Mandrakelinux 10.0
 
Old 07-04-2004, 01:23 AM   #4
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
I don't use mandrake but there is a mandrake control center and under hardware then your mouse see if you can set-up your mouse there,need to be root to change anything,also take a look at ect/X11/xf86config-4 dont change anything just post the mouse stuff and I'm sure someone can help you out.
 
Old 07-04-2004, 01:43 AM   #5
theAntic
Member
 
Registered: Jul 2004
Location: Rexburg, ID
Distribution: Mandrakelinux 10.0
Posts: 34

Original Poster
Rep: Reputation: 15
I posted this in the Linux Hardware forum, including the info you mentioned to post up.

Thanks!
 
Old 07-04-2004, 02:35 AM   #6
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
You should have just stayed here,they get mad if you jump around and double post!
 
Old 07-05-2004, 11:36 PM   #7
rahmed
Member
 
Registered: Feb 2004
Location: somewhere over the rainbow...
Distribution: Slackware 10.1
Posts: 166

Rep: Reputation: 30
in ur XF86Config-4 file, u want to add this to the section that says
Section "Input Device"
Identifier "Mouse1"
and u want to add the line right under it
Option "ZAxisMapping" "4 5"
 
Old 07-06-2004, 12:02 PM   #8
theAntic
Member
 
Registered: Jul 2004
Location: Rexburg, ID
Distribution: Mandrakelinux 10.0
Posts: 34

Original Poster
Rep: Reputation: 15
Ok.. I adjusted my mouse configuration to look like this:

Code:
Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "ZAxisMapping" "4 5"
    Option "Protocol" "IMPS/2" "Buttons" "7"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "6 7"
EndSection
It's still not scrolling vertically and I don't know how to control the operation of the other buttons (ie. one of my thumb buttons jumps the page down, while the buttons directly above and below the roller, which should be jumping the page, don't do anything). Am I missing something?

Last edited by theAntic; 07-06-2004 at 12:03 PM.
 
Old 07-06-2004, 06:58 PM   #9
rahmed
Member
 
Registered: Feb 2004
Location: somewhere over the rainbow...
Distribution: Slackware 10.1
Posts: 166

Rep: Reputation: 30
have u restarted x?
 
Old 07-06-2004, 08:29 PM   #10
theAntic
Member
 
Registered: Jul 2004
Location: Rexburg, ID
Distribution: Mandrakelinux 10.0
Posts: 34

Original Poster
Rep: Reputation: 15
I've restarted my computer a number of times.. doesn't that restart 'X'?
 
Old 07-06-2004, 10:45 PM   #11
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
Hello theAntic.

log in into KDE.

Click on the Application Button (the blue rectangle with yellow start).
Then select following from the fly-out menu:
System->Configuration->Configure your computer

Mandrake control Center will be started, Select there the "Hardware" Icon. In the Mandrake Hardware Control Center
select the Mouse you need. As I can see you have double "ZAxisMapping" entry in your XF86Config-4.
That's not a good idea.

I do not know if you have an USB or PS/2 mouse. The Mandrake configuration
utility will let you choose the bus. Select as first under the selected bus a standard 3-button mouse with wheel, and see if wheel is enabled.

Last edited by Vlad-A; 07-06-2004 at 11:03 PM.
 
Old 07-07-2004, 12:03 AM   #12
theAntic
Member
 
Registered: Jul 2004
Location: Rexburg, ID
Distribution: Mandrakelinux 10.0
Posts: 34

Original Poster
Rep: Reputation: 15
Vlad, you're back! And just in time too.. 'X' isn't loading now when I run Linux. It throws an IO error, apparently because of the changes I made in my XF86Config-4.conf file. Here's what it's saying specifically:
Code:
Parse error on line 42 of section InputDevice in file /etc/X11/XF86Config-4
      "Buttons" is not a valid keyword in this section

(EE) Problem parsing the config file
(EE) Error from xf86HandleConfigFile()

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
 after 0 requests (0 known processed) with 0 events remaining.
I think I know what's happening.. you pointed it out in your post above too - I included an extra line of code that shouldn't be in the Input Mouse section of the XF86Config-4 file. The problem is, I have no idea how to fix it now that X isn't loading. Can I rewrite the XF86 file from the linux text prompt (it looks like DOS when it runs now)? What do I do?

Thanks again!

PS. Is the "Buttons" "7" code I inserted in the XF86Config-4 file also causing problems? It mentioned that "Buttons" (in plural form) was not a valid keyword. Was the advice I got above to include that wrong, or did I just include it incorrectly? Thanks!

Last edited by theAntic; 07-07-2004 at 12:10 AM.
 
Old 07-07-2004, 04:20 AM   #13
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
Hello theAntic,

1) you have in your XF86Config-4
Option "Protocol" "IMPS/2" "Buttons" "7"
It should be:
Option "Protocol" "IMPS/2"
Option "Buttons" "7"
So you need a new line and Option in front of "Buttons"

2) Please delete the following entry from your XF86Config-4
Option "ZAxisMapping" "4 5"

3) GENERAL RECOMENDATION:
As you go more and more into Linux there will be some situations where
you need to change some configuration files.
PLEASE make a backup of the file prior changing it. If something goes
wrong, you have a very easy way to recover.
So
cp XF86Config-4 XF86Config-4.old

4) Yes you can edit files in the command prompt. This is happening with the vi editor
(my all time favorite editor, although some people would not agree with me that
this is the best editor ever written :-) Nevertheless vi is "the" UNIX editor and all
UNIX flavors have it.

Explainig vi would be a very long thing so I will give you here only the hints you need
to fix the XF86Config-4 file.

4-1) first change into etc/X11
cd /etc/X11

4-2) start vi
vi XF86Config-4

4-3) vi has two modes "edit" and "command". You change between those two modes with the [ESC] (Escape) Key.

Right after start you are in the "command" mode.

4-4) Navigate with the arrow keys to the line containing "ZAxisMapping" "4 5".
Place the cusrsor on the first charachter in the line and press twice "d". This will delete the line.
(dd "command" meand delete entire line).

4-5) Navigate with the cusrsor (arrow) keys to the line:
Option "Protocol" "IMPS/2" "Buttons" "7"
4-6) Place the cusrsor on the space between "IMPS/2" and "Buttons"
4-7) Hit the i key (i means insert) and hit the Enter Key. "Buttons" "7" shall be now in a new line.
4-8) Hit the [ESC] Key to go back into command modus.
4-9) Place the cusrsor on the opening quotemark of "Buttons"and hit the i key (as we know this means insert)
4-10) Press the Space key until the opening quotemark of "Buttons" is below the Options keyword
of the previous line (the line above).
4-11) Type now Option and leave one Space between Option and "Buttons"
4-12) Press [ESC] Key to go back to the command mode
4-13) Now hit : (you will be now at the commad line of vi. Usually this is the bottom line of the screen)
4-14) enter wq and hit the Enter key (wq means write and quit)
4-15) If you do not want to save the file then you shall enter at the commad line q! and press Enter

4-6) Reboot your computer.
(e.g by entering: init 6 and hitting the Enter Key)

5) Try to change the mouse settings like I described in my previous posting.

6) Do you have an USB or PS2 Mouse ?

7) Good Luck!!!

Last edited by Vlad-A; 07-07-2004 at 04:26 AM.
 
Old 07-07-2004, 05:58 PM   #14
theAntic
Member
 
Registered: Jul 2004
Location: Rexburg, ID
Distribution: Mandrakelinux 10.0
Posts: 34

Original Poster
Rep: Reputation: 15
EXCELLENT! I reconfigured my XF86Config-4 file and 'X' is once again booting up!

My mouse, however, is still scrolling horizontally... Just to be sure, I did reconfigure my mouse under a number of different driver options, and found that only the PS/2 mouse options seemed to respond. I noticed two things during my mouse driver experiment:
  1. My roller, irregardless of direction (up or down) showed only a "down arrow" while rolling - I think this means it's recording a horizontal scroll
  2. Everytime I selected a new driver, upon reentering the Mandrake Control Center my mouse driver was always reset to Universal Any PS/2 & USB mice - Is this normal?
Here's how my mouse section in the XF86Config-4 file is reading now:
Code:
Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Buttons" "7"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "6 7"
EndSection
Oh yeah, my mouse is USB, but it's plugged into my computer's serial mouse port with a serial adapter..

THANKS!

Last edited by theAntic; 07-07-2004 at 06:01 PM.
 
Old 07-07-2004, 11:20 PM   #15
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
Hello theAntic,

it's normal that your selection is always reset to "Universal Any PS/2 & USB mice".
This is a universal driver for a wide range of mices and maybe your mouse was not recognized
for the option you have selected.

Now let us try following:

1) Log-In into KDE as root

2) Make a backup of your /etc/X11/XF86Config-4
cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.orig
Now we have a copy of the XF86Config-4 file called XF86Config-4.orig

3) open your /etc/X11/XF86Config-4
kwrite /etc/X11/XF86Config-4

4) We will edit following line:
Option "Protocol" "IMPS/2"
in the section: Section "InputDevice"

5) Replace in this line "IMPS/2" with "ExplorerPS/2"
Now your Option for the Mouse Protocol should look like
Option "Protocol" "ExplorerPS/2"

6) Save the changed /etc/X11/XF86Config-4 file

7) Reboot or restart X Server by pressing [CTRL]+[ALT]+[BACKSPACE]

8) See if now the mouse wheel works

9) If the wheel does not work as desired
then change follwing line in XF86Config-4
from
Option "ZAxisMapping" "6 7"
to
Option "ZAxisMapping" "8 9"

This time do not copy XF86Config-4 to XF86Config-4.orig
since you have already done this. If you cp this time
you would overwrite the origanl file with a changed.

10) Save the XF86Config-4 file

11) reboot or restart X Server by pressing [CTRL]+[ALT]+[BACKSPACE]

12) See if now the mouse wheel works

13) If not change back protocol from "ExplorerPS/2" to
"IMPS/2". Do *not* change "ZAxisMapping" "8 9"
back to "ZAxisMapping" "6 7".
Again: do not copy XF86Config-4 to XF86Config-4.orig
since you have already done it. If you cp this time
you would overwrite the origanl file with a changed

14) reboot or restart X Server by pressing [CTRL]+[ALT]+[BACKSPACE]

15) See if wheel works

IMPORTANT: FALLBACK (if something goes wrong)
What to do if something goes wrong: e.g. Mouse does not react at all after changing the XF86Config-4 File and rebooting

2-1) If you notice that your mouse does not react after reboot press following keys at the same time
[CTRL] + [ALT] + [F1]
So you need to press the Control, the ALT and the F1 Key.
This will kill kdm.

2-2) The text screen will be displayed. You may be asked to log in. Log in as root.

2-3) If you see a line like "Starting dm:" or "ALSA driver is already running" and not an input prompt,
just hit the [ENTER] Key.

2-4) At the input prompt, enter
init 3
and hit [ENTER]
System will then enter init level 3.

2-5) Again if the system "hangs" at a line (e.g: ALSA driver is already running, or else)
hit the [ENTER] Key to get a command prompt.

2-6) Change into /etc/X11
cd /etc/X11
2-7) Recover the original XF86Config-4
cp /etc/X11/XF86Config-4.orig /etc/X11/XF86Config-4
You may be asked if you want to overwrite /etc/X11/XF86Config-4
Answer with yes (so press y and then hit the [ENTER] Key)

2-8) Reboot by entering
init 6
and hitting the [ENTER] Key

Last edited by Vlad-A; 07-08-2004 at 01:01 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse Scroll Button doesn't work with Logitech PS/2 MOuse. duffmckagan Slackware 10 12-02-2008 11:27 PM
Logitech mouse, only first button work Causea Linux - Hardware 4 08-09-2004 04:14 AM
Logitech 3 button mouse (no scroll wheel) Jmorales22 Linux - Hardware 4 03-23-2004 06:52 PM
Logitech Mouse: side button won't work hopper02 Linux - Hardware 0 11-21-2003 02:44 PM
Logitech mouse - scroll button kazuni Linux - Newbie 1 06-03-2003 06:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration