LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-10-2010, 10:15 AM   #1
neilymack
LQ Newbie
 
Registered: Aug 2010
Posts: 6

Rep: Reputation: 0
log in screen disabled


Suffering with a log in problems for user accounts but I have compounded it by accidentally disabling local log in!
Using CentOS 5 and from within the local root user I opened the log in screen preferences and then opened the Security tab. I then opened the "configer Xserver" and I have unchecked the "logins are handled by this computer". Now Since I have logged out of root all I have is the X cursor on a black screen and no log in. Obviously logins are not handled by this computer as I unchecked it!!!!!!!
Is there anyway to get this back on as I cannot access this from another PC.
Thanks
 
Old 08-10-2010, 10:21 AM   #2
dcatiii
LQ Newbie
 
Registered: Apr 2010
Location: Dallas, TX
Distribution: Arch, Ubuntu, Redhat
Posts: 26

Rep: Reputation: 0
Do you happen to have access to a Live CD? Almost any distro should work... load your PC via Live CD, determine which configuration file needs to be changed... make the modification and reboot and you should be golden...
 
Old 08-10-2010, 12:23 PM   #3
neilymack
LQ Newbie
 
Registered: Aug 2010
Posts: 6

Original Poster
Rep: Reputation: 0
Unfortunately I dont have access to a live CD. I have worked out how to get a shell up and I can access the root account. Can I activate the GUI from within this shell??
 
Old 08-10-2010, 12:38 PM   #4
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Depends on how exactly you got that shell running. If you have a username (root or some user) you might be able to run `startx` and get a GUI, but don't hold your breath!

Some files of interest:

/etc/securetty # sets which tty's root can login on (at least "console" should be uncommented if root can login on local console.
/etc/login.access # sets who's disallowed to login from where.
/etc/nologin # if exists, will inhibit non-root logins.
/etc/login.defs # a bunch of configuration fields pertaining to logins in general.

If you can't get the GUI, have a look in those files for starters, and see if you can determine if they are configured such that local logins are not allowed. Keep track of what you change, in case you accidentally create a security hole!!!

Good luck.
 
1 members found this post helpful.
Old 08-10-2010, 12:41 PM   #5
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 6/7
Posts: 1,375

Rep: Reputation: 217Reputation: 217Reputation: 217
Why does this need a live CD?

There are two ways to attempt to get in. If you reboot the system and catch grub. Go to the default installation and edit it, go to the kernel line and place a 3 at the end (this setting is not saved). Alternatively try combinations of keys with the F3 button, example Alt + Ctrl + F3 until it drops you into a console.

This will declare run level 3 what will give you terminal/console access to the system. Unfortunately I do not know what file needs to be edited to fix this tho. If none of this works, you might be looking at having actually go into single user-mode to fix this... what is run level 1...
 
1 members found this post helpful.
Old 08-10-2010, 12:49 PM   #6
neilymack
LQ Newbie
 
Registered: Aug 2010
Posts: 6

Original Poster
Rep: Reputation: 0
I managed to get the shell up by usinf ctrl Alt F1. I was then able to log into the root user
 
Old 08-10-2010, 01:33 PM   #7
neilymack
LQ Newbie
 
Registered: Aug 2010
Posts: 6

Original Poster
Rep: Reputation: 0
I have managed to get the gui back up and running.
If I had read the error messages correctly when I attempted the startx command I would have seen the problem was a lock file in the tmp folder. removed it and xstart worked. I have now rechecked the logins handled by this computer box in the security tab and at least this problem is fixed. Now to deal with the network log in problems...........I may return soon.

Thanks for the input guys!!!
 
Old 08-10-2010, 02:33 PM   #8
dcatiii
LQ Newbie
 
Registered: Apr 2010
Location: Dallas, TX
Distribution: Arch, Ubuntu, Redhat
Posts: 26

Rep: Reputation: 0
Quote:
Originally Posted by r3sistance View Post
Why does this need a live CD?

There are two ways to attempt to get in. If you reboot the system and catch grub. Go to the default installation and edit it, go to the kernel line and place a 3 at the end (this setting is not saved). Alternatively try combinations of keys with the F3 button, example Alt + Ctrl + F3 until it drops you into a console.

This will declare run level 3 what will give you terminal/console access to the system. Unfortunately I do not know what file needs to be edited to fix this tho. If none of this works, you might be looking at having actually go into single user-mode to fix this... what is run level 1...
gah, i didn't even think to edit grub / init... thanks, that has given me a new tool.
 
Old 08-10-2010, 04:12 PM   #9
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 6/7
Posts: 1,375

Rep: Reputation: 217Reputation: 217Reputation: 217
Quote:
Originally Posted by dcatiii View Post
gah, i didn't even think to edit grub / init... thanks, that has given me a new tool.
No problem, I have to break into servers occasionally to reset passwords, at customers request of course. Ubuntu is different to CentOS on how to get a root terminal as such. Ubuntu gives single user mode as an option in grub by default but it's passworded. There are still ways passed this (ie init=/etc/bash on the kernel line).
 
Old 08-10-2010, 10:12 PM   #10
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,417

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
With Centos and some other distros you can boot the install media and at the initial prompt, ignore the menu options and type

linux rescue

at the text prompt below. That will boot a RAMdisk version of Linux from the DVD/Cd and attempt to mount the HDD as a non-active disk under '/mnt'. You can then amend files on the HDD
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SBE Log Disabled on Dell PE 6850 Running RHEL Release 5.4 cbryansmith Linux - General 1 01-19-2010 11:52 AM
RHEL4: auditd writing to /var/log/messages even though it is disabled jgrumbles Linux - Security 5 09-21-2008 03:49 AM
Direct rendering enabled in Xorg log, disabled in glxinfo alexbaretta Linux - Software 1 06-23-2006 12:04 PM
Disabled accounts on the login screen! HELP!!!! Adeas Linux - Newbie 5 09-07-2003 09:19 PM
How to fix this error log[DISABLED SET-ID ] Cephas Linux - Security 1 07-31-2002 09:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration