LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-12-2019, 02:20 PM   #1
Rfisher0
LQ Newbie
 
Registered: Mar 2019
Posts: 5

Rep: Reputation: Disabled
Linux Mint 19 booting to tty


Hi!

Having a problem where my laptop is booting into tty.

I thought I had lost my root password yesterday and followed a tutorial to change it where I edited a line of code in the grub menu https://www.google.com/amp/s/m.wikih...-Linux%3famp=1

It did not boot into single user mode but started up normally. Now it is going straight to tty on startup and neither alt-ctrl-f6 or alt-ctrl-f7 get any response.

Sorry if I haven't explained well, would really appreciate any help
 
Old 03-12-2019, 10:06 PM   #2
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 1,796

Rep: Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553
Ctrl- is only needed to escape from being in the GUI. When at tty1-6, only Alt-Fn is needed.

What happens when you try Ctrl-Alt-F[1-5] or Ctrl-Alt-F8?
 
Old 03-12-2019, 10:35 PM   #3
1nuxg33k
Member
 
Registered: Feb 2019
Location: PNW
Distribution: Debian, CentOS, OpenSuse, Mint, LMDE
Posts: 74

Rep: Reputation: 30
Why not reverse what you did to the grub menu?
 
Old 03-13-2019, 08:40 AM   #4
Rfisher0
LQ Newbie
 
Registered: Mar 2019
Posts: 5

Original Poster
Rep: Reputation: Disabled
Thank you for the responses.

Alt-fn returns 'can't reactivate AUX port'

Ctrl-alt-f1 - 5 changes the tty from 1-5. Ctrl-alt-f8 gives no response.

Haven't been able to access grub with e on startup so I can't change the line back.
 
Old 03-13-2019, 12:18 PM   #5
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 8,608

Rep: Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772
The information in the link you posted explain how to change an existing password for the root user. Since Mint uses sudo and does not require creation of a root user/password during the install, did you after the installation create/enable root and create a password for the root user? If you did have root enabled with a password, I would expect the tutorial instructions to work.

Last edited by yancek; 03-13-2019 at 12:23 PM.
 
Old 03-13-2019, 12:44 PM   #6
petelq
Member
 
Registered: Aug 2008
Location: UK
Distribution: openSUSE(Leap and Tumbleweed) and a regularly changing third
Posts: 406

Rep: Reputation: Disabled
Quote:
Originally Posted by Rfisher0 View Post
Thank you for the responses.

Alt-fn returns 'can't reactivate AUX port'

Ctrl-alt-f1 - 5 changes the tty from 1-5. Ctrl-alt-f8 gives no response.

Haven't been able to access grub with e on startup so I can't change the line back.
Do you mean grub still boots but gets you to a console login? If so, log in and change grub from there. Or do you just get a grub prompt?
 
Old 03-13-2019, 12:50 PM   #7
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 1,796

Rep: Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553
Quote:
Originally Posted by Rfisher0 View Post
Alt-fn returns 'can't reactivate AUX port'
Alt-Fn means same thing as Alt-F1, Alt-F2, Alt-F3, Alt-F4, Alt-F5, Alt-F6, Alt-F7 or Alt-F#, not a literal n or #.

Quote:
Ctrl-alt-f1 - 5 changes the tty from 1-5.
With a login prompt? If yes, you can login as root or use sudo and fix what you broke, edit /etc/default/grub and/or /boot/grub/grub.cfg. At a place like this I use the OFM called mc for navigation and editing. If it's not already installed, install it with apt or aptitude. It's simple to use yet powerful and yet retains the shell cmdline ready to type in any command you wish to run. Editing the hard way includes vi and/or vim and/or nano and/or joe and whatever other non-GUI editors may be installed.

Quote:
Haven't been able to access grub with e on startup so I can't change the line back.
Editing as above will enable a permanent fix to the cmdline content. Why e doesn't work I have no idea, unless you managed to change the Grub timeout to 2 or less. Maybe your keyboard is being ignored at that point. Maybe hitting it before Grub appears or using the ESC key or a USB keyboard would help.
 
Old 03-13-2019, 12:53 PM   #8
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 10,598

Rep: Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179
@OP: Post the output of either or both of these commands

Code:
runlevel
who -r
It would also be smart to post your grub.cfg
 
Old 03-13-2019, 03:45 PM   #9
Rfisher0
LQ Newbie
 
Registered: Mar 2019
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by mrmazda View Post

With a login prompt? If yes, you can login as root or use sudo and fix what you broke, edit /etc/default/grub and/or /boot/grub/grub.cfg. At a place like this I use the OFM called mc for navigation and editing. If it's not already installed, install it with apt or aptitude.
I don't understand a lot of this, total Linux newbie. I do have a login prompt, how would I log in as root? I can use sudo -s and prompt changes to root@user: but stumped from there. Since I can't get to the desktop I don't know how to install anything.

Runlevel returns N 5

Who -r returns run-level 5 2019-03-13 14:04

How can I post grub.cfg?

Edit: Got to the gnu grub the line I edited seems to have reverted reading

Linux /boot/vmlinuz-4.15.0-38-generic root=UUID=ce56655c-2a84-4928-bb15-940f24c0e948 ro quiet splash $vt_handoff

Last edited by Rfisher0; 03-13-2019 at 04:09 PM. Reason: Additional information
 
Old 03-13-2019, 06:20 PM   #10
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, arch, ubuntu, others
Posts: 3,445

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
what happens if you login with your username and then type startx
 
Old 03-13-2019, 07:19 PM   #11
Rfisher0
LQ Newbie
 
Registered: Mar 2019
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by colorpurple21859 View Post
what happens if you login with your username and then type startx
xauth: unable to write authority file /tmp/serverauth.5dyawZRcqW-n
xauth: time out in locking authority file home/user/.Xauthority

(EE)
Fatal server error:
Could not create lock file in /tmp/.tX0-lock
 
Old 03-13-2019, 07:53 PM   #12
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 1,796

Rep: Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553
Quote:
Originally Posted by Rfisher0 View Post
xauth: unable to write authority file /tmp/serverauth.5dyawZRcqW-n
xauth: time out in locking authority file home/user/.Xauthority

(EE)
Fatal server error:
Could not create lock file in /tmp/.tX0-lock
This may be because /usr/bin/Xorg are normally mode 0755 with systemd, while startx might require a risky mode 4711. Possibly
Code:
sudo chmod 4711 /usr/bin/Xorg
would allow startx to not error, but without solving your OP.
 
Old 03-13-2019, 07:55 PM   #13
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, arch, ubuntu, others
Posts: 3,445

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
what happens if you run this
Code:
sudo -s
mount -o remount,rw /
exit
startx
there is no space between the , and rw

Last edited by colorpurple21859; 03-13-2019 at 07:57 PM.
 
Old 03-13-2019, 08:07 PM   #14
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 1,796

Rep: Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553Reputation: 553
Quote:
Originally Posted by Rfisher0 View Post
I don't understand a lot of this, total Linux newbie. I do have a login prompt, how would I log in as root?
Probably you cannot, because root normally in Mint and other Ubuntu derivatives no password for root is configured.

Quote:
I can use sudo -s and prompt changes to root@user: but stumped from there. Since I can't get to the desktop I don't know how to install anything.
Code:
sudo apt install mc
to install mc, then
Code:
su -
mc
to use mc in superuser mode, to navigate and make necessary configuration edits.

Quote:
Runlevel returns N 5

Who -r returns run-level 5 2019-03-13 14:04
5 is normal in Mint.

Quote:
How can I post grub.cfg?
Code:
pastebinit /boot/grub/grub.cfg
Quote:
Edit: Got to the gnu grub the line I edited seems to have reverted reading

Linux /boot/vmlinuz-4.15.0-38-generic root=UUID=ce56655c-2a84-4928-bb15-940f24c0e948 ro quiet splash $vt_handoff
When you use the e key to edit at a Grub menu, the edition only works for that boot, a temporary change.
 
Old 03-14-2019, 07:14 PM   #15
Rfisher0
LQ Newbie
 
Registered: Mar 2019
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by colorpurple21859 View Post
what happens if you run this
Code:
sudo -s
mount -o remount,rw /
exit
startx
there is no space between the , and rw
Gives the same error as before when just running xstart.

Was able to access grub menu and tried starting in recovery mode. Since then it's giving me a graphic login which loops.

Also tried clearing data but it's still giving me an error on installing that there isn't enough space.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to reset/restart a tty from another tty? armandino Linux - General 4 02-25-2009 03:09 AM
can a tty execute command on another tty? BeacoN Linux - Desktop 3 11-08-2008 09:39 AM
I it possible to kill a tty or find which tty is being using by which process? geletine Linux - Software 2 01-15-2006 08:40 AM
change tty => system crashes (ati driver/tty resolution) mosca Debian 6 08-05-2004 07:37 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration