LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-05-2005, 09:49 PM   #1
SpyPie
LQ Newbie
 
Registered: Jan 2005
Posts: 17

Rep: Reputation: 0
Lilo Error


This is my first time installing linux, and im completely lost as of now. Im trying to configure lilo.conf because everytime i boot it gives me the error "please append a good root= boot option"

Right now, my swap partition is hda2 and my bootable linux partition is hda1.

What do I put for boot = ? Root = ?

Right now boot = /dev/hda1/ and root = /dev/hda1/

What am I doing wrong? Thanks in advance...


- Brad
 
Old 01-05-2005, 10:06 PM   #2
SpyPie
LQ Newbie
 
Registered: Jan 2005
Posts: 17

Original Poster
Rep: Reputation: 0
Ive also tried root = hd, hda, hda2, and hdb and none have worked. Sorry fot he double post.
 
Old 01-05-2005, 10:48 PM   #3
SpyPie
LQ Newbie
 
Registered: Jan 2005
Posts: 17

Original Poster
Rep: Reputation: 0
No one?
 
Old 01-06-2005, 02:22 AM   #4
SpyPie
LQ Newbie
 
Registered: Jan 2005
Posts: 17

Original Poster
Rep: Reputation: 0
Ok, I really think Ive tried just about every hdX there is and still nothing, what do I do? Ive googled and still nothing that will help me with this error....
 
Old 01-06-2005, 03:31 AM   #5
SpyPie
LQ Newbie
 
Registered: Jan 2005
Posts: 17

Original Poster
Rep: Reputation: 0
Looking back at my posts I can see how vague I was. Sorry, I was frustrated hehe. I just formatted a 10 gig HD and make a 2 gig non bootable swap partition and an 8 gig bootable linux partition, installed phlak, and Lilo. But now when I try to boot it gets about halfway, but then I get the error
Kernal Panic - Cannot mount root fs on 341 (03:41)
Please append a useable "Root+" Boot option
And then it just hangs there until I reboot.
I can get in and edit lilo.conf thanks to my PHLAK bootdisk (which is also the installed distro.)

How might I go about fixing this problem?

I have tried Root = hda1, hda1, hda2 and hdb, as well as Boot = hda, hda1, hda2, hdb and combonations of the two. How might I fix this?

I have searched everywhere and cannot find the answer to this problem, thanks in advance...

- Brad
 
Old 01-06-2005, 03:43 AM   #6
judge_neo
Member
 
Registered: Sep 2004
Location: dumfries, scotland
Distribution: Mandrake10.1 ce
Posts: 65

Rep: Reputation: 15
not really my field but a good partition howto can be found here

http://www.tldp.org/HOWTO/Partition/
 
Old 01-06-2005, 06:43 AM   #7
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Rep: Reputation: 30
What distro are you using?
 
Old 01-06-2005, 07:02 AM   #8
Valindar
Member
 
Registered: Jun 2004
Location: Melbourne, Australia
Distribution: Slackware 9.1
Posts: 33

Rep: Reputation: 15
All I can think of is you want /dev/hda1 not /dev/hda1/ - it's not a directory. I believe that is your problem unless it was a typo in your post, not your lilo.conf.
Oh, and boot = is where you want the bootloader to be installed on. You probably want this on /dev/hda (note the lack of a number, meaning the master boot record (MBR) of the hard drive, on the first harddrive on IDE cable 1). If you were to write boot = /dev/hda1 however, you will be installing it onto (correct my term if I'm wrong) the superblock of that partition, which by default your system will not load the bootloader from.

Note that you need to run /sbin/lilo after everytime you change the config file otherwise the bootloader will not be updated with your changes.

Good luck. Everyone else feel free to correct me if I'm wrong!

Last edited by Valindar; 01-06-2005 at 07:05 AM.
 
Old 01-06-2005, 07:06 AM   #9
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
for each (linux) entry lilo need at least 4 entries to work correctly heres what mine looks like:

image = /boot/kernel-2.4.28 ( the path of the kernel you want to boot, look in boot for vmlinuz or such)
root = /dev/hda2 (where the root partition is (e.g. /))
label = Slackware
read-only (initially mount the root filesystem read-only for check before remounting read-write)

EDIT: the boot option (usually towards the very top of the file) is where you want to install lilo to for example:

boot = /dev/hda (this will install it to the master boot record)
boot = /dev/fd0 (this will install lilo to a floppy)

since this is your first linux install i would recommend installing lilo to a floppy instead of the master boot record (if you decide linux isn't your thing, this will make it easier to uninstall off of your system).

Last edited by __J; 01-06-2005 at 07:10 AM.
 
Old 01-06-2005, 12:47 PM   #10
SpyPie
LQ Newbie
 
Registered: Jan 2005
Posts: 17

Original Poster
Rep: Reputation: 0
Aliright, I finally got that worked out, and saved it. But now when I try to run /sbin/lilo, it says No such file or directory. Whats this about?
 
Old 01-06-2005, 01:16 PM   #11
Valindar
Member
 
Registered: Jun 2004
Location: Melbourne, Australia
Distribution: Slackware 9.1
Posts: 33

Rep: Reputation: 15
Umm, are you running it from a root console? However it would say "Permission denied" if you weren't. Maybe lilo is installed somewhere else, just try plain old 'lilo' as root.
If it still isn't working give 'locate lilo' a go and see what it finds out. If there's a file called lilo run it with an option of --version or something just incase it's not actually lilo. If it is run it normally as root.
 
Old 01-06-2005, 01:22 PM   #12
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
take a look at : #ls /sbin/lilo ( to check if it's there )

and maybe post your " /etc/lilo.conf " -file.

egag
 
Old 01-06-2005, 02:01 PM   #13
SpyPie
LQ Newbie
 
Registered: Jan 2005
Posts: 17

Original Poster
Rep: Reputation: 0
Ok, NOW im getting a "permission denied" message even though im in root. The distro is phlak, and heres my lilo.conf file...

Code:
# /etc/lilo.conf - See: `lilo(8)' and `lilo.conf(5)',
# ---------------       `install-mbr(8)', `/usr/share/doc/lilo/',
#                       and `/usr/share/doc/mbr/'.

# +---------------------------------------------------------------+
# |                        !! Reminder !!                         |
# |                                                               |
# | Don't forget to run `lilo' after you make changes to this     |
# | conffile, `/boot/bootmess.txt', or install a new kernel.  The |
# | computer will most likely fail to boot if a kernel-image      |
# | post-install script or you don't remember to run `lilo'.      |
# |                                                               |
# +---------------------------------------------------------------+

# Support LBA for large hard disks.
#
lba32

# Overrides the default mapping between harddisk names and the BIOS'
# harddisk order. Use with caution.
#disk=/dev/hde
#    bios=0x81

#disk=/dev/sda
#    bios=0x80

# Specifies the boot device.  This is where Lilo installs its boot
# block.  It can be either a partition, or the raw device, in which
# case it installs in the MBR, and will overwrite the current MBR.
#
boot=/dev/hda

# Specifies the device that should be mounted as root. (`/')
#
root=/dev/hda1

# Enable map compaction:
# Tries to merge read requests for adjacent sectors into a single
# read request. This drastically reduces load time and keeps the
# map smaller.  Using `compact' is especially recommended when
# booting from a floppy disk.  It is disabled here by default
# because it doesn't always work.
#
# compact

# Installs the specified file as the new boot sector
# You have the choice between: bmp, compat, menu and text
# Look in /boot/ and in lilo.conf(5) manpage for details
#
install=/boot/boot-menu.b

# Specifies the location of the map file
#
map=/boot/map

# You can set a password here, and uncomment the `restricted' lines
# in the image definitions below to make it so that a password must
# be typed to boot anything but a default configuration.  If a
# command line is given, other than one specified by an `append'
# statement in `lilo.conf', the password will be required, but a
# standard default boot will not require one.
#
# This will, for instance, prevent anyone with access to the
# console from booting with something like `Linux init=/bin/sh',
# and thus becoming `root' without proper authorization.
#
# Note that if you really need this type of security, you will
# likely also want to use `install-mbr' to reconfigure the MBR
# program, as well as set up your BIOS to disallow booting from
# removable disk or CD-ROM, then put a password on getting into the
# BIOS configuration as well.  Please RTFM `install-mbr(8)'.
#
# password=tatercounter2000

# Specifies the number of deciseconds (0.1 seconds) LILO should
# wait before booting the first image.
#
delay=20

# You can put a customized boot message up if you like.  If you use
# `prompt', and this computer may need to reboot unattended, you
# must specify a `timeout', or it will sit there forever waiting
# for a keypress.  `single-key' goes with the `alias' lines in the
# `image' configurations below.  eg: You can press `1' to boot
# `Linux', `2' to boot `LinuxOLD', if you uncomment the `alias'.
#
# message=/boot/bootmess.txt
prompt
timeout=150
#	prompt
#	single-key
#	delay=100
#	timeout=100

# Kernel command line options that apply to all installed images go
# here.  See: The `boot-prompt-HOWO' and `kernel-parameters.txt' in
# the Linux kernel `Documentation' directory.
#
# append=""
append="hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi noapic acpi=off apm=power-off"

# Boot up Linux by default.
#
default=Linux

image=/boot/vmlinuz-2.4.21-xfs
	root=/dev/hda1
	label=Linux
	
	read-only
#	restricted
#	alias=1

image=/vmlinuz.old
	label=LinuxOLD
	read-only
	optional
#	restricted
#	alias=2

# If you have another OS on this machine to boot, you can uncomment the
# following lines, changing the device name on the `other' line to
# where your other OS' partition is.
#
# other=/dev/hda4
#	label=HURD
#	restricted
#	alias=3
other=/dev/hda1
  label="Other(hda1)"

other=/dev/hda2
  label="WinNT(hda2)"
Thanks for all your help so far!
 
Old 01-06-2005, 02:12 PM   #14
Valindar
Member
 
Registered: Jun 2004
Location: Melbourne, Australia
Distribution: Slackware 9.1
Posts: 33

Rep: Reputation: 15
The config at a quick glance looks alright, post exactly what you type in your console when you get a permission denied message.
ie. do you type:

Code:
$ su -
# /sbin/lilo
'/sbin/lilo' - Permission denied
or something to that effect? ($ denotes user, # denotes root, if you haven't picked it up yet)

Please be as detailed as possible, you can never be too detailed!

If someone doesn't help you first, I'll help you in 12 hours (sleep time! it's ten past six in the morning here ).
 
Old 01-06-2005, 04:04 PM   #15
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
a couple of things:

on the linuxOLD entry, you didn't specify a root partition

you might remove the other = /dev/hda1 entry since you have that covered up above

on the winNT entry you might have to add the following at the end:

table = /dev/hda
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LILO L 99 error dllmetal Linux - General 10 12-21-2014 04:29 AM
Lilo error mattp Linux - Newbie 11 08-24-2004 11:14 PM
LILO LinuxEBDA error to /usr/bin/gdm error true_atlantis Slackware 0 04-28-2004 02:31 PM
error loading operating system (lilo error) KoKi Slackware 1 03-03-2004 05:46 PM
Lilo error 99 Groucho Slackware 1 09-30-2003 02:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration