LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-24-2016, 02:20 AM   #1
pconstantatos
LQ Newbie
 
Registered: Dec 2016
Posts: 29

Rep: Reputation: Disabled
Question Languade packages for Libre Office 5.2.4.2


Good Day to all and Merry Christmas. I installed LibreOffice 4.2.4.2 and downloaded the language packs for Italian and Greek. Managed to install Libre office but not the language packs. Can anyone tell me what commands I must use?
 
Old 12-24-2016, 04:51 AM   #2
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 21 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925
You don't say what Linux system you have (distro/version/desktop environment), and what format the language packs are in (names?).

Last edited by hydrurga; 12-24-2016 at 05:08 AM. Reason: I now see that the thread title has the correct version.
 
Old 12-24-2016, 06:27 AM   #3
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 21 MATE, EndeavourOS, antiX, MX Linux
Posts: 3,972
Blog Entries: 32

Rep: Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465
pconstantatos,

Install Italian and Greek language packs:

In Terminal:

Code:
sudo apt-get update
sudo apt-get install libreoffice-help-it 
sudo apt-get install libreoffice-l10n-it 
sudo apt-get install libreoffice-help-el 
sudo apt-get install libreoffice-l10n-el
Then open Writer/LibreOffice > Tools > Options > Language Settings > Change settings as required.

Happy Christmas!

Last edited by beachboy2; 12-24-2016 at 06:35 AM.
 
Old 12-24-2016, 07:35 AM   #4
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 21 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925
Quote:
Originally Posted by beachboy2 View Post
pconstantatos,

Install Italian and Greek language packs:

In Terminal:

Code:
sudo apt-get update
sudo apt-get install libreoffice-help-it 
sudo apt-get install libreoffice-l10n-it 
sudo apt-get install libreoffice-help-el 
sudo apt-get install libreoffice-l10n-el
Then open Writer/LibreOffice > Tools > Options > Language Settings > Change settings as required.

Happy Christmas!
Hi Beachboy. That will only install the latest versions in the repo, not necessarily (and very probably not) the latest version which the OP is downloading. I'm just trying to find out whether they have dpkg or not so I can tell them how to install the downloaded help packages.
 
Old 12-24-2016, 07:36 AM   #5
pconstantatos
LQ Newbie
 
Registered: Dec 2016
Posts: 29

Original Poster
Rep: Reputation: Disabled
Question Spellcheck off

Thanks to both of you
Both language packs have installed but I still get no spell check in these languages, the available languages are English, French and Spanish. Should I do something else to activate the two packs I just installed?
I tried what hydrurga suggested as far as the options are concerned but still no go. Apparently I am missing something. In spellcheck winow neither Greek nor Italian are listed.

Last edited by pconstantatos; 12-24-2016 at 07:44 AM.
 
Old 12-24-2016, 10:27 AM   #6
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 21 MATE, EndeavourOS, antiX, MX Linux
Posts: 3,972
Blog Entries: 32

Rep: Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465
Smile

hydrurga,

Understood.
 
Old 12-24-2016, 10:35 AM   #7
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 21 MATE, EndeavourOS, antiX, MX Linux
Posts: 3,972
Blog Entries: 32

Rep: Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465Reputation: 1465
pconstantatos,

Under Language Settings, you need to ensure that the "Default Language for Documents" is activated for whichever language you require.

In your case this is either Italian or Greek.
 
Old 12-24-2016, 10:54 AM   #8
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 13,163
Blog Entries: 1

Rep: Reputation: 2032Reputation: 2032Reputation: 2032Reputation: 2032Reputation: 2032Reputation: 2032Reputation: 2032Reputation: 2032Reputation: 2032Reputation: 2032Reputation: 2032
@pconstantatos
Quote:
Both language packs have installed but I still get no spell check in these languages, the available languages are English, French and Spanish. Should I do something else to activate the two packs I just installed?
You should download the italian and greek dictionaries and then add them using:
Tools->Extension Manager...->Add..

You need to restart libreoffice afterwards and you may need to select the language (from Tools->Language->..), before starting the spell check

Regards
 
Old 12-24-2016, 11:18 AM   #9
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Debian
Posts: 6,140

Rep: Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314Reputation: 2314
If you have the status bar at the bottom switched on, that shows your default language and you can alter it by clicking on it. Obviously the programs needs to be told which language you're using, or it might end up using the wrong dictionary.
 
Old 12-24-2016, 01:43 PM   #10
pconstantatos
LQ Newbie
 
Registered: Dec 2016
Posts: 29

Original Poster
Rep: Reputation: Disabled
Thumbs up LibreOffice woes

Guys thank you all for your help. The problem has been solved. I wish all of you Merry Christmas and a happy, healthy and prosperous New Year.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Libre office vs Open office Arcane Linux - Software 25 11-26-2019 05:57 PM
Libre Office and Open Office both fail to open MS Office documents correctly. Observed Linux - Newbie 8 07-18-2014 10:48 AM
[SOLVED] Libre Office or Open Office QueenZ Linux - Newbie 12 02-22-2013 03:58 AM
Unoconv Convertor for RHEL 6 : Libre office & open office utility vishwajeet jagtap Linux - Software 0 02-15-2013 09:44 AM
LXer: Libre Office Initial plans for the free office suite [German] LXer Syndicated Linux News 2 11-14-2010 05:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration