LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-28-2016, 09:38 AM   #1
18yu9wdef
Member
 
Registered: Nov 2016
Posts: 39

Rep: Reputation: Disabled
Installing Solus Problem (Secure boot issue? Maybe)


I'm trying to install Solus on my PC, probably going to be my first distro that isn't Ubuntu based. Now, I've had a similar problem installing Apricity OS.

So after I've burned the ISO onto a USB, I booted into my USB. I chose the option to proceed into Solus to try it, but it just went into a blank screen and the monitor eventually turned off. The same thing actually happened with Apricity. I noticed that this didn't actually happen only when I used an Ubuntu based distro. My friend suggested that I disable secure boot or look for an option to use legacy boot.

After looking in my motherboard manual, I found an option to use legacy boot, but still doesn't work, same issue occurs. I haven't found an option to doable secure boot however and I'm not sure where the real problem is actually at.


Motherboard: MSI X99a SLI Plus
 
Old 12-28-2016, 06:02 PM   #2
Brains
Senior Member
 
Registered: Apr 2009
Distribution: Debian Testing, Gentoo
Posts: 1,402

Rep: Reputation: 361Reputation: 361Reputation: 361Reputation: 361
This appears to happen often with PCs having Nvidia graphics, the nouveau driver appears a little unstable lately.
BUT:
As for what issues your live distribution(s) are facing is hard to pinpoint without some kind of information regarding what hardware your "PC" is comprised of. Motherboard is a start, but listing graphics adapter is likely the best hardware component to list when having graphic issues.
Quote:
My friend suggested that I disable secure boot or look for an option to use legacy boot.
Seeing as it appears to boot and give you an option to try it means it's not bios settings or motherboard.

Last edited by Brains; 12-28-2016 at 06:07 PM.
 
Old 12-28-2016, 08:12 PM   #3
18yu9wdef
Member
 
Registered: Nov 2016
Posts: 39

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Brains View Post
This appears to happen often with PCs having Nvidia graphics, the nouveau driver appears a little unstable lately.
BUT:
As for what issues your live distribution(s) are facing is hard to pinpoint without some kind of information regarding what hardware your "PC" is comprised of. Motherboard is a start, but listing graphics adapter is likely the best hardware component to list when having graphic issues.

Seeing as it appears to boot and give you an option to try it means it's not bios settings or motherboard.
Well, my GPU is an Nvidia GTX 970. I'm not sure if that's where the problem is, but I'm not able to get into the OS in the first place. I can't really try it, it just doesn't take me into it.
 
Old 12-28-2016, 08:48 PM   #4
Brains
Senior Member
 
Registered: Apr 2009
Distribution: Debian Testing, Gentoo
Posts: 1,402

Rep: Reputation: 361Reputation: 361Reputation: 361Reputation: 361
Quote:
Originally Posted by 18yu9wdef View Post
Well, my GPU is an Nvidia GTX 970.
As I suspected, I have the 970M
To boot into graphical desktop, you should be able to edit the kernel parameters at the grub menu. For Debian, since I did not use live media, I used the install media after installation in rescue mode to edit the /etc/default/grub file and added --> nouveau.modeset=0 as a parameter, ran command update-grub as root after editing it and rebooted to a desktop with less than optimal resolution, but had a desktop environment. Editing that file this way would get it to boot properly every time after, eventually I installed Nvidia.run installer from Nvidia's web site after installing kernel headers to get the nice desktop. I prefer from repositories but the 340 drivers I need (for desktop with GTS 8600) from Jessie are not compatible withe the version of xorg in my Stretch installation, which is why I went with Nvidia.run installer.

So...
For a live system, you should try adding either of the three parameters to the kernel line before booting.
Code:
nouveau.modeset=0
modeset nouveau.modeset=0
nomodeset
The first one works with my Debian Stretch, if it don't do it for you, try the second one. I have not booted this way since I made the change permanent, but theoretically it should be the same only it would be a one time only, and would have to be done every time you boot it.

Last edited by Brains; 12-29-2016 at 04:48 PM. Reason: added third modeset parameter
 
Old 12-29-2016, 09:16 PM   #5
18yu9wdef
Member
 
Registered: Nov 2016
Posts: 39

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Brains View Post
As I suspected, I have the 970M
To boot into graphical desktop, you should be able to edit the kernel parameters at the grub menu. For Debian, since I did not use live media, I used the install media after installation in rescue mode to edit the /etc/default/grub file and added --> nouveau.modeset=0 as a parameter, ran command update-grub as root after editing it and rebooted to a desktop with less than optimal resolution, but had a desktop environment. Editing that file this way would get it to boot properly every time after, eventually I installed Nvidia.run installer from Nvidia's web site after installing kernel headers to get the nice desktop. I prefer from repositories but the 340 drivers I need (for desktop with GTS 8600) from Jessie are not compatible withe the version of xorg in my Stretch installation, which is why I went with Nvidia.run installer.

So...
For a live system, you should try adding either of the three parameters to the kernel line before booting.
Code:
nouveau.modeset=0
modeset nouveau.modeset=0
nomodeset
The first one works with my Debian Stretch, if it don't do it for you, try the second one. I have not booted this way since I made the change permanent, but theoretically it should be the same only it would be a one time only, and would have to be done every time you boot it.
Ok, so I tried the second option (modeset nouveau.modeset=0) which ended up working so I can try out Solus. Haven't tried the third option for the parameters yet, but I might. Now I noticed that the resolution is stuck at 720p, but my monitor is a 1080p monitor. I tried to change the resolution, but I can't seem it. I assumed that I needed to install my GPU drivers... but I have no idea where to find that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg issue secure boot from nvidia driver iFunction Linux - Hardware 1 12-20-2016 10:38 PM
dual boot error (UEFI secure boot restricting installing centos7 over windows8) praduman1417 Linux - Newbie 3 12-24-2015 09:55 AM
Installing Ubuntu 12.10 with Secure Boot Davidicus Linux - Software 9 01-06-2013 10:38 AM
LXer: Installing Windows 8 with secure boot LXer Syndicated Linux News 0 11-21-2012 09:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration