Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 05-08-2009, 09:53 AM   #1
Registered: Mar 2009
Posts: 40

Rep: Reputation: 15
Question ifconfig problem

hello,I have 2 problems:-please answer them one by one

[1]-i have ubuntu-8.04 and two nic-interfaces card(namely eth0 and eth1).on eth1 interface i have given ipv4 address and nothing else.and for another interface eth0 i have left it for dhcp(for my internet connection) , if i run ifconfig command then i am getting 3 addreses on my eth1 interface they are-inet addr:
inet6 addr: 2000:ffff::215:17ff:fe65:c1a9/64 Scope:Global
and inet6 addr: fe80::215:17ff:fe65:c1a9/64 Scope:Link
I dont know why i am getting two extra address. I think long back ago i was getting only one extra inet6 address(i.e. inet6 addr: fe80::215:17ff:fe65:c1a9/64 Scope:Link) and at that time i was not getting any global address So PLEASE tell me why am i getting these and how to remove these so that i can have only one address (after my assigning).NOTE: My /etc/network/interfaces file has this info:
auto lo
iface lo inet loopback

iface eth1 inet static
auto eth1

iface eth0 inet dhcp
auto eth0

PROBLEM-[2]: I have another system having the same operating system as ubuntu-8.04.this time also i have two interfaces eth0 and eth1.on eth1 im using dhcp for my internet connection.on eth0 i have assigned ipv6 address 2001:468::3/64 Scope global.On this system also i am getting two extra addressess which i never assigned to my eth0.they are:
inet6 addr: 2001:468::219:d1ff:fe1e:e0cc/64 Scope: global
inet6 addr: fe80::219:d1ff:fe1e:e0cc/64 Scope: Link
Here also i think, earliar i was getting only one extra addr and that was link local addr(starting from fe80).
After ifconfig command I want only one global addr(2001:468::3 which i have assigned).PLEASE solve this problem also for me
here my /etc/network/interfaces contents is:
auto lo
iface lo inet loopback

iface eth0 inet6 static
address 2001:468::3
netmask 64
auto eth0

iface eth1 inet dhcp
auto eth1
Old 05-09-2009, 07:00 PM   #2
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
If you do not need IPv6 ... then disable it.
Most networks do not use/need IPv6.
Most likely you have a kernel module running called ipv6 ... black list it.

Otherwise just ignore it.
Old 05-11-2009, 01:13 AM   #3
Registered: Mar 2009
Posts: 40

Original Poster
Rep: Reputation: 15
Red face ifconfig problem

Originally Posted by dxqcanada View Post
If you do not need IPv6 ... then disable it.
Most networks do not use/need IPv6.
Most likely you have a kernel module running called ipv6 ... black list it.

Otherwise just ignore it.
No, i can't blacklist my ipv6 because im working on ipv4 to ipv6 migration and vice-versa.So, i should have my ipv6 up. but the problem is "why additional global ipv6 address is coming,which has not been assigned by me?and how to remove this addtional global address?"

I have tried this to remove but it din't work-
# ifconfig eth1 del 2000:ffff::215:17ff:fe65:c1a9/64
i did it on my first comp. which should have only ipv4 address- You are saying that i have to black-list the ipv6 address from here,so how to do it?

on my 2nd comp. i tried this-
# ifconfig eth0 del 2001:468::219:d1ff:fe1e:e0cc/64
to remove my additional global ipv6 address.her i need only 2001:468::3 (global address which i have assigned) so here i can't black list my ipv6 completely.

Please understand my problems and reply soon.Thanks alot....



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with ifconfig anis_huq Linux - Networking 1 01-10-2007 07:10 AM
ifconfig problem squirrel001 Linux - Networking 2 03-04-2006 02:13 AM
connecting /sbin/ifconfig to bash command ifconfig flammable2 Fedora 4 11-12-2005 08:58 AM
ifconfig problem Gnute Solaris / OpenSolaris 1 07-10-2005 01:49 PM
ifconfig problem chens_83 Linux - General 1 02-15-2002 10:51 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:37 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration