LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-10-2003, 09:24 PM   #1
scorpion777
Member
 
Registered: Jul 2003
Location: Georgia
Posts: 49

Rep: Reputation: 15
I can't mount my cdrom drive


When I type in mount cdrom i get this back:

mount: can't find cdrom in /etc/fstab or /etc/mtab

What do I do to mount it.
 
Old 08-10-2003, 09:27 PM   #2
ksgill
Senior Member
 
Registered: Apr 2003
Location: Toronto, Canada
Distribution: Ubuntu Jaunty (9.04)
Posts: 1,044

Rep: Reputation: 45
mount /dev/cdrom
and unmount using:
umount /dev/cdrom
 
Old 08-10-2003, 09:41 PM   #3
scorpion777
Member
 
Registered: Jul 2003
Location: Georgia
Posts: 49

Original Poster
Rep: Reputation: 15
Thanks, I got it to mount. Now I created a desktop icon so I wouldn't have to use command line to always mount it. When I'm out of root and I click on it it says:

Could not mount device.
The reported error was:
mount: only root can mount /dev/cdrom on /mnt/cdrom

I went to superuser mode and did a chmod +x to /dev/cdrom but it still doesn't work. what do i do for this
 
Old 08-10-2003, 10:33 PM   #4
looper
Member
 
Registered: Apr 2003
Posts: 68

Rep: Reputation: 15
check your fstab file [/etc/fstab]. Verify if inside of it there is a line that starts with the LABEL : /dev/cdrom, if no add this line:
/dev/cdrom /mnt/cdrom iso9660 noauto,ro 0 0

"/MNT/CDROM MUST EXIST" SO check if that folder exists, it should
 
Old 08-10-2003, 11:37 PM   #5
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
thats not so much the case, its just that a normal user doesn't have the rights to mount in which in turn you have to give them rights to do it....
and looper /mnt/cdrom obviously exists if he can mount it as root...
so in your /etc/fstab file where you see the line for you cdrom just add "user" to its options...
so instead of it just saying:
noauto,ro
it will say:
noauto,ro,user
then your normal users will be able to mount.
 
Old 08-11-2003, 08:15 AM   #6
looper
Member
 
Registered: Apr 2003
Posts: 68

Rep: Reputation: 15
scorpion777, Dr0zz is right, I forgot to complete it [it was late]. I wrote what I thought you had inside your fstab instead of what you should have to allow any user to mount it. So yes, add "user" to field 4 of your fstab
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mount external USB cdrom drive rickenbacherus Linux - Hardware 3 05-29-2006 07:12 PM
how do i mount my cdrom drive? mark solomon Linux - Newbie 5 06-10-2004 07:27 AM
my cdrom drive won't mount gcb Linux - General 2 11-14-2001 07:22 AM
Why can't I mount my CDRom Drive??? xM0M0x Linux - General 1 08-23-2001 07:40 AM
Can't mount cdrom after adding new drive jimweatherly Linux - General 4 05-29-2001 11:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration