LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-26-2003, 08:13 PM   #1
Techweenie1
Member
 
Registered: Feb 2003
Location: Hinsdale/Chicago, IL, USA
Distribution: Slackware 10 (2.6.8.1)
Posts: 43

Rep: Reputation: 15
Help w/ GATOS ATI Drivers


(EE) RADEON(0): [dri] RADEONDRIScreenInit failed because of a version mismatch.
[dri] radeon.o kernel module version is 1.7.0 but version 1.100.0 or newer is needed.
[dri] Disabling DRI

ah Linux confuses the hell out of me, anyway I tried installing the new ATI drivers modules from the GATOS project and I keep getting this in the x.log...I've been trying to enable DRI and it just won't enable...and I don't know if I'm installing the modules correctly, please help
 
Old 04-26-2003, 08:42 PM   #2
UnTamed
Member
 
Registered: Dec 2002
Location: Qc, Canada
Distribution: CRUX
Posts: 317

Rep: Reputation: 30
You need the matching drm kernel module.
Check here you'll notice the ATI.2 driver files [...for XFree-4.3.0] are paired with a drm-kernel-1.100.0.x.tar.gz.
You should see the driver you already installed, d/l and install the matching drm-kernel.
 
Old 04-27-2003, 02:46 AM   #3
Techweenie1
Member
 
Registered: Feb 2003
Location: Hinsdale/Chicago, IL, USA
Distribution: Slackware 10 (2.6.8.1)
Posts: 43

Original Poster
Rep: Reputation: 15
Ok I believe I was able to install the modules correctly, including the DRM Kernel Module...when I do a dump to x.log this is what I get now:

XFree86 Version 4.3.0
Release Date: 27 February 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.20 i686 [ELF]
Build Date: 01 March 2003
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sat Apr 26 20:57:29 2003
(==) Using config file: "/etc/X11/XF86Config"
startkde: Starting up...
mcop warning: user defined signal handler found for SIG_PIPE, overriding
mcop warning: user defined signal handler found for SIG_PIPE, overriding
SwitchToMode - scrn: 0 clock: 36000
hdsp: 640 hbeg: 696 hend: 752 httl: 832
vdsp: 480 vbeg: 481 vend: 484 vttl: 509 flags: 10
Checking against clock: 65000 (65000)
hdsp: 1024 hbeg: 1048 hend: 1184 httl: 1344
vdsp: 768 vbeg: 771 vend: 777 vttl: 806 flags: 10
Checking against clock: 49500 (49500)
hdsp: 800 hbeg: 816 hend: 896 httl: 1056
vdsp: 600 vbeg: 601 vend: 604 vttl: 625 flags: 5
Checking against clock: 36000 (36000)
hdsp: 640 hbeg: 696 hend: 752 httl: 832
vdsp: 480 vbeg: 481 vend: 484 vttl: 509 flags: 10
SwitchToMode - Succeeded
SwitchToMode - scrn: 0 clock: 65000
hdsp: 1024 hbeg: 1048 hend: 1184 httl: 1344
vdsp: 768 vbeg: 771 vend: 777 vttl: 806 flags: 10
Checking against clock: 65000 (65000)
hdsp: 1024 hbeg: 1048 hend: 1184 httl: 1344
vdsp: 768 vbeg: 771 vend: 777 vttl: 806 flags: 10
SwitchToMode - Succeeded
kwin: X_SetInputFocus(0x1e00003): BadMatch (invalid parameter attributes)

however according to glxinfo:

name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 1 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x24 24 tc 1 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x25 24 tc 1 24 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x26 24 tc 1 24 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x27 24 dc 1 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x28 24 dc 1 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x29 24 dc 1 24 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x2a 24 dc 1 24 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None

it still says "direct rendering: No" what's going on?
Btw if it helps any I have a ATI Radeon 8500 DV All-In-Wonder

Oh and also this is a clipping from the XF86Config, in which I do enable DRI

Section "Module"

# This loads the DBE extension module.

Load "dbe" # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
#Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection

# This loads the font modules
Load "type1"
Load "freetype"
Load "speedo"

# This loads the GLX module
Load "glx"

# This loads the DRI module
Load "dri"

EndSection

# Enable DRI for all users
Section "DRI"
mode 0666
EndSection

Last edited by Techweenie1; 04-27-2003 at 02:50 AM.
 
Old 04-27-2003, 06:12 PM   #4
Techweenie1
Member
 
Registered: Feb 2003
Location: Hinsdale/Chicago, IL, USA
Distribution: Slackware 10 (2.6.8.1)
Posts: 43

Original Poster
Rep: Reputation: 15
OK got it working had to recompile the kernel without DRM support. Apparently the Kernel only provides DRM 1.1.1 not 1.3...so recompiled without DRM installed the modules manually and vola it works! heh, however now when I boot into my new kernel the VGA=791 won't work...did I miss something when I recompiled?
 
Old 04-27-2003, 06:43 PM   #5
Techweenie1
Member
 
Registered: Feb 2003
Location: Hinsdale/Chicago, IL, USA
Distribution: Slackware 10 (2.6.8.1)
Posts: 43

Original Poster
Rep: Reputation: 15
one more thing I'm noticing that the GL screen savers now aren't as smooth looking as they once were...now there seems to be a flickering effect, is this a trade off of enabling DRI?
 
Old 04-27-2003, 07:33 PM   #6
UnTamed
Member
 
Registered: Dec 2002
Location: Qc, Canada
Distribution: CRUX
Posts: 317

Rep: Reputation: 30
>VGA=791 won't work...did I miss something when I recompiled?

There's "Video mode selection support" in the "Console drivers" section, which translates to CONFIG_VIDEO_SELECT=y in your /usr/src/linux-<version>/.config.

>is this a trade off of enabling DRI?

I doubt it, but it may very well be a trade off of using Gatos'...
 
Old 04-16-2004, 09:48 PM   #7
BlinDlucK
LQ Newbie
 
Registered: Sep 2003
Location: New York
Distribution: Whatever I can get my hands on, usually Knoppix.
Posts: 7

Rep: Reputation: 0
flickering

9800XT
Mandy 10


yea sometimes they'll flicker a little bit, shouldn't be anything too bad, mine do a little.


Oh and i also have an 8500 DV and im seriously considering slapping ohhh slackware or something on here. Is it hard to install gatos drivers? Thank you in advance
 
Old 04-19-2004, 06:25 PM   #8
Damoek
Member
 
Registered: Mar 2004
Location: Us
Distribution: Ubuntu Dapper
Posts: 74

Rep: Reputation: 15
i just started trying to do this GATOS project, i installed the Xfree86 version 4.1.0 and my server crashed... No love, so i backed up the folders /usr/X11 and /usr/X11R86 then it started to go into x with startx and then my monitor gives an out of range error... can i fix this with failsafe settings? or am i screwed? also why do i need v 4.1.0 of Xfree? Please help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help With Gatos (ATI TV Output) sammykrupa Linux - Software 2 06-18-2005 01:47 AM
ATI Rage 128 (Gatos Driver) HELP!! gfem Linux - General 2 12-30-2003 02:07 AM
mythtv ATI AIW 128 (GATOS) mwmethe Linux - Hardware 2 10-25-2003 06:44 PM
ATI M7 3d acceeration issues, Gatos drivers? bax Linux - Laptop and Netbook 2 08-23-2003 06:45 PM
Gatos Drivers PrimaryDataLoop Linux - Hardware 4 07-10-2003 02:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration