LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-27-2005, 09:37 AM   #1
gustavderdrache
LQ Newbie
 
Registered: Mar 2005
Distribution: Slackware 10.1
Posts: 15

Rep: Reputation: 0
Getting sound (with ALSA) to work with Slackware 10.1


Help! I've been trying to get any sound of my box for a few days, now...

I've been reading various things online, trying to get it work... alsaconf says i have a via8233 card and sets it up, but nothing plays even when i set all the volume in alsamixer to 100%. Where do I go next?
 
Old 03-27-2005, 10:05 AM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
What are you trying to play,a cd a mp3 or you using xmms,etc.
 
Old 03-27-2005, 10:07 AM   #3
gustavderdrache
LQ Newbie
 
Registered: Mar 2005
Distribution: Slackware 10.1
Posts: 15

Original Poster
Rep: Reputation: 0
Right now, i'm just trying to play an mp3 file I made on my other computer, just to get sound working. I ran it through aplay, noatun, and Kaboodle. No sound came from any of them....
 
Old 03-27-2005, 10:11 AM   #4
futhark
Member
 
Registered: Nov 2003
Location: Montréal (Can)
Distribution: FC4
Posts: 110

Rep: Reputation: 15
What exactly are the symptoms of "this thing does not work"?

In FC3 I have struggled quite a bit with Alsa. After I selected this output in XMMS, I could play files but I wouldn't hear anything. Sound would kick in after an alsactl restore. Eventually I have found the real solution was to disable the sound server in KDE (odd?).

Good luck!
 
Old 03-27-2005, 10:42 AM   #5
gustavderdrache
LQ Newbie
 
Registered: Mar 2005
Distribution: Slackware 10.1
Posts: 15

Original Poster
Rep: Reputation: 0
When I say 'not working', I mean that there's no sound output despite using all the sound players I can find.

I haven't tried XMMS, I'll try that before I go into the settings again. How would I get the 'alsactl restore' you were talking about?
 
Old 03-27-2005, 01:08 PM   #6
Haiyadragon
Member
 
Registered: Sep 2003
Location: Gorredijk, Netherlands
Distribution: Arch Linux
Posts: 400

Rep: Reputation: 30
How about non-mp3 sound? Do you hear system sounds and stuff like that? Open the control center, Sound & Multimedia -> Sound System; is "Enable the sound system" checked? If so, go to the hardware tab. What audio device is selected? Try selecting "Advanced Linux Sound Architecture" (alsa).
 
Old 03-27-2005, 01:29 PM   #7
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
If you su to root, can you hear sound by cat'ing a file to >/dev/dsp? If so, make sure that you are a member of the audio group.
 
Old 03-27-2005, 02:57 PM   #8
gustavderdrache
LQ Newbie
 
Registered: Mar 2005
Distribution: Slackware 10.1
Posts: 15

Original Poster
Rep: Reputation: 0
I tried the Control Center settings, fiddled around, but nothing's worked. And then I su'd to root and tried cat'ing a text file I found in my directory:

cat lspci.txt > /dev/dsp

but no sound came out. And yeah, I've tried both a .wav and a .mp3 file, neither plays. And if the system is beeping at me, I completely missed it.
 
Old 03-27-2005, 09:26 PM   #9
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
what happens when you do as root
Code:
modprobe snd-via82xx
and do you have something like this in modules.conf
Code:
-->
alias char-major-116 snd
alias snd-card-0 snd-via82xx
# module options should go here
# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
#-->

Last edited by comprookie2000; 03-27-2005 at 09:29 PM.
 
Old 03-27-2005, 10:23 PM   #10
gustavderdrache
LQ Newbie
 
Registered: Mar 2005
Distribution: Slackware 10.1
Posts: 15

Original Poster
Rep: Reputation: 0
Here's my modules.conf file, the whole thing:

Code:
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.8 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-via82xx
alias sound-slot-0 snd-via82xx
# --- END: Generated by ALSACONF, do not edit.---
I ran modprobe snd-via82xx and got nothing. I tried playing some sound files and didn't get any sound played, so I'm guessing that something is still wrong.
 
Old 03-28-2005, 09:38 AM   #11
futhark
Member
 
Registered: Nov 2003
Location: Montréal (Can)
Distribution: FC4
Posts: 110

Rep: Reputation: 15
Oh BTW I was wrong saying I had disabled the sound server in KDE. It is in KMIX I had disabled the "restore settings on startup" option. I don't know why but KMIX was messing up my mixer settings.

I was asking what were the exact symptoms because I experienced two myself:
- Permission denied to sound devices. Leads to pretty specific error popups in apps. Fixed by changing permissions.
- XMMS actually playing the songs, but no sound output is generated. Was a mixer problem.

Someone suggested to have a look at /dev/dsp. ALSA devices are actually in /dev/snd. You may want to check if you have appropriate permissions on these , eg 666. In Fedora3 they've added support for udev. This udev thing is responsible of setting default permissions on devices. You may want to see if you have /etc/udev/permissions.d/50-udev.permissions in SUSE.

"alsactl" is an utility bundled with ALSA. It's to restore or save settings into the config file. If you run "alsactl restore" as root it'll restore the mixer settings. You may want to try the following in text mode (init 3) before and after using alsactl:
locate .wav
aplay somewav
 
Old 03-28-2005, 10:04 AM   #12
gustavderdrache
LQ Newbie
 
Registered: Mar 2005
Distribution: Slackware 10.1
Posts: 15

Original Poster
Rep: Reputation: 0
My problem is that nothing's playing, I set the permissions of /dev/snd to 0666 and I'm still not getting any sound. XMMS will play my song (but give me a message about its shared library), but no sound comes out. Same with aplay, Kaboodle, and Noatun. I'm stumped at this point, folks.
 
Old 03-28-2005, 01:24 PM   #13
DeusExLinux
Member
 
Registered: May 2004
Location: Tampa, Fl
Distribution: Arch
Posts: 648

Rep: Reputation: 30
this is going to sound really dumb, but here goes (it stumped me for a bit cause it was so obvious)

When you run alsamixer, your sound levels might be up all the way, but are they unmuted? (if so, press m when highlighting master,pcm, and whatever other ones you want to unmute....)
 
Old 03-28-2005, 03:53 PM   #14
gustavderdrache
LQ Newbie
 
Registered: Mar 2005
Distribution: Slackware 10.1
Posts: 15

Original Poster
Rep: Reputation: 0
Heh, yeah, I've been through alsamixer a few times and I believe that the master volume is unmuted. Ah, well, it was a good suggestion.
 
Old 03-28-2005, 04:18 PM   #15
gustavderdrache
LQ Newbie
 
Registered: Mar 2005
Distribution: Slackware 10.1
Posts: 15

Original Poster
Rep: Reputation: 0
aha!

Well, I just booted up the KDE and got a message from artsmessage that it couldn't open the sound driver because it didn't have proper permission. Now what do I do?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting two sound cards to work with ALSA linuxpyro Linux - Hardware 3 08-24-2005 09:25 PM
alsa appears to work, but no sound JackSmith Linux - Hardware 15 05-21-2005 01:26 AM
getting flash sound to work with ALSA YetAnotherDave LinuxQuestions.org Member Success Stories 0 02-19-2005 08:54 AM
Sound in Slackware 9.1 with ALSA doesnt work? Bauernkilla Slackware 5 09-20-2004 11:41 PM
Slackware 9.1 + ALSA = no sound vvv Slackware 3 12-07-2003 03:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration