LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-22-2018, 01:34 PM   #1
Cofyka
LQ Newbie
 
Registered: Jul 2018
Posts: 1

Rep: Reputation: Disabled
Unhappy From Windows to Ubuntu and I can't write to second driver.


I've been using Windows for almost my whole life and now I switched to Ubuntu because of its flexibility. I have 2 drives, one is for OS and the second where all my work is and important files. But here is the problem, in Ubuntu the second drives doesn't work properly I think. I can't create any new folders and if I try to change permissions from 'create and delete files' to 'access files' the message pops up saying "Sorry, could not change the permissions of 'New Volume":Error setting permissions: Read-only file system".
I came up to this problem when I tried to load an old android project with the android studio, the IDE said it doesn't have permission to access the file . Maybe all this is because of my poor knowledge of permissions, idk. Any help would be great ! Thanks.

Last edited by Cofyka; 07-23-2018 at 10:43 AM.
 
Old 07-22-2018, 01:55 PM   #2
jsbjsb001
Senior Member
 
Registered: Mar 2009
Location: Earth? I would say I hope so but I'm not so sure about that... I could just be a figment of your imagination too.
Distribution: CentOS at the time of this writing, but some others over the years too...
Posts: 1,968

Rep: Reputation: 892Reputation: 892Reputation: 892Reputation: 892Reputation: 892Reputation: 892Reputation: 892
You'll need to mount it read-write, or you will not be able to change permissions or write to it.
 
Old 07-22-2018, 02:42 PM   #3
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,479

Rep: Reputation: 994Reputation: 994Reputation: 994Reputation: 994Reputation: 994Reputation: 994Reputation: 994Reputation: 994
Your data drive might be NTFS format, which Linux mounts read-only by default. You can remount it like so:
Code:
mount -o remount rw /dev/sdb1
where sdb1 is the device file for the drive. It might be different. You can type 'mount' to see all the mount points and figure out which is the correct drive.
 
Old 07-22-2018, 06:09 PM   #4
ArazelEternal
Member
 
Registered: Apr 2018
Location: South Central Wisconsin, USA
Distribution: Fedora 28 Workstation - Cinnamon Desktop Spin
Posts: 46

Rep: Reputation: Disabled
Quote:
Originally Posted by AwesomeMachine View Post
Your data drive might be NTFS format, which Linux mounts read-only by default. You can remount it like so:
Code:
mount -o remount rw /dev/sdb1
where sdb1 is the device file for the drive. It might be different. You can type 'mount' to see all the mount points and figure out which is the correct drive.
Every Linux distro I have used mounts ntfs as read/write. Ive used CentOS, RHEL, OpenSUSE, Oracle, Fedora. Maybe Ubuntu is different, but every distro Ive used mounts ntfs as read/write by default. Anyway, follow the advice given here as it does sound like its mounted as read-only which I find a little odd. However I am still fairly new to linux.
 
Old 07-22-2018, 06:26 PM   #5
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 8,061

Rep: Reputation: 1597Reputation: 1597Reputation: 1597Reputation: 1597Reputation: 1597Reputation: 1597Reputation: 1597Reputation: 1597Reputation: 1597Reputation: 1597Reputation: 1597
Ubuntu and other Linux systems are designed as multi-user systems so the default is to allow any normal user read-write access only to the /home/user directory and sub-directories so if you are logged in as a user, that is expected behavior. You need to do some reading on using sudo in Ubuntu to give yourself permissions and/or change ownership. See the link below. Also the type of filesystem you are using will make a difference.

https://help.ubuntu.com/community/RootSudo?
 
Old 07-22-2018, 10:04 PM   #6
mrmazda
Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 652

Rep: Reputation: 185Reputation: 185
NTFS is a proprietary filesystem format whose performance suffers in diverse ways when used in Linux. Long term you should probably make plans to either backup the data on that disk, reformat it with a native Linux format (e.g. EXT4 or XFS), then restore the data, or, get another disk to use instead, and convert the old one to use as a backup device.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
windows driver for read/write ext3 partitions friendship7 General 4 01-04-2012 02:40 PM
[SOLVED] How to find, identify, write to or load a driver from CD ROM to LINUX UBUNTU 11.04 Fromthebronx Linux - Newbie 41 08-22-2011 10:58 PM
Ubuntu 8.04 in windows network cannot get write access for all samba shares cliffsur Linux - Newbie 6 09-18-2008 12:29 PM
Windows driver to read/write Linux file system bmccurdy General 3 08-23-2004 05:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration