Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 01-21-2005, 10:52 AM   #1
LQ Newbie
Registered: Jan 2005
Location: Pittsburgh
Posts: 2

Rep: Reputation: 0
Fedora Core 3, kernel headers, DRI

A problem with my video card has led me to a problem with (lacking) Fedora kernel header files.

I will briefly outline my video card issue for some background: I start out at 800x600 resolution, which I personally can't stand. But when I bump my settings up to 1600x1200 and restart, my monitor displays a "signal out of range" error and nothing else (I had to login without X and restore the previous config manually just to be able to see my desktop again.) I decide the best way to remedy this is to update my video card drivers. Here is the Intel support doc that describes this process:

You'll notice one of the requirements is "kernel header files installed," which of course they aren't. Thanks to another thread and the Fedora release notes, I learn that "In order to eliminate the redundancy inherent in providing a separate package for the kernel source code when that source code already exists in the kernel's .src.rpm file, Fedora Core 3 no longer includes the kernel-source package."


So I go get a kernel .src.rpm from

and follow the steps laid out in the release notes, although I didn't fully understand what was going on after step 3 (rpmbuild). Still...

[atg@atgtest ~]$ rpm -a |grep kernel-source
[atg@atgtest ~]$

And of course the installer chokes because it can't find the package...

[root@atgtest dripkg]# ./

Compiling new agpgart module...
Compiling DRM module...

ERROR: Kernel modules did not compile

The DRI drivers can not be installed without the latest kernel modules.
Installation will be aborted. See the dri.log file for information on
what went wrong.

[root@atgtest dripkg]# cat dri.log
make: *** No rule to make target `gdg.ko'.  Stop.
So my questions are, how do I know if I built the source tree successfully? And do I have to register the kernel-source package somehow so the DRI installer will know that it's there? Has anyone encountered this video signal issue before and is there an easier resolution that I've totally missed? I routinely find answers from this site but this is the first time I have been compelled to ask a question as I am really at a dead end. Thanks in advance.

(Sorry, this is my first post and I can't post URLs)
Old 01-21-2005, 11:43 AM   #2
Registered: Jul 2004
Location: Czech Republic - Roudnice nad Labem
Distribution: Debian
Posts: 253

Rep: Reputation: 34
Kernel headers are in Feodra Core 3 at this place /lib/modules/2.6.10-1.741_FC3/source/include
Old 01-21-2005, 11:46 AM   #3
LQ Newbie
Registered: Jan 2005
Location: Pittsburgh
Posts: 2

Original Poster
Rep: Reputation: 0
OK, but how do I get the driver installer to understand this?
Old 02-02-2005, 09:37 AM   #4
LQ Newbie
Registered: Oct 2003
Posts: 1

Rep: Reputation: 0
Your makefile should supply the include directory to use via the -I parameter. I use a
symlink at /usr/src/linux that points to the correct /lib/modules/... directory.
Here's my Makefile:

# Include directory to point to kernel include
INCLUDE = /usr/src/linux/include
# /usr/src/linux -> /lib/modules/2.6.10-1.741_FC3/build/include

# Compiler
CC = gcc

# Compiler flags.

TARGET = pcifinder.o

OBJS = pcifinder.o

all: $(OBJS)

pcifinder.o: pcifinder.cIn file included from /usr/src/linux/include/linux/config.h:4,
from /usr/src/linux/include/linux/fs.h:9,
from pcifinder.c:45:
/usr/include/linux/autoconf.h:1:2: #error Invalid kernel header included in userspace
In file included from /usr/src/linux/include/linux/fs.h:10,
from pcifinder.c:45:

@rm -f *.o

I actually have my own question. Everything appears to be setup correctly but gcc complains
in a few ways. A couple of the relavant error messages (out of many are:

1. #error Invalid kernel header included in userspace
2. /usr/src/linux/include/linux/linkage.h:5:25: asm/linkage.h: No such file or directory

I am building a kernel module (-D__KERNEL__ -DMODULE) so I don't understand the first message. Also, linkage.h does in fact exist at <asm/linkage.h> so again, this is a mystery. My guess is that gcc is using some other include directory and it is not being initialized correctly to build a kernel module. This exact same Makefile worked fine under kernel 2.4 however. Any ideas?

Steve Q.
ALT Software Inc.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel for fedora core 3 scripttron75 Linux - Software 3 10-21-2005 05:25 PM
dri fedora Core 4 yaBoy Fedora 2 06-24-2005 01:05 PM
Fedora Core 3 and kernel 2.4.21 gabrieldimitriu Fedora 1 04-01-2005 01:34 AM
How to install cvs DRI snapshot in Fedora core 1 sirius57 Fedora 0 11-30-2004 09:02 PM
Fedora Core 1 with 2.6.x kernel Memzback Fedora 14 05-18-2004 01:12 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:42 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration