LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-16-2004, 09:34 AM   #1
littleg
LQ Newbie
 
Registered: Dec 2004
Posts: 10

Rep: Reputation: Disabled
Dual boot no longer offers Linux option.


Ok I have (had) RH9 and XP Pro dual booting.

I partitioned the drives with Partition Magic and was intending to use BootMagic for the loader.

After I installed the Linux I started getting the Linux boot screen with RED HAT and DOS as options. This worked great!

I thought I was finished with the BootMagic program because its screen did not come up when the PC started only the Linux screen.

I uninstalled the BootMagic program.

Bad.
Bad.
Stupid.

Now I don't get the Linux screen and Windows boots as it did before the dual boot setup.

What should I do? I someone has ideas or the links to some help I would appreciate it.

In a pickle here. I really liked the Linux and want to keep using it.
 
Old 12-16-2004, 09:49 AM   #2
junme
Member
 
Registered: Oct 2004
Location: ~/.au
Distribution: Mepis Kanotix SUSE
Posts: 189

Rep: Reputation: 31
just install again this time make a boot disk or if you did us it
i am presuming u put your bootloder in the mbr
if your bootloder (grub lilo) is in your / partion then your *.* boot loader program should pick it up
 
Old 12-16-2004, 09:59 AM   #3
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 52
boot from linux cd and use rescue mode
Your linux partition will be mounted under /mnt/sysimage
or something like that.

do
Code:
chroot /mnt/sysimage
if you use grub try:
Quote:
grub-install /dev/hda
if you use lilo make sure there is a line
on /etc/lilo.conf with something like:
boot=/dev/hda
and type:
Quote:
lilo
.hda=primary master
if your hard disk you boot from is not
primary master then you need
hdb,hdc or hdd.

Before you try all this better just try to upgrate your system from the cd.
It may give you an option to install the boot loader
 
Old 12-16-2004, 10:02 AM   #4
littleg
LQ Newbie
 
Registered: Dec 2004
Posts: 10

Original Poster
Rep: Reputation: Disabled
How do I know which is grub and which is lilo?
 
Old 12-16-2004, 10:04 AM   #5
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 52
I dual boot and my lilo.conf looks like:
Code:
prompt
timeout=50
default=linux
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
lba32
                                                                                
image=/boot/vmlinuz-2.6.5-1.358
        label=linux
        initrd=/boot/initrd-2.6.5-1.358.img
        read-only
        append="rhgb quiet root=LABEL=/"
                                                                                
other=/dev/hda1
        optional
        label=Other
my grub.conf looks like:
Code:
default=1
timeout=10
splashimage=(hd0,6)/grub/splash.xpm.gz
title Fedora Core (2.6.5-1.358)
        root (hd0,6)
        kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/ quiet
        initrd /initrd-2.6.5-1.358.img
title Windows XP
        rootnoverify (hd0,0)
        chainloader +1
 
Old 12-16-2004, 10:21 AM   #6
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 52
i think rh9 use grub by default.
you probably have both, but im not sure.

If you have a /boot/grub/grub.conf (in your actual linux partition, after you do the chroot thing)
and a /etc/lilo.conf.anacoda u use grub.
if you just have /etc/lilo.conf you use lilo.

try first the upgrade thing, it should work, if you are afraid to install the bootloader manually.

A piece of advice:
DO NOT use partition magic to create your linux partitions.
better use it to resize windows partitions or delete a partition.
leave the space you want to use for linux unallocated, and let linux
create its own partitions.
Nowdays linux creates 3 partitions:
/ (the main partition)
/boot (a very small partition)
and the swap partition.

Last edited by perfect_circle; 12-16-2004 at 10:24 AM.
 
Old 12-16-2004, 10:28 AM   #7
littleg
LQ Newbie
 
Registered: Dec 2004
Posts: 10

Original Poster
Rep: Reputation: Disabled
perfect_circle

Would it be better if I unallocated that space and started over. It is mostly a learning venture for me anyway. That said, I don't want to do it if the improvement is maginal at best. I don't think the swap thing is properly set up btw.
 
Old 12-16-2004, 11:01 AM   #8
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 52
Well, thats up to u. I just offer you a solution.
the swap partition should be 2 times your ram.
I 've got 256MB Ram so my swap partition is half a GB.
If I had 1GB RAM i wouldn't create a swap partition at all, but
thats an other story.

It may be better to reinstall linux if you think so,
and let linux do the partitioning.
It's up to u.
 
Old 12-16-2004, 03:32 PM   #9
bconsilvio
LQ Newbie
 
Registered: Nov 2004
Distribution: Ubuntu-64 on AMD64 WD160GB SATA, WIN2K on Maxtor IDE, 1 GB Mem
Posts: 8

Rep: Reputation: 0
Angry Dual boot FC3 and W2K on AMD64

Help requested to get dual boot working. I think I hosed the MBR, and can't seem to fix it. Hope this is the right thread.

Brief History: 1. New PC, Installed FC3 64 version, works fine. No want Windows no more. Happy, happy.
2. Realized I needed W2K also, after all. My wife's W2K laptop starts going flakey. Need a backup for it.
3. Try to load W2K, but it fails. Thought I did the fdisk right, but....
4. Web folks suggest loading windows first, then partition for linux. Sounds good. Wipe out FC3, and try Win2k again.
5. Fdisk and format 16gb C: drive, plus 2 other 30GB partitions. Fdisk/status looks ok, but W2K install still fails. do fdisk/mbr, W2k still fails to load. Knoppix boots fine from CD, and shows the 3 partitions also.
6. On boot Grub starts, but hangs with blinking cursor. FC3 will not re-install, either.
Now what? Are there commands in Knoppix I can use to fix the hard drive so that the installs work?
 
Old 12-16-2004, 09:18 PM   #10
junme
Member
 
Registered: Oct 2004
Location: ~/.au
Distribution: Mepis Kanotix SUSE
Posts: 189

Rep: Reputation: 31
bconsilvio have you set the first win partition active ?
 
Old 12-17-2004, 12:15 AM   #11
bconsilvio
LQ Newbie
 
Registered: Nov 2004
Distribution: Ubuntu-64 on AMD64 WD160GB SATA, WIN2K on Maxtor IDE, 1 GB Mem
Posts: 8

Rep: Reputation: 0
Exclamation

I dont know if its active or not. How do I tell, and what command makes it active?

(and thanks for answering yet another newbie question)
 
Old 12-17-2004, 03:59 AM   #12
junme
Member
 
Registered: Oct 2004
Location: ~/.au
Distribution: Mepis Kanotix SUSE
Posts: 189

Rep: Reputation: 31
in fdisk type p
should look like this

Device Boot Start End Blocks Id System
/dev/hda1 * 1 38776 19543041 c W95 FAT32 (LBA)
note the star *

to set active in fdisk > a

Last edited by junme; 12-17-2004 at 04:13 AM.
 
Old 12-17-2004, 08:48 AM   #13
bconsilvio
LQ Newbie
 
Registered: Nov 2004
Distribution: Ubuntu-64 on AMD64 WD160GB SATA, WIN2K on Maxtor IDE, 1 GB Mem
Posts: 8

Rep: Reputation: 0
Thanks. Do you mean Fdisk in Linux?

I'm booting with DOS (ME) . Fdisk/Status looks different but apparantly equivalent.
I found MBRtool on the web and set the C: dirve active. tried W2K again, still runs thru the 4 floppy startup OK, and stops on the CD, Cant find a HD. MBRtool display shows first partition as ACT = 128 (base 10) , TYPE= 0C, start C/H/S = 0-1-1, END= 921-254-63. LBA start = 63 Extended parttion begins at 922, as it should, TYPE=0F. What are the TYPE codes? The C: partition correct?
 
Old 12-17-2004, 09:24 PM   #14
junme
Member
 
Registered: Oct 2004
Location: ~/.au
Distribution: Mepis Kanotix SUSE
Posts: 189

Rep: Reputation: 31
use one or the other this is where you will run into trouble

"The easiest way to wipe your MBR and partition table on a Linux box is with a command like:

dd if=/dev/zero of=/dev/hda count=1 bs=512 && sync && echo done.

... if you see it echo "done" then you have successfully wiped the partition table and MBR on your first IDE drive. (Use /dev/sda to blow away your first SCSI drive). "

cfdisk may be easier for u
 
Old 12-17-2004, 10:55 PM   #15
bconsilvio
LQ Newbie
 
Registered: Nov 2004
Distribution: Ubuntu-64 on AMD64 WD160GB SATA, WIN2K on Maxtor IDE, 1 GB Mem
Posts: 8

Rep: Reputation: 0
Thanks, Sorry if I seem dense. Isnt cfdisk part of linux? I dont have linux installed anymore. Nothing's installed.

All I can get to boot is MSDOS (ME) from floppy, or Knoppix from CD. In dos, I can use fdsik and format and MBRtool. The ltter is very dangerous and powerful, but was able to make the C partition active. not that it helped. When I try to install Fedora C3, it runs though the first several screens and then quits because there is no linux partition.

How do I add a Linus partition to the 3 I have? Can I use the DOS tools to do it? Not Fdisk, but perhaps MBRtools?

Assuming I can find cfisk on knoppix terminal window, what should I do with it to fix the hard drive?

Should I just wipe all the partitions I have and start over with no partitonns at all??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu no longer a boot option after installing Fedora Cinematography Linux - Distributions 3 07-19-2005 05:32 PM
Dual Boot : Making Windows First Option in boot menu Maxwell Rain Linux - Software 3 11-27-2004 04:00 PM
Dual Boot Option mikeCanada Linux - Newbie 3 10-20-2004 11:40 PM
Dual Boot option with Linux and Windows XP kuyalfinator General 11 01-16-2004 02:24 AM
Dual boot no longer works z.zar Linux - General 6 08-20-2003 07:02 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration