LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-27-2004, 09:06 PM   #16
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47

You should have checked the HCL here at LQ. You seem to be using the wrong module.

http://www.linuxquestions.org/hcl/sh...php?product=54
 
Old 02-28-2004, 07:24 AM   #17
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
I was in a hurry before. This could possibly solve the problem.

Quote:
/etc/modules.conf
alias eth0 8139too
alias usb-controller usb-ohci
alias usb-controller1 ehci-hcd
alias souund-slot-emu10k1
That should look like this:
/etc/modules.conf
alias eth0 3c59x
alias usb-controller usb-ohci
alias usb-controller1 ehci-hcd
alias souund-slot-emu10k1
 
Old 02-29-2004, 11:12 AM   #18
ScooterB
Member
 
Registered: Sep 2003
Location: NW Arkansas
Distribution: Linux Redhat 9.0, Fedora Core 2,Debian 3.0, Win 2K, Win95, Win98, WinXp Pro
Posts: 344

Rep: Reputation: 31
Check for IRQ conflicts with your NIC.
 
Old 03-18-2004, 12:12 PM   #19
Guigo
LQ Newbie
 
Registered: Aug 2003
Location: Brazil
Distribution: Red Hat 9.0 / Fedora Project Core 1
Posts: 12

Rep: Reputation: 0
How can I do this: check for IRQ conflicts with NIC???
I don't know how to do it.
 
Old 03-19-2004, 09:21 AM   #20
ScooterB
Member
 
Registered: Sep 2003
Location: NW Arkansas
Distribution: Linux Redhat 9.0, Fedora Core 2,Debian 3.0, Win 2K, Win95, Win98, WinXp Pro
Posts: 344

Rep: Reputation: 31
Type "lspci -v" (no parenthesis). This should give you a list of everything including it's irq.
 
Old 04-16-2004, 07:28 PM   #21
gdelaine
LQ Newbie
 
Registered: Apr 2004
Location: Atlanta, GA
Distribution: Fedora Core 1
Posts: 1

Rep: Reputation: 0
determining ip information for eth0...failed

I have the exact same problem. The temporary fix was the following:
Boot with windows (I know, it sucks), if you have a dual boot sys, or get another PC to boot on Windows on your current connection.
open and command prompt (Start>Run>command Start>Run>cmd)
at the DOS prompt type ipconfig -all
and get all the network information including:
IP
Netmask
Gateway
DNS1
DNS2
and the name attributed to your box.
Reboot with Linux and configure your eth0 with a static device using the information you obtained. If your DHCP lease is long enough, it should work.

I am still looking for a more permanent solution, but I think it's ISP related.

G
 
Old 04-17-2004, 12:24 AM   #22
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
/etc/modules.conf
alias eth0 8139too
alias usb-controller usb-ohci
alias usb-controller1 ehci-hcd
alias souund-slot-emu10k1

This might be your problem.
I don't see an alias in there for your network card, and your system is configured to use DHCP on boot, therefore, it will always fail on boot until you add an alias for the module for your network device.

I don't know what the module is called for the Relatek network card but, this is the problem.
 
Old 04-17-2004, 12:25 AM   #23
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
EXAMPLE:

That should look like this:
/etc/modules.conf
alias eth0 3c59x
alias usb-controller usb-ohci
alias usb-controller1 ehci-hcd
alias souund-slot-emu10k1


Loads modules at boot time.
try 'lsmod' to see the currently used modules.
 
Old 05-01-2004, 07:35 AM   #24
thatbloke
LQ Newbie
 
Registered: May 2004
Distribution: Fedora Core 1
Posts: 21

Rep: Reputation: 15
I have the same problem! Only problem is, I'm not sure if I have the correct driver loaded, as I do not know what type of NIC I have... It's just some kind of Generic one bought from PC world around the end of 2001... thats about all I know! I cant get any info about it from windows, as the driver supplied just calls it a "10/100M Ethernet PCI Adapter." XP reckons its an Asound based card but whenever it tries to use that driver (not the one supplied) then it doesn't work! would I be better off getting a more well known type of card that I know has a linux driver for it???

EDIT: I forgot to mention... I'm using Red Hat 9 and it picks up the network card during install and its using the "fealnx" module/driver for it...

Last edited by thatbloke; 05-01-2004 at 08:51 AM.
 
Old 05-02-2004, 07:40 AM   #25
thatbloke
LQ Newbie
 
Registered: May 2004
Distribution: Fedora Core 1
Posts: 21

Rep: Reputation: 15
B_U_M_P
 
Old 05-13-2004, 07:49 AM   #26
prara
LQ Newbie
 
Registered: Aug 2003
Distribution: Mandriva, Ubuntu, Fedora
Posts: 24

Rep: Reputation: 15
same problem:

unable to ifconfig eth0 up
the error message is written:
SIOCSIFFLAGS: Function not implemented

I have a VIA-RHINE onboard NIC in Mandrake 10.
 
Old 06-05-2004, 04:46 PM   #27
JuanKerr
LQ Newbie
 
Registered: Jun 2004
Posts: 1

Rep: Reputation: 0
Quote:
Originally posted by thatbloke
I have the same problem! Only problem is, I'm not sure if I have the correct driver loaded, as I do not know what type of NIC I have... It's just some kind of Generic one bought from PC world around the end of 2001... thats about all I know! I cant get any info about it from windows, as the driver supplied just calls it a "10/100M Ethernet PCI Adapter." XP reckons its an Asound based card but whenever it tries to use that driver (not the one supplied) then it doesn't work! would I be better off getting a more well known type of card that I know has a linux driver for it???

EDIT: I forgot to mention... I'm using Red Hat 9 and it picks up the network card during install and its using the "fealnx" module/driver for it...

If it's the same generic PC World card as mine, it uses the Myson MDT8xx chipset, which kernels above 2.4.5 have support for.

This doesn't mean it'll work of course (though suse, mandrake and windows have no problem with it). Mine will never start on boot, something that I'm working on at the moment (hence came across this thread), however if you manually initialize it ('# ifconfig eth0 up') then activate it with 'neat' it should work. fealnx.o is the correct module for it but lord alone knows why redhat won't start it properly on its own.

I'll post more if I can get it resolved, I'm pretty new to this too.

EDIT: adding '/sbin/dhclient eth0' to my /etc/rc.d/rc.local seems to have done the trick. It's still failing on boot but seems to have an IP address from the DHCP server by the time X starts. It's unlikely to be that the DHCP server is too slow for the system (as it's not for suse or mandrake) so i can only imagine it's probably a bug in the 'fealnx' stuff. Try this though, worked for me.


Last edited by JuanKerr; 06-05-2004 at 08:02 PM.
 
Old 06-06-2004, 05:36 AM   #28
thatbloke
LQ Newbie
 
Registered: May 2004
Distribution: Fedora Core 1
Posts: 21

Rep: Reputation: 15
hi, thanks for the tips thing is, I have sorted the problem out on mine by just getting a new network card. Had another one spare which i knew linux had drivers for thanks anyway
 
Old 06-10-2004, 08:18 AM   #29
dosfreak
LQ Newbie
 
Registered: Jun 2004
Posts: 2

Rep: Reputation: 0
Smile

I had this problem with Fedora Core 2 with a 3c905b and found a message on dclug.org.uk that fixed me right up: Disable kudzu... something about the probing process screws up the NIC. Once I disabled kudzu, I was good as gold.

If you prefer the GUI, disable kudzu like this:
"Redhat menu", "system settings", "server settings", "services" and uncheck "kudzu".

If you prefer the shell, disable kudzu like this:
cd /etc/rc.d/rc5.d/
mv *kudzu K99kudzu

http://www.dclug.org.uk/archive/2003/11/msg00194.html

-Nate
 
Old 06-30-2004, 06:20 PM   #30
bobbitt
LQ Newbie
 
Registered: Mar 2003
Distribution: RedHat 9.0
Posts: 7

Rep: Reputation: 0
Make sure you have dhclient installed. Running "rpm -q dhclient" should show something like "dhclient-3.0.1rc14-1". If nothing is displayed, dhclient isn't installed, but needs to be. (Try "up2date dhclient" for that.)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Determining IP information for eth0....failed linuxnew Linux - Networking 12 05-11-2004 07:05 AM
determining ip information for eth0...failed flamah Linux - Networking 5 02-27-2004 01:18 PM
Bringing up interface eth0: determining ip information for eth0... failed ralphethomas Linux - Networking 0 01-24-2004 06:33 PM
Determining IP information for eth0: failed... rajeshdorai Linux - Networking 5 10-09-2003 10:50 PM
Determining IP information for eth0...FAILED chappy011 Linux - Networking 22 06-03-2002 12:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration