Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 05-01-2006, 03:04 PM   #1
Registered: Mar 2006
Location: Lund, Sweden
Distribution: Arch, Slack
Posts: 51

Rep: Reputation: 16
Configuring my locales in rc.conf?

It used to be good until I updated libxfixes. Then everything got messed up until I downgraded it again. However, text doesn't work as it used to. I can't see subs (at least in spanish) well because all letter with (αν) etc turns into an (#) which makes them practicly unreadable. And I still get the:
203032/Share/video/movies/scary_movie_IV$ firefox
(firefox-bin:6343): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.
when launching firefox. I tried a locale -a but there's also some bad output.
203025/Share/video/movies/scary_movie_IV$ locale -a
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
On suggestion in another thread, I've tried commenting my setting in locale.gen and running locale-gen without succes. I've also tried picking my (swedish) locales in the list without improvements. What to do? I'm using Arch.

Old 05-02-2006, 03:31 PM   #2
Senior Member
Registered: Aug 2003
Location: Houston, TX
Distribution: Arch
Posts: 1,381

Rep: Reputation: 47
Give this a try.

Edit /etc/locale.gen. Everything should be commented, except the two "sv_SE" lines and the "en_US" ones (better to keep the default). Check with 'grep -v ^# /etc/locale.gen'.
Run 'locale-gen'.
Run 'locale -a', pick what you want and copy that exact line into /etc/rc.conf.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
locales mrbabis Linux - Software 5 10-28-2005 05:24 PM
Configuring httpd.conf for CGI in Apache 2.x clinton Linux - Newbie 2 01-01-2005 02:13 AM
Trouble configuring Samba with Fedora, any advice, heres my smb.conf trekgraham Linux - Networking 7 05-03-2004 04:29 PM
Problems connecting to samba shares from w2k or XP systemafter configuring smb.conf f marvc Linux - Software 0 06-09-2003 08:12 AM
Debian 3.0 Installation Hangs at "Configuring Locales" screen tigerflag Linux - Distributions 1 11-14-2002 12:23 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:51 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration