LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-12-2003, 01:59 PM   #1
mib
Member
 
Registered: Mar 2003
Location: Canada
Distribution: RedHat 8.0 (Psyche)
Posts: 34

Rep: Reputation: 15
Question Configure ADSL Connection


How can I configure RedHat8 to use my ADSL connection? I tried all sorts of stuff to try to make it work. RH8 won't even activate it. I'm dual booting XP and RH8 (thanks to yngwin and others), and my ISP is Bell Sympatico (.ca), not to mention I have an Ethernet card hooked up to a hub, which is connected to a DSL modem, which in turn is plugged in the only phone jack in my room. Anyways, when I run "ipconfig /all" from my command prompt in XP (when connected), my settings are illustrated by the following:


C:\>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : (classified)
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : HP EN1207D-TX PCI 10/100 Fast Ethern
et Adapter
Physical Address. . . . . . . . . : (classified)
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : (classified lol)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

PPP adapter Sympatico Access Manager:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Physical Address. . . . . . . . . : (classified)
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : (classified)
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 65.93.75.216
DNS Servers . . . . . . . . . . . : 206.47.244.105
206.47.244.61

C:\>


Oh, and by the way, the protocol XP uses through this connection is PPPoE (point to point protocol over ethernet) if you already didn't know. I've expulged some information, such as the MAC/Physical Address and IP, that may be subject to abuse, not that anyone on this forum might do so... But, anyways, how can I use this information to get RH8 to even activate my connection? I don't think it detects my DSL modem (Speedstream 5200 Enet modem; came with the Sympatico kit). It, as in the Network configuration utility in RH8, also doesn't have an option to use the PPPoE protocol; only PPP for xDSL connections.

Anyone out there using a xDSL connection on Linux with a setup similar to mine [external modem, etc. (I dont think the hub matters)]? I could use some comments and advice from anyone, whether or not you're using RH8. Thanks in advance.

Last edited by mib; 07-24-2003 at 09:57 AM.
 
Old 03-12-2003, 02:09 PM   #2
loke137
Member
 
Registered: Feb 2003
Location: Brasil
Distribution: Debian Etch
Posts: 147

Rep: Reputation: 15
donwnload pppoe from www.roaringpenguin.com . It should do it if your eth card is configured
 
Old 03-12-2003, 04:00 PM   #3
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Have you tried running netconfig as root in command line? Also, maybe try redhat-config-network or something to that effect. RedHat users please correct me here.
 
Old 03-12-2003, 04:26 PM   #4
mib
Member
 
Registered: Mar 2003
Location: Canada
Distribution: RedHat 8.0 (Psyche)
Posts: 34

Original Poster
Rep: Reputation: 15
I don't know why I didnt do this before, but I went to the Sympatico site (sympatico.ca) and it had some instructions for xDSL users running Linux. I followed the instructions found at the following site:

http://www1.sympatico.ca/help/local/...inux.bell.html

Anyways, after doing everything I needed to in the instructions successfully (I think), and after I ran the "start-pppoe.txt" file in the konsole terminal, I ran the "ifconfig" command as the instructions described. I got the following:

(hold up: I'll post this part in my next message because I copied the info to a floppy and it's not showing. So I'll have to restart and boot into linux again to get that info)

Anyways, after that, I tried running Mozilla, and the connection wasn't working. BRB. Im gonna restart and get that info from Linux.
 
Old 03-12-2003, 04:58 PM   #5
mib
Member
 
Registered: Mar 2003
Location: Canada
Distribution: RedHat 8.0 (Psyche)
Posts: 34

Original Poster
Rep: Reputation: 15
Aite, I figured that you have to mount/unmount the floppy thingy before the files get copied... my bad. Anyways, here's what I typed in the konsole terminal:


[root@localhost root]# cd /usr/local/bin
[root@localhost bin]# start-pppoe.txt
[root@localhost bin]# ifconfig
eth0 Link encap:Ethernet HWaddr (classified...)
UP BROADCAST RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:3 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:276 (276.0 b) TX bytes:0 (0.0 b)
Interrupt:9 Base address:0x9000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:122 errors:0 dropped:0 overruns:0 frame:0
TX packets:122 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:8400 (8.2 Kb) TX bytes:8400 (8.2 Kb)

[root@localhost bin]#


Anyone know where the problem is in the "ifconfig" command, because, obviously, there must be because I don't see the configuration settings of the new "ppp0" device the instructions guaranteed and my connection still doesn't work (in Linux at least). Thanks in advance once again.

Last edited by mib; 03-12-2003 at 04:59 PM.
 
Old 03-13-2003, 12:03 PM   #6
mib
Member
 
Registered: Mar 2003
Location: Canada
Distribution: RedHat 8.0 (Psyche)
Posts: 34

Original Poster
Rep: Reputation: 15
Ok, I'm deciding to go with the Roaring Penguin PPPoE software... Which one should I install? I'm running RH8 and my kernel is version 2.4.1.8 (I think; its 2.4 series for sure). I meet the requirements to use it. Oh, and I already downloaded pppd 2.4 from www.samba.com or something because I don't know if I already have it or not. Roaring Penguin says, "The binary RPM's will not work on Mandrake, and probably won't work on non-Red Hat systems. Use the source for those systems," and I'm using a RH8 system. But it also says, "RP-PPPoE now includes an optional GUI setup program. (Linux only.) The GUI requires Tcl/Tk version 8.0 or higher. For screenshots, see the online manual. Note that the GUI is entirely optional and is meant for desktop users; it is inappropriate to run GUIs on firewall or gateway machines." What's up with that??? I don't want to use the GUI since I probably intend to use Apache in the near future, but all the source downloads (that will work for RH8, according to Roaring Penguin) *include* the GUI... Any advice? Thanks.
 
Old 03-13-2003, 12:09 PM   #7
mib
Member
 
Registered: Mar 2003
Location: Canada
Distribution: RedHat 8.0 (Psyche)
Posts: 34

Original Poster
Rep: Reputation: 15
NVM

Never mind... I look like an idiot... I got it now...
 
Old 03-13-2003, 03:46 PM   #8
twan
Member
 
Registered: Feb 2003
Location: Brasschaat, Antwerpen - Belgium
Distribution: Gentoo
Posts: 52

Rep: Reputation: 15
Re: NVM

Quote:
Originally posted by mib
Never mind... I look like an idiot... I got it now...
no you don't It's just so simple sometimes
 
Old 03-13-2003, 04:00 PM   #9
mib
Member
 
Registered: Mar 2003
Location: Canada
Distribution: RedHat 8.0 (Psyche)
Posts: 34

Original Poster
Rep: Reputation: 15
Smile THANKS

THANKS for the link loke137... I used Roaring Penguin's PPPoE software to use my ADSL connection. Although it took me 2 hours (seriously) to make it work, I'm happy to post this message using Linux for once. Anyways, if you have Bell Canada's Sympatico High Speed DSL Service, this is what I did. First, I downloaded Roaring Penguin's PPPoE software for my RedHat 8.0 system running a 2.4.x kernel and a pppd version of 2.4 (see http://www.roaringpenguin.com/pppoe). The software downloads I chose were:

Source gzipped tar file (includes gui):

http://www.roaringpenguin.com/pppoe/rp-pppoe-3.5.tar.gz

And I downloaded the GPG Signature file (although I don't know what it is or what it means and didn't even use it; someone want to fill me in?):

http://www.roaringpenguin.com/pppoe/...3.5.tar.gz.sig

Then, I followed the installation instructions found in the http://www.roaringpenguin.com/pppoe) page, which stated:

1. You must be logged in as "root", and if installing from source (which we are), you need a complete C development environment (compiler, make, linker, header, libraries).
2. Decide whether you want the GUI or not (go to http://www.roaringpenguin.com/pppoe to decide), then open up a terminal (or console, whatever you call it) and use the "cd" command to change your directory to the directory where you saved your downloaded tar file and type:

(if you don't want the gui);

tar xvfz rp-pppoe-3.5.tar.gz
cd rp-pppoe-3.5
./go

(if yo do want the gui);

tar xvfz rp-pppoe-3.5.tar.gz
cd rp-pppoe-3.5
./go-gui


Then, after that it should lead you through a setup. Go ahead and type whatever until you get to the end and it says you're done. Well, close the console or terminal, and then open it again (this is how I made it work). And use "cd" to go to the directory where RP-PPPoE was installed (probably, you should go to the directory where you downloaded the tar file, and then type "cd rp-pppoe-3.5") and type "adsl-setup". Your screen should look like this:


Welcome to the ADSL client setup. First, I will run some checks on
your system to make sure the PPPoE client is installed properly...

The following DSL config was found on your system:

Device: Name:
ppp0 DSLppp0

Please enter the device if you want to configure the present DSL config
(default ppp0) or enter 'n' if you want to create a new one:


Where it prompts you for the device (at the end of the text above), type in the text under the "Device" title, in this case "ppp0" and press enter. Then, your screen should look like this:


LOGIN NAME

Enter your Login Name (default b1xxxx@sympatico.ca):


Note, it might say "default b1(whatever)" without the "@sympatico.ca"... that's alright for now as we are going to address that. Since you are most likely reading this because you are a Sympatico user, type in your user account login (at the prompt) and don't forget the "@sympatico.ca" part. Press enter. Now make your screen look just like mine, meaning, answer the prompts just as I have:


INTERFACE

Enter the Ethernet interface connected to the ADSL modem
For Solaris, this is likely to be something like /dev/hme0.
For Linux, it will be ethX, where 'X' is a number.
(default eth0): eth0

Do you want the link to come up on demand, or stay up continuously?
If you want it to come up on demand, enter the idle time in seconds
after which the link should be dropped. If you want the link to
stay up permanently, enter 'no' (two letters, lower-case.)
NOTE: Demand-activated links do not interact well with dynamic IP
addresses. You may have some problems with demand-activated links.
Enter the demand value (default no): no

DNS

Please enter the IP address of your ISP's primary DNS server.
If your ISP claims that 'the server will provide dynamic DNS addresses',
enter 'server' (all lower-case) here.
If you just press enter, I will assume you know what you are
doing and not modify your DNS setup.
Enter the DNS information here: server

PASSWORD

Please enter your Password:
Please re-enter your Password:

USERCTRL

Please enter 'yes' (two letters, lower-case.) if you want to allow
normal user to start or stop DSL connection (default yes): yes

FIREWALLING

Please choose the firewall rules to use. Note that these rules are
very basic. You are strongly encouraged to use a more sophisticated
firewall setup; however, these will provide basic security. If you
are running any servers on your machine, you must choose 'NONE' and
set up firewalling yourself. Otherwise, the firewall rules will deny
access to all standard servers like Web, e-mail, ftp, etc. If you
are using SSH, the rules will block outgoing SSH connections which
allocate a privileged source port.

The firewall choices are:
0 - NONE: This script will not set any firewall rules. You are responsible
for ensuring the security of your machine. You are STRONGLY
recommended to use some kind of firewall rules.
1 - STANDALONE: Appropriate for a basic stand-alone web-surfing workstation
2 - MASQUERADE: Appropriate for a machine acting as an Internet gateway
for a LAN
Choose a type of firewall (0-2): 0

Start this connection at boot time

Do you want to start this connection at boot time?
Please enter no or yes (default no):no

** Summary of what you entered **

Ethernet Interface: eth0
User name: b1nvza29@sympatico.ca
Activate-on-demand: No
DNS addresses: Supplied by ISP's server
Firewalling: NONE
User Control: yes
Accept these settings and adjust configuration files (y/n)? y
Adjusting /etc/sysconfig/network-scripts/ifcfg-ppp0
Adjusting /etc/ppp/chap-secrets and /etc/ppp/pap-secrets
(But first backing it up to /etc/ppp/chap-secrets.bak)
(But first backing it up to /etc/ppp/pap-secrets.bak)



Congratulations, it should be all set up!

Type '/sbin/ifup ppp0' to bring up your xDSL link and '/sbin/ifdown ppp0'
to bring it down.
Type '/sbin/adsl-status /etc/sysconfig/network-scripts/ifcfg-ppp0'
to see the link status.


Note, at the password prompt, type your password, and at the firewall prompt, type whatever you wish (I typed 0 just to test the connection). Now, just like the script tells you, type "/sbin/ifup ppp0" to connect. It should look like this if it worked:


[root@localhost rp-pppoe-3.5]# /sbin/ifup ppp0
[root@localhost rp-pppoe-3.5]#


If at any time you are surfing the web and you get a DNS error or something. Go to the terminal or console, navigate to the rp-pppoe-3.5 directory and type "/sbin/adsl-status /etc/sysconfig/network-scripts/ifcfg-ppp0"; it should look like this:


[root@localhost rp-pppoe-3.5]# /sbin/adsl-status /etc/sysconfig/network-scripts/ifcfg-ppp0
Note: You have enabled demand-connection; adsl-status may be inaccurate.
adsl-status: Link is attached to ppp0, but ppp0 is down


After you probably get that message, type "/sbin/ifup ppp0" to reconnect, and it should work perfectly. At any time, if you want to disconnect, type "/sbin/ifdown ppp0". It's pretty damn obvious how this works. Although I'm a newbie, I'm pretty familiar with networking in Windows and so it was pretty easy for me, although it took 2 hours because I figured that you had to close all the terminals/consoles and text editors that were using those files (I was messing around with the pppoe.conf file to make it work) to save the changes... Stupid me. Anyways, note that this was for a Sypmatico.ca High Speed DSL connection and using the non-gui version of RP-PPPoE and I think you're going to have to open up the terminal and connect like this everytime. Oh, and here's my pppoe.conf file under the /etc/ppp/ directory, in case you have trouble connecting:


#***********************************************************************
#
# pppoe.conf
#
# Configuration file for rp-pppoe. Edit as appropriate and install in
# /etc/ppp/pppoe.conf
#
# NOTE: This file is used by the adsl-start, adsl-stop, adsl-connect and
# adsl-status shell scripts. It is *not* used in any way by the
# "pppoe" executable.
#
# Copyright (C) 2000 Roaring Penguin Software Inc.
#
# This file may be distributed under the terms of the GNU General
# Public License.
#
# LIC: GPL
# $Id: pppoe.conf,v 1.10 2002/04/09 17:28:38 dfs Exp $
#***********************************************************************

# When you configure a variable, DO NOT leave spaces around the "=" sign.

# Ethernet card connected to ADSL modem
ETH='0'

# ADSL user name. You may have to supply "@provider.com" Sympatico
# users in Canada do need to include "@sympatico.ca"
# Sympatico uses PAP authentication. Make sure /etc/ppp/pap-secrets
# contains the right username/password combination.
# For Magma, use xxyyzz@magma.ca
USER='b1xxxx@sympatico.ca'

# Bring link up on demand? Default is to leave link up all the time.
# If you want the link to come up on demand, set DEMAND to a number indicating
# the idle time after which the link is brought down.
DEMAND=no
#DEMAND=300

# DNS type: SERVER=obtain from server; SPECIFY=use DNS1 and DNS2;
# NOCHANGE=do not adjust.
DNSTYPE=SERVER

# Obtain DNS server addresses from the peer (recent versions of pppd only)
# In old config files, this used to be called USEPEERDNS. Changed to
# PEERDNS for better Red Hat compatibility
PEERDNS=yes

DNS1=
DNS2=

# Make the PPPoE connection your default route. Set to
# DEFAULTROUTE=no if you don't want this.
DEFAULTROUTE=yes

### ONLY TOUCH THE FOLLOWING SETTINGS IF YOU'RE AN EXPERT

# How long adsl-start waits for a new PPP interface to appear before
# concluding something went wrong. If you use 0, then adsl-start
# exits immediately with a successful status and does not wait for the
# link to come up. Time is in seconds.
#
# WARNING WARNING WARNING:
#
# If you are using rp-pppoe on a physically-inaccessible host, set
# CONNECT_TIMEOUT to 0. This makes SURE that the machine keeps trying
# to connect forever after adsl-start is called. Otherwise, it will
# give out after CONNECT_TIMEOUT seconds and will not attempt to
# connect again, making it impossible to reach.
CONNECT_TIMEOUT=30

# How often in seconds adsl-start polls to check if link is up
CONNECT_POLL=2

# Specific desired AC Name
ACNAME=

# Specific desired service name
SERVICENAME=

# Character to echo at each poll. Use PING="" if you don't want
# anything echoed
PING="."

# File where the adsl-connect script writes its process-ID.
# Three files are actually used:
# $PIDFILE contains PID of adsl-connect script
# $PIDFILE.pppoe contains PID of pppoe process
# $PIDFILE.pppd contains PID of pppd process
CF_BASE=`basename $CONFIG`
PIDFILE="/var/run/$CF_BASE-adsl.pid"

# Do you want to use synchronous PPP? "yes" or "no". "yes" is much
# easier on CPU usage, but may not work for you. It is safer to use
# "no", but you may want to experiment with "yes". "yes" is generally
# safe on Linux machines with the n_hdlc line discipline; unsafe on others.
SYNCHRONOUS=no

# Do you want to clamp the MSS? Here's how to decide:
# - If you have only a SINGLE computer connected to the ADSL modem, choose
# "no".
# - If you have a computer acting as a gateway for a LAN, choose "1412".
# The setting of 1412 is safe for either setup, but uses slightly more
# CPU power.
CLAMPMSS=1412
#CLAMPMSS=no

# LCP echo interval and failure count.
LCP_INTERVAL=20
LCP_FAILURE=3

# PPPOE_TIMEOUT should be about 4*LCP_INTERVAL
PPPOE_TIMEOUT=80

# Firewalling: One of NONE, STANDALONE or MASQUERADE
FIREWALL=NONE

# Linux kernel-mode plugin for pppd. If you want to try the kernel-mode
# plugin, use LINUX_PLUGIN=/etc/ppp/plugins/rp-pppoe.so
LINUX_PLUGIN=

# Any extra arguments to pass to pppoe. Normally, use a blank string
# like this:
PPPOE_EXTRA=""

# Rumour has it that "Citizen's Communications" with a 3Com
# HomeConnect ADSL Modem DualLink requires these extra options:
# PPPOE_EXTRA="-f 3c12:3c13 -S ISP"

# Any extra arguments to pass to pppd. Normally, use a blank string
# like this:
PPPD_EXTRA=""


########## DON'T CHANGE BELOW UNLESS YOU KNOW WHAT YOU ARE DOING
# If you wish to COMPLETELY overrride the pppd invocation:
# Example:
# OVERRIDE_PPPD_COMMAND="pppd call dsl"

# If you want adsl-connect to exit when connection drops:
# RETRY_ON_FAILURE=no


Note, change this doc to match your account if it already doesn't have your login name in the line where it says "USER='b1xxxx@sympatico.ca'" (change the b1xxxx part to your account). And if you change your login in this file, remember to change it in the pap-secrets and chap-secrets (don't need to modify this one if you're using Sympatico; Sympatico doesn't use chap) files found in the same directory. I hope this has been helpful to anyone who needed it. Remember, I'm only a NEWBIE to Linux, so don't critisize me if I said something wrong; it's simply how I did it. Just kindly correct me in any places where I'm wrong. Thanks again to loke137 for the link to http://www.roaringpenguin.com. I'm now enjoying using Linux to use the internet.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PF - design/configure firewall for network using ADSL connection -- please help me b:z *BSD 3 06-22-2005 01:27 AM
adsl-setup : what else to configure? xgreen Linux - Networking 4 06-13-2005 12:01 PM
How do I configure my adsl connection for network install? subaruwrx Debian 2 11-20-2004 08:09 AM
How to configure an ADSL connection with authentication? ricguitar Linux - Networking 14 09-02-2004 02:51 PM
How to configure adsl connection from downloaded driver? timberwolf Mandriva 3 12-10-2003 11:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration