LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-16-2009, 02:58 PM   #1
Xcalable
LQ Newbie
 
Registered: Sep 2009
Posts: 5

Rep: Reputation: 0
CentOS slow when network is enabled, otherwise fast


Hi

I've installed centOS and it is slow when the network is activated, terminal takes like 10-15 seconds to start, and other stuff like screen saver also takes long to open. But when I deactivate the network in centOS everything is fast, what could be the problem?

I'm running centOS in virtualbox.

Thanks
 
Old 09-17-2009, 07:55 AM   #2
bhageshp
Member
 
Registered: Sep 2008
Location: Mumbai
Distribution: Redhat
Posts: 41

Rep: Reputation: 16
Post

Check out what are the network related services which are active and trying to connect to a server/client. Also check the host system can communicate with the virtualbox client

Last edited by bhageshp; 09-17-2009 at 07:57 AM.
 
Old 09-17-2009, 09:57 AM   #3
prasanta
Member
 
Registered: Mar 2005
Location: India
Distribution: Debian
Posts: 368

Rep: Reputation: 37
Quote:
I've installed centOS and it is slow when the network is activated, terminal takes like 10-15 seconds to start, and other stuff like screen
It seems like the machine is taking too much time in getting the IP from the LAN, in case you are using DHCP.

Regards,

--
Prasanta
 
Old 09-17-2009, 03:17 PM   #4
Xcalable
LQ Newbie
 
Registered: Sep 2009
Posts: 5

Original Poster
Rep: Reputation: 0
I'm using a static ip, and the host can ping the vm, everything works, samba shares, internet etc. I have a router, it's just slow for some reason. I've read somewhere else that it could be the DNS that's taking too long, but my etc/hosts seems right, so I don't know...
 
Old 09-17-2009, 03:33 PM   #5
prasanta
Member
 
Registered: Mar 2005
Location: India
Distribution: Debian
Posts: 368

Rep: Reputation: 37
In case you are using dynamic dns, that might be a problem. This has nothing to do with /etc/resolv.conf. Try removing nsupdate in case you using dynamic dns.

Regards,

--
Prasanta
 
Old 09-17-2009, 04:00 PM   #6
Xcalable
LQ Newbie
 
Registered: Sep 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Do you mean like dyndns.com ?My router has that feature which I have configured and forwarding port 80 to centos, I have not configured centos to use dyndns, if that was what you meant.
 
Old 09-17-2009, 05:54 PM   #7
lutusp
Member
 
Registered: Sep 2009
Distribution: Fedora
Posts: 835

Rep: Reputation: 102Reputation: 102
Quote:
Originally Posted by Xcalable View Post
I'm using a static ip, and the host can ping the vm, everything works, samba shares, internet etc. I have a router, it's just slow for some reason. I've read somewhere else that it could be the DNS that's taking too long, but my etc/hosts seems right, so I don't know...
But slow DNS resolution or slow DHCP would not slow down your entire system. The cause must lie elsewhere. Try looking at the system message log:

# tail -f /var/log/messages

Now try activating the network. See what is going on.

Another trick, when a system slows down, is this:

$ top

"top" shows where the machine is spending its time, with the biggest time user at the top of the list. This should tell you why the system is slowing down.
 
Old 09-19-2009, 11:31 AM   #8
Xcalable
LQ Newbie
 
Registered: Sep 2009
Posts: 5

Original Poster
Rep: Reputation: 0
I've done

# tail -f /var/log/messages

And activating the network gives the following output:

Sep 19 19:23:12 CentOS kernel: eth0: link up, 100Mbps, full-duplex
Sep 19 19:23:14 CentOS avahi-daemon[2062]: New relevant interface eth0.IPv6 for mDNS.
Sep 19 19:23:14 CentOS avahi-daemon[2062]: Joining mDNS multicast group on interface eth0.IPv6 with address fe80::a00:27ff:fe66:ef4b.
Sep 19 19:23:14 CentOS avahi-daemon[2062]: Registering new address record for fe80::a00:27ff:fe66:ef4b on eth0.
Sep 19 19:23:16 CentOS avahi-daemon[2062]: New relevant interface eth0.IPv4 for mDNS.
Sep 19 19:23:16 CentOS avahi-daemon[2062]: Joining mDNS multicast group on interface eth0.IPv4 with address 10.0.0.101.
Sep 19 19:23:16 CentOS avahi-daemon[2062]: Registering new address record for 10.0.0.101 on eth0.

I've also looked at # top and Xorg is using the most cpu %, but it peaks at 3%, so can't be that.
 
Old 09-19-2009, 12:12 PM   #9
prasanta
Member
 
Registered: Mar 2005
Location: India
Distribution: Debian
Posts: 368

Rep: Reputation: 37
Network does not seem be the issue. Disable network during boot up and later on give a static IP and then check the performance. Is some sort of NFS, NIS running ?

Regards,

--
 
Old 09-20-2009, 08:43 AM   #10
Xcalable
LQ Newbie
 
Registered: Sep 2009
Posts: 5

Original Poster
Rep: Reputation: 0
I've disabled the network on boot up and everything is fast, enabled network and the slowness returns...

I don't have NFS/NIS running.

I've also went through all of the services disabling/enabling them one at a time, no difference. This is quite frustrating.

If this helps, it's CentOS 5.3, when I installed it I configured it for httpd, clustering and file sharing (disabled for now)

Thank you to all for trying to help, any more suggestions is welcome.
 
Old 12-29-2009, 01:55 PM   #11
cg40oz
LQ Newbie
 
Registered: Dec 2009
Location: /dev/random
Posts: 15

Rep: Reputation: 0
It may that your computer is having a issue resolving it's own hostname. Make sure your /etc/hosts has a entry for your computer.

127.0.0.1 localhost.localdomain localhost
::1 localhost6.localdomain6 localhost6
Your computers IP ComputerName.something.net computerName
 
Old 12-29-2009, 02:17 PM   #12
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,087

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
I'd try disabling IPV6 for a start.

Nobody seems to be using IPV6 yet, and IPV6 lookups (for essential things like localhost) need to time-out before IPV4 is tried. This wastes a lot of time, even if you are not using networking:

RedHat 5 & Centos 5

Edit /etc/sysconfig/network and set "NETWORKING_IPV6" to "no"

Add/Edit the following to /etc/modprobe.conf :

alias ipv6 off
alias net-pf-10 off

Edit: You'll need to restart networking, or reboot for the changes to take effect.

Last edited by tredegar; 12-29-2009 at 02:22 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tigon3 network card fast on receive, slow on send bagpussnz Linux - Networking 2 06-15-2006 03:16 PM
hdparm enabled but still slow copy props666999 Slackware 6 08-08-2005 07:54 PM
winex3 slow in voodoo 3 (dri enabled) jammers Linux - Hardware 0 07-20-2004 09:32 AM
internet fast-slow-fast-slow big_and_fat_guy Mandriva 5 10-11-2003 06:44 PM
Redhat GNOME runs slow when network is enabled gregpend Red Hat 2 10-08-2003 11:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration