LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-25-2012, 05:28 AM   #1
ust
Senior Member
 
Registered: Mar 2003
Location: fasdf
Distribution: Debian / Suse /RHEL
Posts: 1,130

Rep: Reputation: 30
Can not run old program


We use a very old database on redhat 3 before , it works fine .

We have just installed a Redhat 5 and try to run this database on it , it pop the following error .

"symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference"


I tried to set the follwoing on .bash_profile but do not work .

export LD_ASSUME_KERNEL=2.4.1
source ~/.bash_profile

the error is as below :
"error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory"


Can advise how to fix it ?

thanks.
 
Old 10-25-2012, 06:45 AM   #2
droyden
Member
 
Registered: Feb 2007
Location: UK
Posts: 150

Rep: Reputation: 19
You need to copy across those old libc libraries into a directory and use LD_LIBRARY_PATH
 
Old 10-25-2012, 11:02 AM   #3
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 19,176

Rep: Reputation: 4401Reputation: 4401Reputation: 4401Reputation: 4401Reputation: 4401Reputation: 4401Reputation: 4401Reputation: 4401Reputation: 4401Reputation: 4401Reputation: 4401
Quote:
Originally Posted by ust View Post
We use a very old database on redhat 3 before , it works fine. We have just installed a Redhat 5 and try to run this database on it , it pop the following error .
"symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference"


I tried to set the follwoing on .bash_profile but do not work .

export LD_ASSUME_KERNEL=2.4.1
source ~/.bash_profile

the error is as below :
"error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory"
Can advise how to fix it ?
Again, have you CONTACTED RED HAT SUPPORT????. You seem to be using RHEL, and this has been asked of you several times...if you're paying for RHEL, you have access to their support, and they can advise you on such things.

Also...copying libc files from one system to another is a VERY dangerous thing to do. You again provide next to no details (what KIND of database? program that's accessing it??), so it's hard to say. Best advice would be to back that database up, and import it into something current, so that you don't have these issues going forward.
 
Old 10-25-2012, 07:03 PM   #4
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,406

Rep: Reputation: 2396Reputation: 2396Reputation: 2396Reputation: 2396Reputation: 2396Reputation: 2396Reputation: 2396Reputation: 2396Reputation: 2396Reputation: 2396Reputation: 2396
Quote:
Best advice would be to back that database up, and import it into something current, so that you don't have these issues going forward.
this, seriously this..
Even if you manage to cobble something together that 'works' it won't be supported by the relevant vendor(s) and is guaranteed to be unstable sooner or later.
 
Old 10-25-2012, 11:44 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,181

Rep: Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505Reputation: 2505
contact red hat tech support
you ARE paying them for the tech support -- use it
a server license is NOT cheep - so use the support that you are paying for

have them help you migrate from an ancient rhel3
to the current RHEL


or

do not use RHEL -- it is NOT really a free OS
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help Trying to open or run a file/program through a c++ program xskycamefalling Programming 4 01-19-2010 02:26 PM
Need help Trying to open or run a file/program through a c++ program xskycamefalling Programming 2 01-18-2010 02:51 PM
Simple C++ Program: Program Compiles But Won't Run (Segmentation Fault) violagirl23 Programming 3 01-09-2008 12:09 AM
Viewing program messages when program isn't run from command line? Locura Linux - Software 1 09-27-2003 08:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration