LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-06-2004, 01:42 PM   #16
Pharcae
LQ Newbie
 
Registered: Jul 2004
Location: Finland
Distribution: Fedora core 2, Knoppix
Posts: 13

Original Poster
Rep: Reputation: 0

I just had an harddisk crash so my linux install is gone
I will post the output from /sbin/lspci as soon as i have linux up and running again.

the drivers for the older distros:
http://www.telewell.com/tuotteet/tw_...300C_linux.htm

sorry about the double-posting
 
Old 07-06-2004, 03:55 PM   #17
bruno buys
Senior Member
 
Registered: Sep 2003
Location: Rio
Distribution: Debian
Posts: 1,509

Rep: Reputation: 46
***
No, don't. Double posting is against our Rules.
***

Sorry, i didn't mean to break any rule. I meant instead of.
 
Old 07-06-2004, 04:40 PM   #18
Pharcae
LQ Newbie
 
Registered: Jul 2004
Location: Finland
Distribution: Fedora core 2, Knoppix
Posts: 13

Original Poster
Rep: Reputation: 0
Well, I got hold on a spare harddrive and I installed Red hat 9 on it as the modem is supposed to work with it. I followed the instructions that came with the driver (altough they are quite hard to understand). I ran the installscript but the modem does not seem to work.
Here is the /sbin/lspci:


Host bridge: Silicon Integrated Systems [SiS] 746 Host (rev 02)
PCI bridge: Silicon Integrated Systems [SiS] SG86C202
ISA bridge: Silicon I~tegrated Systems [SiS] SiS85C503/5513 (LPC Bridge) (rev 25)
IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (r

USB Controller: Silicon Integrated Systems [SiS]
USB 1.0 Controller (rev Of) USB Controller: Silicon Integrated Systems [SiS]
USB 1.0 Controller (rev Of) USB Controller: Silicon Integrated Systems [SiS]
USB 2.0 Controller Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (r

System peripheral: Conexant ADSL AccessRunner PCI Arbitration Device (rev 01)
ATM network controller: Conexant AccessRunner PCI ADSL Interface Device (rev 01)
VGA compatible controller: ATI Technologies Inc R350 AH [Radeon 9800]
Display controller: ATI Technologies Inc Radeon R350 [Radeon 9800] (Secondary)
 
Old 07-06-2004, 06:15 PM   #19
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 59
This is probably a better bet... someone did make a driver:

http://patrick.spacesurfer.com/linux..._pci_adsl.html

Cheers,

Finegan
 
Old 07-07-2004, 05:37 AM   #20
Pharcae
LQ Newbie
 
Registered: Jul 2004
Location: Finland
Distribution: Fedora core 2, Knoppix
Posts: 13

Original Poster
Rep: Reputation: 0
Well thanks for the link but i cant get the drivers to compile correct, i get "error 1" and "error 2", I am sure that you have to do something diffrent with red hat/fedora as there are a link on that page that should lead to "Conexant PCI ADSL modem installation guide for RedHat and Fedora systems" - too bad that the site does not contain that guide. I would post the make and make install log but it is 7 pages long, a wee bit too long to post here
 
Old 07-07-2004, 06:04 AM   #21
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 59
Most likely, you do not have your kernel source installed, its going to need that, check to see if there's anything under /usr/src, also, what comes after error[1]?

Cheers,

Finegan
 
Old 07-07-2004, 06:24 AM   #22
Pharcae
LQ Newbie
 
Registered: Jul 2004
Location: Finland
Distribution: Fedora core 2, Knoppix
Posts: 13

Original Poster
Rep: Reputation: 0
I am sure that I had the source before trying to use "make" and "make install"
i got the source off the fedora core 2 cd and it is in /usr/src/linux(versionnumber)

make[3]: *** [aread] Error 1
make[3]: Leaving directory `/home/pharcae/linux-atm-2.4.0/src/test'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/pharcae/linux-atm-2.4.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/pharcae/linux-atm-2.4.0'
make: *** [all-recursive-am] Error 2

Then it returns to the promt.
 
Old 07-07-2004, 06:57 AM   #23
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 59
Need a couple more lines up, sorry mate.

Cheers,

Finegan
 
Old 07-07-2004, 07:26 AM   #24
Pharcae
LQ Newbie
 
Registered: Jul 2004
Location: Finland
Distribution: Fedora core 2, Knoppix
Posts: 13

Original Poster
Rep: Reputation: 0
Here is a copy of the last page:

2>&1
mv -f .libs/text2ip.lo text2ip.lo
Ibin/sh ..I../libtool --mode=compile gcc -DHAVE_CONFIG-H -I. -I. -1..1..
-I..I../src/include -g -02 -Wall -Wshadow -Wpointer-arith -Wwrite-strings -Wstrict-prototypes -c timer.c
rm -f .libs/timer.lo
gcc -DHAYE-CONFIG-H -I. -I. -I. .1.. -I..I../src/include -g -02 -Wall -Wshadow -Wpointer-arith -Wwrite-strings -Wstrict-prototypes -c timer.c -fPIC -DPIC -o
.libs/timer.lo
gcc -DHAYE-CONFIG-H -I. -I. -1..1.. -I..I../src/include -g -02 -Wall -Wshadow -Wpointer-arith -Wwrite-strings -Wstrict-prototypes -c timer. c -o timer. o >/dev/null 2>&1 mv -f .libs/timer.lo timer.lo
Ibin/sh ..I../libtool --mode=compile gcc -DHAVE_CONFIG-" -I. -I. -1..1..
-I..I../src/include -g -02 -Wall -Wshadow -Wpointer-arith -Wwrite-strings -Wstrict-prototypes -c unix.c
rm -f .libs/unix.lo
gcc -DHAYE-CONFIG-H -I. -I. -I. .1.. -I. .1../src/include -g -02 -Wall -Wshadow -Wpointer-arith -Wwrite-strings -Wstrict-prototypes -c unix.c -fPIC -DPIC -o .libs/unix.lo gcc -DHAYE-CONFIG-H -I. -I. -I. .1.. -I. .1../src/include -g -02 -Wall -Wshadow -Wpointer-arith -Wwrite-strings -Wstrict-prototypes -c unix.c -o unix.o >/dev/null 2>&1
mv -f .libs/unix.lo unix.lo
Ibin/sh ..I../libtool --mode=link gcc -I..I../src/include -g -02 -Wall -Wshadow -Wpointer-arith -Wwrite-strings -Wstrict-prototypes -version-info 1:0:0 -o libatm.la -rpath lusr/lib text2atm.lo atm2text.lo atmequal.lo sdu2cell.lo text2qos.lo qos2text.lo qosequal.lo sap2text.lo text2sap.lo sapequal.lo misc.lo ans. lo common. lo diag.lo kptr.lo text2ip.lo timer.lo unix.lo -lresolv
rm -fr .libs/libatm.la .libs/libatm.* .libs/libatm.*
gcc -shared text2atm.lo atm2text.lo atmequal.lo sdu2cell.lo text2qos.lo qos2text.lo qosequal.lo sap2text.lo text2sap.lo sapequal.lo misc.lo ans. lo common. lo diag.lo kptr.lo text2ip.lo timer.lo unix.lo -lresolv -lc -WI,-soname -WI,libatm.so.1 -o
.libs/libatm.so.1.0.0
(cd .libs && rm -f libatm.so.1 && In -s libatm.so.1.0.0 libatm.so.1)
(cd .libs && rm -f libatm.so && In -s libatm.so.1.0.0 libatm.so)
ar cru .libs/libatm.a text2atm.o atm2text.o atmequal.o sdu2cell.o text2qos.o qos2text.o qosequal.o sap2text.o text2sap.o sapequal.o misc.o ans. o common. o diag.o kptr.o text2ip.o timer.o unix.o
ranlib .libs/libatm.a
creating libatm.la
(cd .libs && rm -f libatm.la && In -s ../libatm.la libatm.la)
make[3]: Leaving directory '/home/pharcae/linux-atm-2.4.0/src/lib'
Making all in test
make[3]: Entering directory '/home/pharcae/linux-atm-2.4.0/src/test'
gcc -DHAYE-CONFIG-H -I. -I. -1..1.. -I..I../src/include -g -02 -Wall -Wshadow
-Wpointer-arith -Wwrite-strings -Wstrict-prototypes -c aread.c
Ibin/sh . .1../libtool --mode=link gcc -I..I../src/include -g -02 -Wall -Wshadow -Wpointer-arith -Wwrite-strings -Wstrict-prototypes -o aread aread.o
. .1../src/lib/libatm.la
mkdir .libs
gcc -I. .1../src/include -g -02 -Wall -Wshadow -Wpointer-arith -Wwrite-strings -Wstrict-prototypes -o .libs/aread aread.o ..I../src/lib/.libs/libatm.so -lresolv ..I../src/lib/.libs/libatm.so: undefined reference to 'blli-1~use'
collect2: Id returned 1 exit status
make[3]: *** [aread] Error 1
make[3]: Leaving directory `/home/pharcae/linux-atm-2.4.0/src/test'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/pharcae/linux-atm-2.4.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/pharcae/linux-atm-2.4.0'
make: *** [all-recursive-am] Error 2
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow scp & wget transfer rate in Fedora Cora 64 joey52 Linux - Networking 17 12-27-2004 01:01 PM
Fedora Cora 64 /etc/ld.so.conf joey52 Fedora 5 12-22-2004 04:12 PM
Fedora Cora 64 Fresh RPM's joey52 Fedora 4 12-22-2004 03:52 PM
The quest for the Telewell TW-IA300C adsl pci modem driver Pharcae Linux - Hardware 2 07-06-2004 12:53 PM
Mandrake 10.0 and TeleWell IA300C Conexant ADSL PCI avis Linux - Networking 6 06-22-2004 06:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration