Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 10-03-2005, 05:07 AM   #1
LQ Newbie
Registered: Oct 2005
Posts: 4

Rep: Reputation: 0
can't connect to Internet with adsl router

I am a complete newbie. I cannot connect to the Internet under Linux using a 4-port adsl router (D-Link 504T, its internal modem handles the connection and passowrd, etc.).

It works fine under windows and has been already configured through firefox/windows calling the router IP number.

All the distro's I've tried see the eth0 port. If I set it to auto DHCP, nothing happens. When I set it to fixed IP, they all require some specification of IP address, Subnet and gateway.

I have tried some numbers that were specified in the router documentation (it says its IP address is, it also says the subnet is There is no mention of "gateway". Nothing seems to work.

Am I missing something? Is there something else that needs to be specified? Its the same problem on FC1, Ubuntu 5.04 and Mandriva LE.

Any suggestions are greatly appreciated - cheers, Buzzgrowl
Old 10-03-2005, 05:30 AM   #2
Registered: Aug 2005
Location: /home/teebones
Distribution: sometimes this, sometimes that..
Posts: 502

Rep: Reputation: 56
for the static configuration (non dhcp):

The gateway is the IP address of the modem (e.g.
The subnet is
Your IP address should be something other than .1 in the range
The DNS will be your modem IP address too.
Old 10-03-2005, 11:47 AM   #3
LQ 5k Club
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,096

Rep: Reputation: 408Reputation: 408Reputation: 408Reputation: 408Reputation: 408
Welcome to LQ. Glad you have managed to make a start!
If your modem is already set up, it should be easy to get it working with linux.
Easiest is to use DHCP:
Plug in the modem's ethernet cable.

Open a terminal.
Become root:
su -
Give your password.
Give the following commands:
ifdown eth0
Will bring the interface down, in case anything else was using it.
dhclient eth0
Should set up your connection if your modem provides a DHCP server (most seem to).

If this works, put the dhclient eth0 command at the end of the file /etc/rc.d/rc.local, and you will be connected at every boot time.
If this does not work, post the output of ifconfig eth0 for us to take a look at.

Static IP addressing is not that much more complicated, but DHCP is really easy.


Edit: Path to rc.local

Last edited by tredegar; 10-03-2005 at 11:51 AM.
Old 10-04-2005, 01:04 PM   #4
LQ Newbie
Registered: Oct 2005
Posts: 4

Original Poster
Rep: Reputation: 0
can't connect to Internet with adsl router

Dear all,
Thanks *very*! much for the advice, will try it tonight + get back tomorrow on if/how it worked.
big cheers - Buzzgrowl
Old 10-04-2005, 01:42 PM   #5
Registered: May 2005
Location: München, Germany
Distribution: Slackware, Arch
Posts: 386

Rep: Reputation: 41
Check the DNS Server numbers in the network configuration. Are they specified correctly? (Notice: I am extremely allergic to this, because they have caused my woe and frustration in the past, so it's the FIRST thing I always check when the internet isn't working). If you don't know what they should be, go back to windows and check or contact your ISP. Hope this helps..

Old 10-04-2005, 05:31 PM   #6
LQ Newbie
Registered: Oct 2005
Posts: 4

Original Poster
Rep: Reputation: 0
can't connect to Internet with adsl router

Hi Ahmed,
My ISP says that if the DNS does not resolve automatically I should try these: : : : :

I will do this tomorrow and see. Is there some reason why the router resolves ok with windows on top, but not with linux? Is this an issue at/with the ISP, or in my box?

cheers -Buzzgrowl
Old 10-04-2005, 07:28 PM   #7
Senior Member
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
If you don't use DHCP, Linux won't be able to figure out your name servers automatically, you can just add them to /etc/resolv.conf by adding the following lines to the file


Old 10-06-2005, 03:50 AM   #8
LQ Newbie
Registered: Oct 2005
Posts: 4

Original Poster
Rep: Reputation: 0
can't connect to Internet with adsl router

It works now.
Here is a rundown -

FC1 didn't work, it kept asking to delete and add NIC on reboot after changes were made and then failed to connect all the same. It could not see the router on its IP address from a browser.

Mandriva LE didn't work - It took ages to accept changes in NIC setting as well as to activate them, and then still did not see the router.

Ubuntu 5.10 for AMD64 worked (!!!) - The router was visible through the browser immediately after installation. It accepted the ISP's DNS servers when set up to a fixed IP (I chose but only after the router IP was deleted from the DNS list. It finally started working when the actual browser was set to "auto detect proxy" (instead of the default "direct connection to internet").

However Ubuntu has an issue with screen resolutions and the fix is a manual edit of the /etc/X11/xorg.conf file. As a total newbie I managed this but was very careful.

Once again, thanks to everyone here on the forum!
Old 10-06-2005, 09:49 AM   #9
LQ Newbie
Registered: Oct 2005
Posts: 1

Rep: Reputation: 0
from a newbie to other,

Once I had this problem. It was the second day of using Suse.
The day before when I installed Suse everything was fine and Internet connection was functioning correctly.

On the second day before starting my Suse, I started my Windows and find out my router (4 port DSL router) is down ... (because of some unknown reasons this happends often with my provider - german T-online) ... so I reset the router and could get internet on my windows, however, now my Suse wouldnt start networking services and as a result no Internet to surf on.

Solution: I deleted my network interface card (in Suse you can do it in Yast control center) and then added the same card with the necessery parameters for my DSL connection as I had done by first time installation of Suse ... zim-zalla-bim ... everything OK again.

Conclusion: everytime you reset your dsl router, remove and set up your network interface card to avoid such problem. (I think the reason for this is that by a router reset, dns servers information need to be renewed)


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get ADSL Modem Router from Planet to connect with Internet dtee Linux - Networking 2 01-25-2005 09:55 AM
help! setting for connect internet via ADSL router(suse 9.1) mysurface Linux - Networking 0 10-21-2004 03:00 AM
internet through adsl router dhbiker Linux - Networking 14 10-03-2004 03:26 PM
MDK9.1 can't connect to linksys router (to ADSL) A.J.Gibson Mandriva 14 01-27-2004 06:52 PM
Can't connect to internet via ADSL hawthorn2003 Mandriva 4 01-16-2004 07:30 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:33 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration