LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-06-2003, 07:18 AM   #1
dibblethewrecke
Member
 
Registered: Nov 2003
Location: UK
Distribution: Arch Linux
Posts: 210

Rep: Reputation: 30
Unhappy can't compile KDE themes mandrake 9.1 qt missing


This is really getting me down.

I'm trying to compile two KDE themes, just in case it's useful these are Plastik and Thinkeramik from kde-look.

They both need qt libraries, i get a message at the end of the compile, i think it says that my current ones are not new enough. So, being a resourceful guy i google for the error and libs, and check my mandrake rpm's for the files.

I found several that i thought it was but they all seemed unsuitable under scrutiny.

So, basically, give me an idiots guide to:

a) understanding what the hell i'm compiling!
b) how i'm doing that, i'm doing it but not really sure how, and what i need to get it to work and where i can find that and implement it on my system

please

Last edited by dibblethewrecke; 11-06-2003 at 12:59 PM.
 
Old 11-06-2003, 04:21 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,576

Rep: Reputation: 191Reputation: 191
If you're running QT that comes with MDK 9.1, it should be OK. What was the error message, exactly?

Check if you have qt-devel installed. The command is something like
rpm -qa|grep devel|grep qt
If a file qt-devel (or similar (qt3-devel will also do) is not listed, you dont have it installed. It may be the reason the themes don't compile. Install it (it's somewhere on the installation cds) and try again.
 
Old 11-10-2003, 03:05 PM   #3
dibblethewrecke
Member
 
Registered: Nov 2003
Location: UK
Distribution: Arch Linux
Posts: 210

Original Poster
Rep: Reputation: 30
Make sure that you have compiled Qt with thread support!

Sorry, had a total cock up back there! I somehow managed to uninstall all the qt libs and kde wouldn't run - gave me a bit of a scare, had no idea what went wrong, thought it was X. Tried to run kde as root, got an error that qt lib was mssing, realised it was KDE, troed to run rpmdrake, couldn't in console so guessed at

startx -icewm

it worked ! ran rpmdrake, reinstall qt stuff! Hurrah! I am learning, come on be proud of me guys, i figured that all out myself!

So, back to the original prob. All qt libs reinstalled it seems. tried your command up there, got back:

libqt3-devel-3.1.1-13mdk

Tried to compile theme again:

checking for Qt... configure: error: Qt (>= Qt 3.1.0) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

Wasn't getting the last bit about thread support before. have googled and found something about the wrong gcc complier???? That's well out of my depth i think. I don't really know what i am doing when i am compiling stuff (as i said up there) so it's a bit hard for me to understand where the process is going wrong!

Know you guys'll sort me out!
 
Old 11-10-2003, 04:21 PM   #4
Mikhail_16
Member
 
Registered: Oct 2003
Distribution: Gentoo rules them all
Posts: 279

Rep: Reputation: 31
well make sure you are running at least qt version 3.1.0 or greater. btw, qt-devel and qt should be 2 different packages. also run 'ldconfig' command as root (thats from RH, i do not exactly know what it is in mandrake). If nothing works try figuring out where qt is intalled and make sure that your system actually finds it.
 
Old 11-10-2003, 04:35 PM   #5
dibblethewrecke
Member
 
Registered: Nov 2003
Location: UK
Distribution: Arch Linux
Posts: 210

Original Poster
Rep: Reputation: 30
Quote:
well make sure you are running at least qt version 3.1.0 or greater
i'm pretty sure i confirmed that above tho i may be wrong

Quote:
Check if you have qt-devel installed. The command is something like rpm -qa|grep devel|grep qt
Quote:
tried your command up there, got back: libqt3-devel-3.1.1-13mdk
er...i think that covers it
 
Old 11-10-2003, 04:55 PM   #6
Mikhail_16
Member
 
Registered: Oct 2003
Distribution: Gentoo rules them all
Posts: 279

Rep: Reputation: 31
make sure that you have QT itself installed:

rpm -qa | grep -i 'qt'

As i said, QT and QT-devel are 2 different packages.
 
Old 11-10-2003, 06:05 PM   #7
dibblethewrecke
Member
 
Registered: Nov 2003
Location: UK
Distribution: Arch Linux
Posts: 210

Original Poster
Rep: Reputation: 30
ok, ran that one:

libqt3-3.1.1-13mdk
libqt3-devel-3.1.1-13mdk
libqt3-common-3.1.1-13mdk

how's that?

could you explain the commands i am using because i don't understand them!
 
Old 11-10-2003, 06:36 PM   #8
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,576

Rep: Reputation: 191Reputation: 191
The command "rpm -qa | grep -i 'qt'" gets all installed packages (rpm -qa does it) and shows only the ones with 'qt' string inside their names.

The result you get is 100% correct. There must be something different. First, find if you have 'libqt-mt'. The command is
locate libqt-mt
It'll list you files beginning with 'libqt-mt'. You should get something like /usr/lib/qt3/lib/libqt-mt.so.3
(more than one entry, there are many symlinks to the main libarary; it's important to have libqt-mt.so)
Look at the directory you see before the library name. Write it down and try the following (change /usr/lib/qt3 to the right directory in your system)
export QTDIR=/usr/lib/qt3
export LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
cd /directory/you/have/the/theme/in
./configure
 
Old 11-10-2003, 06:42 PM   #9
dibblethewrecke
Member
 
Registered: Nov 2003
Location: UK
Distribution: Arch Linux
Posts: 210

Original Poster
Rep: Reputation: 30
ok, my buddies and i, namely trial and error, have managed to ascertain that:

i had no (or the wrong) gcc compiler and i was missing several libs inc ljpeg and lpng

now the ./configure works fine but i can't make. i have suspicions that i'm it's because i'm not putting any options after the ./configure but i don't know what i am suppose to put! i've googled but no luck - it's a bit confusing to have instructions in install and read me that assume so much!
 
Old 11-10-2003, 07:01 PM   #10
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,576

Rep: Reputation: 191Reputation: 191
As I can se, we haven't asked you if you have gcc installed. What happens when you run
gcc
 
Old 11-10-2003, 07:42 PM   #11
Mikhail_16
Member
 
Registered: Oct 2003
Distribution: Gentoo rules them all
Posts: 279

Rep: Reputation: 31
i wonder if you have to be root to actually do make for that stuff?

Try doing 'su' (become root)
then running 'make' and/or 'make install' on it.
 
Old 11-11-2003, 03:03 AM   #12
dibblethewrecke
Member
 
Registered: Nov 2003
Location: UK
Distribution: Arch Linux
Posts: 210

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by Mara
The command "rpm -qa | grep -i 'qt'" gets all installed packages (rpm -qa does it) and shows only the ones with 'qt' string inside their names.

The result you get is 100% correct. There must be something different. First, find if you have 'libqt-mt'. The command is
locate libqt-mt
It'll list you files beginning with 'libqt-mt'. You should get something like /usr/lib/qt3/lib/libqt-mt.so.3
(more than one entry, there are many symlinks to the main libarary; it's important to have libqt-mt.so)
Look at the directory you see before the library name. Write it down and try the following (change /usr/lib/qt3 to the right directory in your system)
export QTDIR=/usr/lib/qt3
export LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
cd /directory/you/have/the/theme/in
./configure
mara, i'll try this but i think you have seen that we may be passed the qt problem (tho i'm not sure)

I'll check the gcc by running

gcc

i guess that's right and i'll get back to you.

mikhail - i did the make stuff as root first time round, so it's not that
 
Old 11-11-2003, 03:53 AM   #13
dibblethewrecke
Member
 
Registered: Nov 2003
Location: UK
Distribution: Arch Linux
Posts: 210

Original Poster
Rep: Reputation: 30
ok, consider the first problem solved.

libqt-mt was there in the place suggested, i think was always there, i think the problem was i didn't have the gcc compiler, now i have.

I have done the configure stage using

./configure

i get the message

Good - your configure finished. Start make now

when i start make with

make

it doesn't work. it gives me all this but there is no error obvious to me in this one:

make all-recursive
make[1]: Entering directory `/mnt/win_d/Linux/plastik-0.3.9'
Making all in style
make[2]: Entering directory `/mnt/win_d/Linux/plastik-0.3.9/style'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/mnt/win_d/Linux/plastik-0.3.9/style'
Making all in client
make[2]: Entering directory `/mnt/win_d/Linux/plastik-0.3.9/client'
Making all in config
make[3]: Entering directory `/mnt/win_d/Linux/plastik-0.3.9/client/config'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/mnt/win_d/Linux/plastik-0.3.9/client/config'
make[3]: Entering directory `/mnt/win_d/Linux/plastik-0.3.9/client'
source='plastik.cpp' object='plastik.lo' libtool=yes \
depfile='.deps/plastik.Plo' tmpdepfile='.deps/plastik.TPlo' \
depmode=gcc3 /bin/sh ../admin/depcomp \
/bin/sh ../libtool --silent --mode=compile --tag=CXX g++ -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/lib/qt3/include -I/usr/X11R6/include -I/usr/include/kwin -DQT_THREAD_SUPPORT -D_REENTRANT -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -O2 -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DQT_PLUGIN -c -o plastik.lo `test -f 'plastik.cpp' || echo './'`plastik.cpp
plastik.cpp:24:28: kwin/workspace.h: No such file or directory
plastik.cpp:25:26: kwin/options.h: No such file or directory
In file included from plastik.cpp:28:
plastik.h:26:25: kwin/client.h: No such file or directory
In file included from plastik.cpp:30:
plastikclient.h:26:25: kwin/client.h: No such file or directory
In file included from plastik.cpp:30:
plastikclient.h:37: `Client' is not a class or namespace
plastikclient.h:40: parse error before `*' token
plastikclient.h:61: warning: ISO C++ forbids declaration of `MousePosition' with no type
plastikclient.h:61: `MousePosition' declared as a `virtual' field
plastikclient.h:61: parse error before `(' token
plastikclient.h:69: `QBoxLayout' was not declared in this scope
plastikclient.h:69: `layout' was not declared in this scope
plastikclient.h:69: parse error before `&' token
plastikclient.h:37: warning: `class KWinInternal::PlastikClient' has virtual functions but non-virtual destructor
plastikclient.h: In member function `QPixmap KWinInternal::PlastikClient::getTitleBarTile(bool) const':
plastikclient.h:44: return type `struct QPixmap' is incomplete
plastik.cpp: In member function `void KWinInternal::PlastikHandler::reset()':
plastik.cpp:59: `options' undeclared (first use this function)
plastik.cpp:59: (Each undeclared identifier is reported only once for each function it appears in.)
plastik.cpp:69: `Workspace' undeclared (first use this function)
plastik.cpp:69: parse error before `::' token
plastik.cpp: In static member function `static QColor KWinInternal::PlastikHandler::getColor(KWinInternal::ColorType, bool)':
plastik.cpp:106: `Options' undeclared (first use this function)
plastik.cpp:106: parse error before `::' token
plastik.cpp:108: parse error before `::' token
plastik.cpp:111: parse error before `::' token
plastik.cpp:115: parse error before `::' token
plastik.cpp:120: parse error before `::' token
plastik.cpp:125: parse error before `::' token
plastik.cpp:129: parse error before `::' token
plastik.cpp:131: parse error before `::' token
plastik.cpp:103: warning: unused parameter `const bool active'
plastik.cpp: At global scope:
plastik.cpp:145: syntax error before `*' token
plastik.cpp:165: parse error before `}' token
make[3]: *** [plastik.lo] Error 1
make[3]: Leaving directory `/mnt/win_d/Linux/plastik-0.3.9/client'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/mnt/win_d/Linux/plastik-0.3.9/client'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/mnt/win_d/Linux/plastik-0.3.9'
make: *** [all] Error 2

so close yet so far

what am i doing wrong now!
 
Old 11-11-2003, 01:24 PM   #14
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,576

Rep: Reputation: 191Reputation: 191
Quote:
Originally posted by dibblethewrecke

plastik.cpp:24:28: kwin/workspace.h: No such file or directory!
It means you don't have a file from kdebase-devel package. It may mean that you don't have kdebase-devel installed. So
rpm -qa|grep kdebase
If there's no kdebase-devel, use
urpmi kdebase-devel
to install it.
 
Old 11-11-2003, 02:07 PM   #15
mep]-[isto
Member
 
Registered: Nov 2003
Distribution: Slackware 9.1
Posts: 61

Rep: Reputation: 15
heya, this is related to this thread so i thought id post in here. i was in the same position as dibble, but i have managed to pull through! (after installing lots of libs, png gpl etc) but now my final problem in this momentous battle of installing....A THEME! lol no but seriously...ive done ./configure -prefix=/usr, make, make install and they all seem to have passed through fine with no errors..great!

my question now..wheres my theme and how do i go about applying it? ive gone to add theme in kde control centre, browsed to the dir where my theme was compiled in and no themese are anywhere to be found.

any hints? i would be most grateful!

thankyou!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
compile kde with Konstruct but missing file!! ngan_yine Linux - Newbie 5 03-07-2005 02:34 AM
dont know how to install themes on mandrake 10 with KDE 2.4 goodall16 Linux - Newbie 5 04-29-2004 10:08 AM
How can I compile KDE 3.2 on mandrake 8.1? MjeSeCaR Mandriva 4 01-18-2004 06:19 PM
kde (mandrake 9.2) missing/broken menus williec30 Linux - Software 2 12-16-2003 07:18 PM
installing icon themes in mandrake 9, kde 3 plasm4 Linux - Newbie 0 10-06-2002 05:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration