LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-18-2003, 04:48 PM   #1
01AWW18T
LQ Newbie
 
Registered: Sep 2003
Posts: 4

Rep: Reputation: 0
Unhappy Can't boot in b/c of messed up video


Hi, I've recently installed a copy of RedHat 9.0 running in Virtual PC on my Win XP computer. During the installation of linux, I changed the probed monitor setting from the default one to a Generic one. I now can't see the display correctly and the graphics is all messed up when I boot into linux. Any ideas how I can revert back to the default probed monitor setting so I can see what I'm doing?? TIA

I need to know how to get into shell from the bootloader.,. I think.,., damn i'm such a n00b in this linux stuff

I'm using the grub bootloader.
 
Old 09-18-2003, 04:57 PM   #2
Derek-kun
Member
 
Registered: Sep 2003
Posts: 65

Rep: Reputation: 15
ya, i did the exact same thing. when i was installing mandrake i chose the actual type of monitor that i have, yet the graphics were massed up. what i had to do was re-install it and pick the one it started with. just go with what it wants you to have, don't change it. or if you can some how make it into drakconf in the condition it's in then you can change it from there, but if you havn't done anything big or importent i'd say your best bet would be to re-install it.
 
Old 09-18-2003, 04:59 PM   #3
01AWW18T
LQ Newbie
 
Registered: Sep 2003
Posts: 4

Original Poster
Rep: Reputation: 0
The problem with the default setting was that it wouldn't goto 1024 x 768.,., ., the max setting was only 800x600.,
can I change the res after the install??
 
Old 09-18-2003, 05:01 PM   #4
Derek-kun
Member
 
Registered: Sep 2003
Posts: 65

Rep: Reputation: 15
i'm pretty sure you can, i saw something about resolution in drakconf. as long as you can tell what you are doing you should be able to find where you can change it. but i'm a complete newb to so i'm going by what i remember seeing, not by fact.
 
Old 09-18-2003, 05:04 PM   #5
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Is the problem you are having in graphical mode right? Boot into text mode. If you don't know how to make it, when into graphical mode press simultaneously "ctrl+alt+F[1-6]". (ctrl+alt+F7 brings you back to graphical environment). This will call a text mode login screen. Login as root, go into /etc/X11. There you have a file called XF86Config. Edit it with your prefered editor (mcedit, pico, vi etc). There will be a line with your monitor type, including resolution, sync and refresh rate. Edit it with your values. A monitor manual and a precisely graphicscard model/amount of memory will be really handy
 
Old 09-18-2003, 05:06 PM   #6
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Quote:
Originally posted by 01AWW18T
The problem with the default setting was that it wouldn't goto 1024 x 768.,., ., the max setting was only 800x600.,
can I change the res after the install??
Try using the following keys simultaneously:

ctrl + alt + [plus or minus key at your num. pad]

and see if you can change between resolutions.
 
Old 09-18-2003, 05:09 PM   #7
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Quote:
Originally posted by Derek-kun
i'm pretty sure you can, i saw something about resolution in drakconf. as long as you can tell what you are doing you should be able to find where you can change it. but i'm a complete newb to so i'm going by what i remember seeing, not by fact.
Derek-kun is almost right. Although, drakconfig is a Mandrake tool, not found into Redhat which I believe you are using judging by your first post
Redhat has a tool to configure XF86Config too, but the text editing is the one I actually use
 
Old 09-18-2003, 11:06 PM   #8
01AWW18T
LQ Newbie
 
Registered: Sep 2003
Posts: 4

Original Poster
Rep: Reputation: 0
alright., i finally got it to work., turns out i had to set it to 16 thousands of colours .,., ARGH

ok another question.,.,

I can't get the res to be 1024 x 768., its always 800x600 or less

I've tried changin it in the display settings., but it would just revert back to 800x600.,

i've also tried changing it by editing the XF86Config file., but again., it reverts to 800x600.,

anyone know how i can get this to work?
 
Old 09-19-2003, 04:05 AM   #9
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Hi 01AWW18T!!!

Hmmm, I can go up to that resolution you are trying to achieve in a 2 mega video card computer. Make sure the amount of Video Ram you have matches with the amount of video Ram defined into your XF86Config file . You can also copy/paste your XF86Config here so everybody could give a better look at it
 
Old 09-19-2003, 10:01 AM   #10
01AWW18T
LQ Newbie
 
Registered: Sep 2003
Posts: 4

Original Poster
Rep: Reputation: 0
I'm running virtual pc on my laptop., which has the Intel Extreme Graphics 2 chipset for video. I think it varies the shared memory for video depending on the load, so I just set 16megs in linux for the video. I'm not too sure if that's right or not.
anyways here's my XF86Config file:

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Unprobed Monitor"
HorizSync 31.5 - 37.9
VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "s3"
VendorName "Videocard vendor"
BoardName "S3 Trio32 (generic)"
VideoRam 16384
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768" "800x600"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection


Thanks alot
 
Old 09-19-2003, 10:38 AM   #11
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
I cannot see anything wrong right away, but you can always play with the video ram values (not with refresh rate though, you can easily destroy your monitor playing with it...ghehe), but what I would recommend is for you to uncomment the following line out:

Load "dri"

Simply place an "#" character at the beginning of the line like this:

# Load "dri"

Again, I've played all my cards here. If this does not help, try to google for your video card type and Linux .

Good luck my friend!!
 
Old 10-16-2003, 11:07 AM   #12
paulo
Member
 
Registered: Oct 2002
Distribution: Fedora Core 2
Posts: 32

Rep: Reputation: 15
Quote:
Originally posted by Megaman X
Try using the following keys simultaneously:

ctrl + alt + [plus or minus key at your num. pad]

and see if you can change between resolutions.
I recently screwed up my Xserver which I am a little helpless without. Maybe I'm a lucky newb (or a smart one for always checking linuxquestions.org first) but, I thought I was going to have to either re-install RH 9 or mess with tons of text commands and . files that I know little about. But, this trick worked like a charm. Oh yeah and I learned a little bit more about XF86Config - because I tried that first (after pulling up another session ctrl alt F1). I am slowly getting more familiar with doing things what I used to consider the hard way (text). And that is good.
 
Old 10-16-2003, 12:13 PM   #13
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
That's cool Paulo, thanks for sharing it And welcome to LinuxQuestions.org . Redhat has a nice tool for configuring Xserver:

redhat-config-xfree86

If I remember right. You can even run it from text mode . Although, I highly recomend you to try using text editing as often as you can. The reason for it is, that sooner or later, you will want to try another distro, let's say Mandrake, and you have a totally different set of tools, so obviously redhat-config-xfree86 won't work :S. Sticking with text editing and learning what and where most of the important files are (fstab, initrc, inittab, xf86config, rc.modules and many, many others) you most likely will end up fixing any Linux distribution whereever you are. Using the tools provided by each distro, you will be good at only one thing
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RedHat X boot messed up dmanchepalli Red Hat 0 02-14-2005 08:43 PM
Daul Boot? Messed up? mohbana Mandriva 3 11-27-2004 05:04 AM
RH9 - won't boot - messed up fstab amanu1 Linux - Newbie 1 05-06-2004 07:52 PM
Messed up boot loader help please!!!! jerrit Linux - General 4 02-07-2004 08:16 AM
ok, messed up VIDEO Drivers!?!?!? Gnute Slackware 4 05-17-2003 01:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration