LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-19-2013, 08:39 PM   #1
Altiris
Member
 
Registered: Mar 2013
Posts: 555

Rep: Reputation: Disabled
2 errors with TigerVNC server


I am currently having 2 errors while having setup TigerVNC server. The server works and is operable at least with the first error. The first error shows up whenever I restart the vncserver service.

Code:
Starting VNC server: 1:tom xauth: (stdin):1:  bad display name "computer1:1" in "add" command
tom is my username and computer1 is my hostname. Anyone know how to fix this?

The other error I receive is a "Connection refused 111" error whenever I try connecting to my VNC after I add the "-localhost" command in the vncservers.conf file as so
Code:
VNCSERVERARGS[1]="-geometry 800x600 -localhost"
I have port forwarded the port 5901 for my user and when I remove the -localhost it works again. The -localhost enables an SSH tunnel.
(http://wiki.centos.org/HowTos/VNC-Se...bb301ea0038a26)
 
Old 08-20-2013, 12:59 AM   #2
Doug G
Member
 
Registered: Jul 2013
Posts: 749

Rep: Reputation: Disabled
First, the -localhost option tells the vnc server to ONLY accept connections from localhost, i.e. your local machine. So don't use that startup option if you want to connect from other computers. The option is primarily there for port tunneling like with ssh.

And for whatever it's worth on my Fedora machine I use VNCSERVERARGS[2]="-geometry 1024x700" not VNCSERVERARGS[1]
 
Old 08-21-2013, 11:49 AM   #3
Altiris
Member
 
Registered: Mar 2013
Posts: 555

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Doug G View Post
First, the -localhost option tells the vnc server to ONLY accept connections from localhost, i.e. your local machine. So don't use that startup option if you want to connect from other computers. The option is primarily there for port tunneling like with ssh.

And for whatever it's worth on my Fedora machine I use VNCSERVERARGS[2]="-geometry 1024x700" not VNCSERVERARGS[1]
If I were to keep that -localhost command then VPN to the computer would that allow me to use VNC? However I get an error whenever enabling the -localhost.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to connect through TigerVNC a.abdulna Linux - Newbie 1 03-21-2013 08:09 AM
No cursor seen in VNC viewers when connecting to TigerVNC server picnik Linux - Newbie 3 06-15-2011 04:07 AM
TigerVNC Some Questions... vonedaddy Linux - Software 1 10-18-2010 10:32 AM
[SOLVED] Uninstall TigerVNC? ncjks Linux - Newbie 2 08-04-2010 08:45 AM
TigerVNC on 2010.1 MartenH Mandriva 3 08-01-2010 12:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration