LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-07-2015, 09:26 AM   #1
prabhucbr
LQ Newbie
 
Registered: May 2010
Posts: 5

Rep: Reputation: 0
Smile 'make' asks for 'target' during installation of php-5.6.13.tar.gz


I am using Rosa R6 Desktop Fresh.

I tried installing php-5.6.13.tar.gz, first by 'tar -zxvf', followed by 'make', which eventually presented with the following message:

make: *** No targets specified and no makefile found. Stop.

In the directory, there are 5 Makefile-s with the following extensions: .frag, .fragments, .gcov, .global and .objects

Can anyone guide me to install the php successfully? Also, how can I pursue the next command, 'make install', after this command?

Thanks in advance and any help is highly appreciated.
 
Old 09-07-2015, 09:48 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2021 CentOS7.9 + 50+ other Linux OS, for test only.
Posts: 17,437

Rep: Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623
Welcome to LQ.

tar xvf php-5.6.13.tar.gz && ./configure --<the usual ~79 options> && make

php.spec : The configuring is line 875 .. 1119.
https://drive.google.com/file/d/0B7S...ew?usp=sharing
Ref. http://dl.fedoraproject.org/pub/fedo...1.fc24.src.rpm


-
 
Old 09-07-2015, 12:57 PM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2021 CentOS7.9 + 50+ other Linux OS, for test only.
Posts: 17,437

Rep: Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623
Installing php, Rosa R6

Installing php, Rosa R6 :

Open a terminal window, and type ..
1) su <enter root password>
2) urpmi php
... and the 21 php packages will be installed : Version=5.5.26
( php-5.6.13 is a version for the future.)

Other install method : You can also use a GUI application, "the package manager".
The name in the Menu is : "Install & Remove Software".


-
 
Old 09-08-2015, 05:55 AM   #4
prabhucbr
LQ Newbie
 
Registered: May 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by knudfl View Post
Welcome to LQ.

tar xvf php-5.6.13.tar.gz && ./configure --<the usual ~79 options> && make

php.spec : The configuring is line 875 .. 1119.
https://drive.google.com/file/d/0B7S...ew?usp=sharing
Ref. http://dl.fedoraproject.org/pub/fedo...1.fc24.src.rpm


-
Hi Knudfl,

Thanks for your kind reply.

This method fits me but could you be more clear please?

./configure --<the usual ~79 options> && make

This is bit confusing. What should I use after -- ?

Also, I couldn't understand the configuring details with the file you have sent.

I would be grateful, if you could explain me the process, if you dont mind.

Kindly give me the step by step commands, if you dont mind.

Should you need any details from me, please do notify so that I can provide you the details.

Thanks a lot.
 
Old 09-08-2015, 08:27 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2021 CentOS7.9 + 50+ other Linux OS, for test only.
Posts: 17,437

Rep: Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623
Re #4 .

? Why do you want to use the bleeding edge php-5.6.13 ?
If you never compiled any software before, php is not the one to start with.

"php-5.6.13" will (probably) be used by a few OS`s next year.
E.g. Fedora 24. ( The current bleeding edge Fedora is version 22, has php-5.6.8 ).


Please use your "Install & Remove Software" to install php. See post #3.


-
 
Old 09-09-2015, 12:10 AM   #6
prabhucbr
LQ Newbie
 
Registered: May 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Hi Knudfl,

Thanks for the reply. I accept your suggestion and have installed PHP from the "Install and Remove Software" in the OS.

Earlier, I was keen on installing version 5.6.13 because, as the web page claimed, it was the minimum requirement to install composer for laravel.

Thanks.
 
  


Reply

Tags
php-5.6.13


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
make xconfig asks for qt installation doughyi8u Linux - Newbie 10 10-25-2016 02:03 PM
NS2 installation problem: no rule to make target 'VERSION' , needed by gen/version.c bilabongster Linux - Newbie 23 12-07-2011 12:54 PM
NS 2 compilation error: make: *** No rule to make target ‚??VERSION‚??, needed by ‚??gen/ve Marz22 Linux - Newbie 8 11-21-2011 03:20 AM
Help with Installation. "No rule to make target.." Aries311 Linux - Software 2 07-02-2005 04:47 PM
php-4.3.3.tar.gz installation. eye Linux - Software 3 11-02-2003 09:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration