LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-24-2016, 09:37 PM   #1
JSully
LQ Newbie
 
Registered: Oct 2016
Location: Oklahoma
Posts: 2

Rep: Reputation: Disabled
Arrow WPA_SUPPLICANT can replace eth0 with wlan0 on startup? Using wpa_gui.


I have hit a wall since Ive gotten a laptop. ive mounted drivers for wifi on desktop for antennas. Im using linux slackware with kde interface. Ive already used wpa_gui and used the fallowing script
"wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wpa_supplicant.conf" and "dhcpcd" thats how I log into my wifi. I know I could possibly use network manager. If anyone has an idea or similar problem let me know. I also have an executable file on desktop but it crashes after sleep or computer hibernation. Is it possible to have it already searching for my wifi or start up "a" network manager when searching for eth0 on boot. maybe a boot mount?
 
Old 10-26-2016, 08:42 AM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware, Slarm64 & Android
Posts: 16,288

Rep: Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322Reputation: 2322
Slackware Linux has a file /etc/rc.d/rc.inet1 which is invoked with a 'start' argument during bootup, & resume (from suspend/hibernate). Why not use that?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Recreating /var/run/wpa_supplicant/wlan0 under CentOS 6.4 student23 Linux - Newbie 1 04-19-2013 06:58 AM
eth0 and wlan0 vs wlan0 problem player107 Linux - Wireless Networking 3 02-25-2013 09:54 AM
[SOLVED] bonding wlan0 and eth0 dimm0k Slackware 4 07-09-2011 02:54 PM
wpa_gui, could not get status from wpa_supplicant tmkd Slackware 5 12-17-2010 03:17 AM
wpa_gui/wpa_supplicant does not "release" ip when changing networks BCarey Slackware 21 11-26-2007 01:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration