LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-06-2004, 04:35 AM   #1
uveraser
Member
 
Registered: Dec 2003
Location: Tavistock, Devon, England
Distribution: Slackware 9.1, LFS 5.0, Mandrake 9.0/9.1/10.0, Knoppix 3.1, Windows 98SE, Windows XP Pro
Posts: 37

Rep: Reputation: 15
Using an internet connection


Hi,
This is a real noob question, but I can't find anything on the internet about this (it's all about LANs or dhcp servers).

After much trouble I have finally got my "Sagem F@st 800 (E2T)" usb adsl modem working under Slackware 9.1. I think- it appears to be working, but I don't know whether it is fully working yet because I don't know how to set up slackware to use it.

In ifconfig I have the "ADIModem" interface, which has been given, by the startup script, the fixed ip 192.168.60.30. When I run the ADI_PPP_Go script the interface ppp0 is added, with no ip address.

1. Is the ppp0 interface supposed to have an ip address?
2. Which interface gives me my internet ip address?
3. If the answer to the above question is the ADIModem interface, why the heck is it fixed?
4. How do I tell it to get its ip from the dhcp server of my isp?
5. Is there anything else I need to do or should I just be able to open a web browser, change the proxy to "Direct connection" and it will work?

Thanks
Simon
 
Old 07-06-2004, 05:04 AM   #2
uveraser
Member
 
Registered: Dec 2003
Location: Tavistock, Devon, England
Distribution: Slackware 9.1, LFS 5.0, Mandrake 9.0/9.1/10.0, Knoppix 3.1, Windows 98SE, Windows XP Pro
Posts: 37

Original Poster
Rep: Reputation: 15
Hmmm,
Was messing around trying to get it to work and ppp0 magically found an ip address. Very strange. Well anyway, it now works (at long last!).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow Internet Connection when Connecting to Internet on Browsers lennysokol Linux - Networking 8 04-09-2011 04:29 PM
Nic card -> cable internet modem no internet connection zeshan_b Mandriva 21 09-26-2004 11:48 AM
Messed up my internet settings (NO internet connection) :( Almazick Linux - Networking 2 09-08-2004 12:05 PM
My internet apps cannot detect my internet connection esthon_wood Mandriva 5 08-30-2004 08:38 PM
i can get internet connection in windows but in LINUX there is no connection ruzvay Linux - Networking 2 06-08-2004 07:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration