LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-10-2001, 11:34 AM   #1
bisbane
LQ Newbie
 
Registered: Jul 2001
Posts: 9

Rep: Reputation: 0
Unable to access to a website on apache web server


Hi all,
I have a web site installed on Apache and mySQL data base running on Redhat 7.X.
I can browse the web site without any problem from the local web server where the site installed.
However, I cannot browse the site from a remote client either by using the web site IP address or its FQDN. Yet I can ping back and forward between the web server and the client no problem.

The FQDN is resolved properly when I try to ping by name.

The web server and the client has a direct connection without any proxy or firewall in the way.

I'm quite new to Linux so I don't know what else to do when I already tried all the basic trouble shooting techniques.

Is there anything I need to modify on the Apache web serve or on the remote browser to make it work.

Please help

Thank you very much in advance

Bisbane
 
Old 07-10-2001, 11:41 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 256Reputation: 256Reputation: 256
I answered this in the other forum you first posted this. Please refer to cross reference http://www.linuxquestions.org/questi...&threadid=4122
 
Old 07-11-2001, 03:10 AM   #3
Ricardo77uk
Member
 
Registered: Jun 2001
Location: London England
Distribution: Suse 7.1
Posts: 45

Rep: Reputation: 15
Modify the hosts file

I dont think it is a prob with httpd.conf as it works on the local machine. On linux the solution is relatively easy, you simply modify your hosts file located in /etc

add the I.P address of the local machine along with the name of your virtualsite

Example
-----------

192.168.0.1 www.mysite.com

In Windoze you would need to do the same in /windows/hosts

In the United Kingdom version of windows, the hosts file has the extension .SAM if this is the case with your computer then simply rename hosts.sam to hosts.

You should find this works...cheers
 
Old 07-11-2001, 10:18 AM   #4
bisbane
LQ Newbie
 
Registered: Jul 2001
Posts: 9

Original Poster
Rep: Reputation: 0
I got it figured out. It was the default firewall, the IPchains daemon landed during the OS installation. After reconfigure the firewall, everything works as expected.

Thank you very much for your quick reponses

Bisbane
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Forbidden access to soft link on apache web server bnj Linux - Software 3 05-03-2005 09:14 AM
can only access apache website from within network kubrickfan799 Linux - Networking 3 08-10-2004 07:33 PM
Apache Web Server - access from the www vesta41 Linux - Software 8 01-07-2004 07:55 PM
Unable to access to a website on apache web server bisbane General 3 07-10-2001 12:03 PM
remote access to a website on apache web server bisbane Linux - Newbie 0 07-09-2001 07:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration