LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


View Poll Results: how many friends use Linux as their desktop around you
few(less than 10) 7 100.00%
many(more than 10) 0 0%
a large number(more then 20) 0 0%
Voters: 7. You may not vote on this poll

Reply
  Search this Thread
Old 05-08-2015, 10:26 AM   #1
gbcbooks
Member
 
Registered: Aug 2014
Posts: 199

Rep: Reputation: Disabled
turn on interface Keepalive feature on Linux


Hi everyone

i have establised Gre tunnel over Ipsec on my Linux to a cisco router/ASA Firewall, however , i also turn on keepalive feature on cisco interface but i can not find out a way on linux site. it makes the gre interface going down on cisco router site.

and i know there is a way to turn on TCP keepalive function with changing the vaule of some file under /proc/

-----------------------------------
example:
echo '4' > /proc/sys/net/ipv4/tcp_keepalive_time
echo '3' > /proc/sys/net/ipv4/tcp_keepalive_intrvl
echo '3' > /proc/sys/net/ipv4/tcp_keepalive_probe
------------------------------------

i believe that only affect established TCP Connection, and have few concern on inteface keepalive .

i started ospf process between this two machines , keepalive function is a very important for me to deploy this scheme and help me to control route.

please help me to figure out this.
 
Old 08-05-2015, 03:55 AM   #2
Star Rat
LQ Newbie
 
Registered: Jan 2009
Distribution: Slackware 12.2 / Slackware 13.1 --no-kde
Posts: 14

Rep: Reputation: 3
I suspect you're attacking the wrong end of the celery - effectively the router should be suggesting the keepalive (if, as you say, it is set on the router) for your box, not the other way round... What model of router are you using?

Last edited by Star Rat; 08-05-2015 at 03:57 AM.
 
Old 08-05-2015, 04:05 AM   #3
gbcbooks
Member
 
Registered: Aug 2014
Posts: 199

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Star Rat View Post
I suspect you're attacking the wrong end of the celery - effectively the router should be suggesting the keepalive (if, as you say, it is set on the router) for your box, not the other way round... What model of router are you using?
Cisco 1812j
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome 3: Howto Turn off HotCorner / Auto Mouse-Over Feature kataklysm Linux - Desktop 6 05-14-2012 08:43 PM
LXer: Ubuntu Builder Updated With Improved Interface, Wizard Feature And QEMU Support LXer Syndicated Linux News 1 03-27-2012 12:56 PM
LXer: Turn off or limit the Recent Documents feature in Ubuntu LXer Syndicated Linux News 0 07-08-2009 01:50 PM
How to turn off a desktop feature trevil SUSE / openSUSE 2 12-19-2006 10:56 AM
unable to turn off auto mounting feature sharkus SUSE / openSUSE 1 08-22-2006 03:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration