LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-15-2015, 05:59 AM   #1
amitesh_sahay
LQ Newbie
 
Registered: May 2015
Posts: 5

Rep: Reputation: Disabled
to disable IPv6 on Fedora server 21


Hi,

I am new to Fedora-server21, and its been 3 days that I am not able to start working on it. I have installed fedora21 in Oracle virtualBox, and my host machine is Win 7. The installation went smoothly with no hiccups, but I am not able to see IPv4 on my fedora at all, I have followed many online post to disable, but I couldn't. I did try some suggestion from

https://ask.fedoraproject.org/en/ques...

But I don't think its helping me by any means. In the above link, there is another link that guide to some check up on the system for IPv6

http://www.g-loaded.eu/2008/05/12/how...

It ask to execute lsmod | grep ipv6, and see if it show only "ipv6". I did, but I get below

nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat nf_conntrack nf_nat_ipv4,nf_nat_ipv6,ip6tables_nat

and some other menu items similar, but single "ipv6". The link do suggest to blacklist the IPv6 in some file under /etc/modprobe.d

In my machine I could see two files lying under the location

a) lockd.conf b) openfwwf.conf

there is no mention of any specific file name to be edited in the link.

Can somebody help me out to disable Ipv6, and enable IPv4, I need to communicate with my host machine (win 7) to share files to and fro, which I do not think is possible without IPv4 under my situation.

I am more used to redhat 5x, and redhat6x, where I do not see such issues of IPv6 at all. Also a very interesting observation in my /etc/sysconfig/network-scripts path. It has ifcfg-enp0s3, and ifcfg-lo, there is no eth(n) . Is this is something new in fedora21, or its something having to do just with my machine? the content of ifcfg-enp0s3 is very new to me, which I haven't experienced while working with redhat.

I am in desperate need of suggestions.

Regards,

Amitesh
 
Old 05-15-2015, 08:34 AM   #2
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 875

Rep: Reputation: 282Reputation: 282Reputation: 282
Disabling IPv6 wont fix any problem you have with your system.

You did enable the network when creating the VM?
 
Old 05-15-2015, 07:59 PM   #3
amitesh_sahay
LQ Newbie
 
Registered: May 2015
Posts: 5

Original Poster
Rep: Reputation: Disabled
Hi WildWizard,

Yes, I did, I have taken "Bridged Network" , "Allow All".

Regards,
Amitesh S
 
Old 05-16-2015, 04:44 AM   #4
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 875

Rep: Reputation: 282Reputation: 282Reputation: 282
Quote:
Originally Posted by amitesh_sahay View Post
Hi WildWizard,

Yes, I did, I have taken "Bridged Network" , "Allow All".

Regards,
Amitesh S
What do mean by "Allow All"

I just did a test install of the latest VB + F21 install and it works just fine (the network interface is enp0s3 also)
 
Old 05-16-2015, 09:52 AM   #5
amitesh_sahay
LQ Newbie
 
Registered: May 2015
Posts: 5

Original Poster
Rep: Reputation: Disabled
reply

following are the details of VM settings for network. May be it will help more to understand the issue.

1) Enable Network Adapter --- checked
2) Adapter type : Intel PRO/1000 MT Desktop(82540EM){ however, there are other options as well, I took the default).
3) Promiscuous Mode ----Allow All.
4) Attached to ---- Bridged Adapter
5) cable connected --- checked

Attached a screenshot as well

Thanks

Amitesh
Attached Thumbnails
Click image for larger version

Name:	network.jpg
Views:	28
Size:	78.1 KB
ID:	18472  
 
Old 05-16-2015, 08:49 PM   #6
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 875

Rep: Reputation: 282Reputation: 282Reputation: 282
ok, the only setting I have that differs is the promiscuous setting on mine is on the default setting of deny.

It shouldn't make any difference but I would still change it to test anyway.

Also could you grab the output of "ip addr show" from the system while it's running?
Attached Thumbnails
Click image for larger version

Name:	Fedora.png
Views:	30
Size:	13.3 KB
ID:	18484  
 
Old 05-16-2015, 11:00 PM   #7
amitesh_sahay
LQ Newbie
 
Registered: May 2015
Posts: 5

Original Poster
Rep: Reputation: Disabled
Following are the o/p

++++++++++++++++++++++++++++++++++++++
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default

link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_Ift forever preferred_Ift forever
inet6 ::1/128 scope host
valid_Ift forever preferred_Ift forever
2: enp0s3: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether 08:27:9e:52:62 brd ff:ff:ff:ff:ff:ff
++++++++++++++++++++++++++++++++++++++

I compared the ip addr show output with yours, and I could see that for some reason,its taking loopback ip for ipv4.

Since my ISP is DHCP, so as soon I login to my ISP portal on my win 7(host), the fedora should take Ipv4 as well from the pool as soon as its up. Just a thought, could be wrong though.

Somebody did suggest me to create two file under /etc/modprob.d as blacklist.conf, and ipv6.conf, and enter following respectively


blacklist net-pf-10
blacklist ipv6

and

alias net-pf-10 off
alias ipv6 off

after doing this , I could see one change in the ifconfig output

+++++++++++++++++++++++++

enp0s3: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether 08:00:27:93:52:62

The change is in the "ether", earlier it used to be "inet6" in place of "ether". I really don't know if that makes any sense, or makes any difference.
++++++++++++++++++++++++

just wanted you to know.

Regards,
Amitesh

Last edited by amitesh_sahay; 05-16-2015 at 11:23 PM. Reason: adding value
 
Old 05-17-2015, 12:27 AM   #8
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 875

Rep: Reputation: 282Reputation: 282Reputation: 282
Quote:
Originally Posted by amitesh_sahay View Post
Since my ISP is DHCP, so as soon I login to my ISP portal on my win 7(host), the fedora should take Ipv4 as well from the pool as soon as its up. Just a thought, could be wrong though.
You have some sort of web portal to authenticate your connection?

Your not using a basic home router that handles it all for you?

You should switch to the NAT setting as it sounds like your net connection is not standard in any way shape or form.
 
1 members found this post helpful.
Old 05-17-2015, 07:59 AM   #9
amitesh_sahay
LQ Newbie
 
Registered: May 2015
Posts: 5

Original Poster
Rep: Reputation: Disabled
reply

yes indeed, the NAT settings did it all, my IPv4 is now active.
Thank you for your prompt replies, as well as for your time.

Regards,
Amitesh
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't disable IPv6 bhamid Linux - Networking 10 04-30-2013 02:13 AM
How to disable ipv6? ms-trex Slackware 7 12-13-2012 04:20 PM
Best Way to disable IPV6 idlehands Linux - General 6 12-04-2012 09:58 AM
Preseeding/Kernal Boot Line (Ubuntu Server 10.04-4 LTS x64) - Disable IPv6? Sniperm4n Ubuntu 11 05-07-2012 12:26 PM
Disable IPV6 bjb_nyj101 Linux - Software 2 06-07-2007 09:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration