LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-08-2004, 04:52 AM   #1
verbose
Member
 
Registered: Aug 2004
Distribution: deb lenny 2.6.21-amd64
Posts: 320

Rep: Reputation: 31
SWAT cannot connect


Hello,
I've read a few of the SWAT threads around here related to the same problem I'm having but none have helped.

When I try to connect to localhost:901 I receive the error:
www.google.com could not be found. Please check the name and try again.

127.0.0.1:901 gives me the error:
The connection was refused when attempting to contact 127.0.0.1.

/etc/services contains:
swat 901/tcp


Can anyone help me resolve this?
Thanks
 
Old 08-08-2004, 07:12 AM   #2
zaphodiv
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 388

Rep: Reputation: 30
Hmm, include the http:// part

Have you sent a HUP signal to inetd or rebooted to get inetd to re read /etc/services?
 
Old 08-08-2004, 08:44 AM   #3
amfoster
Member
 
Registered: Aug 2004
Distribution: debian, SuSE
Posts: 365

Rep: Reputation: 36
swat is an xinetd service. You must enable swat to be used. It is in the scheme of apps that are considered "Unsafe" since the data passed is in clear text. These include telnet, rlogin etc.

I do not know what distro you are using, but typically from the text mode you can cd to /etc/xinetd.d directory and edit the file in there named swat. It probably has a line that reads disable = yes. Either change it to no or comment out the line. Save the file and then restart the xinetd daemon.
/etc/init.d/xinetd restart

You should be good to go.

On some distros, this swat entry may be in the /etc/ineetd file, but usually it will be in the directory I mentioned.

If you are using Red Hat (yuk!) in xwindows you can issue serviceconf and turn swat on in the GUI. From the black screen you can issue ntsysv and turn it on there. Don't forget to restart the xinetd daemon.

On SuSe, everything is done using Yast.




I suggest if you are new to the system that you visit www.webmin.com and download it. It is a great weeb based administration tool that will include tools for setting up swat, apache, ftp, well, basically everything!


Tony
 
Old 08-08-2004, 02:01 PM   #4
verbose
Member
 
Registered: Aug 2004
Distribution: deb lenny 2.6.21-amd64
Posts: 320

Original Poster
Rep: Reputation: 31
It was so late I forgot to post xinetd.d/swat:

{
socket_type = stream
wait = no
protocol = tcp
only_from = 127.0.0.1
user = root
log_on_failure += USERID
server = /usr/sbin/swat
port = 901
disable = no
}

I'm using Fedora 2/ 2.6.6-1.427 and just disabled my firewall considering my winmodem still isn't fully working. It's still not working. Thanks for the suggestion of webmin amfoster.
 
Old 08-08-2004, 02:35 PM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 19,108

Rep: Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967Reputation: 2967
Did you restart xinetd?
 
Old 08-08-2004, 04:57 PM   #6
verbose
Member
 
Registered: Aug 2004
Distribution: deb lenny 2.6.21-amd64
Posts: 320

Original Poster
Rep: Reputation: 31
Yes, I did '/bin/kill -HUP -a xinetd'
 
Old 08-09-2004, 11:23 PM   #7
zaphodiv
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 388

Rep: Reputation: 30
>swat is an xinetd service.
Not allways. It runs from normal inetd on slackware.

Verbose, what browser are you using to connect to swat?
Try lynx http://127.0.0.1:901

Can you ping 127.0.0.1 ?

My guess is that a firewall or iptables is blocking the connection.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SWAT - Could not connect to port 901 brucerowe Linux - Networking 17 09-11-2008 12:45 PM
Samba - Swat: Cannot Connect to Localhost:901 Sloppyunderfoot Linux - Networking 3 02-10-2005 01:26 PM
Can not connect to SWAT anymore lovswr Linux - Networking 0 11-08-2003 12:16 PM
Problem to connect to SWAT from remote scram Linux - Networking 2 07-18-2003 09:04 AM
samba's SWAT...won't connect Robert0380 Linux - Software 7 07-16-2003 05:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration