LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-02-2004, 09:12 AM   #1
Un0riginal
LQ Newbie
 
Registered: Jun 2004
Location: Leeds
Distribution: Suse 9.1
Posts: 5

Rep: Reputation: 0
*sorry mods can you move to wired* Suse 9.1 DHCP service pulling everything but IP


Got a D-link wireless router to play with at work used my linux box to set it up, it DHCP'd and pulled a 192.168.0.100 IP address with the router default gateway etc... no problems there set it all up, then put linux box back onto our main network, and restarted network again, it pulled the right network mask and all the DNS servers, but not my IP, the IP it keeps on the 192.168.0.100. The DHCP is not a true DHCP but a bootp, don't know if that would have any implications, my mate said not as suse usually just gets up and goes.

Have deleted the card in YAST and re-added it, it keeps all same details. have renamed the cfg-eth-*MAC* address file that it creates, but it didn't recreate another and wouldn't even see the card till it was put back.

I'm fairly new to linux as a whole and am completly stumped by this, had a friend look at it and he can't figure it out either. So I am hoping that somebody might have some experience with this problem.

Any help gratefully received.

Cheers

Daryl

Last edited by Un0riginal; 08-02-2004 at 09:13 AM.
 
Old 08-02-2004, 12:56 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 67
Moved as requested

Try running "dhcclient" as root.
 
Old 08-03-2004, 05:52 AM   #3
Un0riginal
LQ Newbie
 
Registered: Jun 2004
Location: Leeds
Distribution: Suse 9.1
Posts: 5

Original Poster
Rep: Reputation: 0
cant seem to find a "dhcclient" to run ..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed of DHCP service from DLink Router / Switch Steve Cronje Linux - Networking 11 03-07-2011 06:35 AM
problem dhcp service with 3com 4900 sx (3c17702) & 4228G (3c17304) n_f Linux - Networking 2 07-13-2005 06:36 AM
DHCP not pulling IP on later 2.4 self compiled kernels php Slackware 1 05-15-2005 04:21 PM
SuSE 9.2 RAID-0 on A8V mobo problem, pulling my hair out as I type! VidCypher Linux - Hardware 9 03-08-2005 07:02 PM
Network service on Suse Loke Linux - Distributions 1 02-01-2003 04:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration