LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 05-23-2009, 01:02 AM   #1
Recursion
LQ Newbie
 
Registered: Apr 2009
Posts: 27

Rep: Reputation: 17
Slow ssh connection over lan with Ubuntu Desktop and Ubuntu Server


I have my laptop(OS Ubuntu Server 9.04) which I am planning on using for a development machine. The laptop as well as my desktop(OS Ubuntu 9.04 Desktop) are behind a D-link 655 NAT router.

I first noticed that when I ssh'ed into the laptop, the connection was quite slow. So i verbosed the ssh connection and got this. I boldered where it stalls and holds for a while

Quote:
ssh -v name@192.168.0.199
OpenSSH_5.1p1 Debian-5ubuntu1, OpenSSL 0.9.8g 19 Oct 2007
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to 192.168.0.199 [192.168.0.199] port 22.
debug1: Connection established.
debug1: identity file /home/llama/.ssh/identity type -1
debug1: identity file /home/llama/.ssh/id_rsa type -1
debug1: identity file /home/llama/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.1p1 Debian-5ubuntu1
debug1: match: OpenSSH_5.1p1 Debian-5ubuntu1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.1p1 Debian-5ubuntu1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host '192.168.0.199' is known and matches the RSA host key.
debug1: Found key in /home/llama/.ssh/known_hosts:4
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: /home/llama/.ssh/identity
debug1: Trying private key: /home/llama/.ssh/id_rsa
debug1: Trying private key: /home/llama/.ssh/id_dsa
debug1: Next authentication method: password
I then did a ping from the Desktop to the laptop and got this

Quote:
ping -c4 -v 192.168.0.199
PING 192.168.0.199 (192.168.0.199) 56(84) bytes of data.
64 bytes from 192.168.0.199: icmp_seq=1 ttl=64 time=0.232 ms
64 bytes from 192.168.0.199: icmp_seq=2 ttl=64 time=0.216 ms
64 bytes from 192.168.0.199: icmp_seq=3 ttl=64 time=0.215 ms
64 bytes from 192.168.0.199: icmp_seq=4 ttl=64 time=0.221 ms

--- 192.168.0.199 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3000ms
rtt min/avg/max/mdev = 0.215/0.221/0.232/0.006 ms

The ping's aren't to bad, but the initial ssh connection is very slow, how can I speed this up?

Last edited by Recursion; 05-23-2009 at 01:04 AM.
 
Old 05-23-2009, 02:17 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,345

Rep: Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945
If it freezes there I'd wager that it was a DNS lookup being done on your ip at the server. Either make the DNS entry exist and within a primary DNS service being used by that server, or stop the server doing a lookup in the first place in sshd_config
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow LAN transfer from Ubuntu Dapper to Windows XP SP2 Kaladar Linux - Networking 2 12-09-2011 11:53 AM
Ubuntu Desktop access to Ubuntu Server DarkFlame Linux - Server 10 01-21-2009 07:22 AM
XP desktop to Ubuntu server slow copy bring7 Linux - Server 3 07-07-2008 02:29 PM
Intel i810 on-board graphics card bug, with Ubuntu server 7.04 running Ubuntu-Desktop calebf Linux - Server 2 05-14-2007 11:53 PM
slow ssh response after upgrate to ubuntu 7 xafwodahs Linux - General 6 04-24-2007 12:45 PM


All times are GMT -5. The time now is 08:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration