LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-25-2004, 03:31 AM   #1
Moebius
Member
 
Registered: Dec 2002
Location: Milwaukee, WI
Distribution: Ubuntu, Kubuntu, Debian, CentOS
Posts: 216

Rep: Reputation: 30
samba very slow


When I try to copy anthing off of my samba server it goes VERY slowly. I can't even stream a movie over the network. When I copy things to it, it goes faster, but not nearly as fast as it should. This computer, which I'm tring to copy file from is amd64 and has samba 3.05 and the computer which I'm trying to copy files to is a Windows XP laptop. They both have 100mbit network cards. The one on this computer is onboard a Asus K8V Deluxe. I think it's using the sk98lin driver or something like that.

Here is my smb.conf
Code:
# Samba config file created using SWAT
# from 127.0.0.1 (127.0.0.1)
# Date: 2004/08/13 18:52:30

# Global parameters
[global]
	server string = Samba Server %v
	interfaces = lo, eth0
	bind interfaces only = Yes
	guest account = samba
	log file = /var/log/samba/log.%m
	max log size = 50
	socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
	printcap name = lpstat
	preferred master = Yes
	domain master = Yes
	guest ok = Yes
	hosts allow = 127.0.0.1, 192.168.1.0/24
	hosts deny = 0.0.0.0/0
	printing = cups
	print command = /usr/bin/lp -d '%p' %s; rm %s
	lpq command = /usr/bin/lpstat -o '%p'
	lprm command = /usr/bin/cancel '%p-%j'
	lppause command = lp -i '%p-%j' -H hold
	lpresume command = lp -i '%p-%j' -H resume
	queuepause command = /usr/bin/disable '%p'
	queueresume command = /usr/bin/enable '%p'

[print$]
	comment = Printer Drivers
	path = /etc/samba/printer # this path holds the driver structure
	write list = zac, root
	guest ok = No

[HPOfficeJet6110]
	comment = HP OfficeJet 6110 all-in-one
	path = /var/spool/samba
	printer admin = zac, root
	printable = Yes

[printers]
	comment = All Printers
	path = /var/spool/samba
	printer admin = zac, root
	printable = Yes
	browseable = No

[public]
	comment = Public Files
	path = /home/samba
	read only = No
	create mask = 0777

[homes]
	read only = No
	guest ok = No

[music]
	path = /mnt/music

[movies]
	path = /mnt/movies

[data2]
	path = /mnt/data2
 
Old 08-25-2004, 09:47 AM   #2
tychovi
LQ Newbie
 
Registered: Feb 2003
Location: Virgin Islands
Distribution: Ubuntu, Debian, CentOS, Fedora
Posts: 15

Rep: Reputation: 0
very slow samba (waltz???)

Hello,

Try a search in the networking section of LQ there are lots of issues that people are have with slow connections in Samba Windows networks.

A fair amount of it seems to revolve around GB Ethernet drivers and certain kernels/mobo's. Also check to make sure you have all of the autoneg. bleck turned off and everybody's talking the same duplex and speed. Then checkout your packet stats and make sure your switch/hub/crossover cable is up to snuff.

If you dig around here a little bit you'll find a lot more info, these are just the rough edges. LOL

tychovi
 
Old 08-25-2004, 10:38 AM   #3
sandgroper
Member
 
Registered: Jul 2004
Location: Perth , Western Australia
Distribution: Fedora Core 5 , Mint 9
Posts: 118

Rep: Reputation: 15
Quote Moebius


When I try to copy anthing off of my samba server it goes VERY slowly. I can't even stream a movie over the network. When I copy things to it, it goes faster, but not nearly as fast as it should. This computer, which I'm tring to copy file from is amd64 and has samba 3.05 and the computer which I'm trying to copy files to is a Windows XP laptop. They both have 100mbit network cards. The one on this computer is onboard a Asus K8V Deluxe. I think it's using the sk98lin driver or something like that.

Here is my smb.conf ............
---------------------------------------------------------------

You need to add a few other stanzas in the [global ] section
[global]

netbios name = <computer name>
load printers = yes

And then in the shared directories you will have to put

[share directory]
path = <directory path>
browseable = yes
writable =yes # or read only = yes



Perhaps the main reason why your samba connection is very slow is because there is no netbios name idendifying the samba server and having the shared directories without any options to browse is not very helpful either.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
samba (very slow) stomach Linux - Software 1 10-26-2005 12:07 PM
Slow Samba..... benmay05 Linux - Networking 5 01-29-2005 08:07 PM
Samba VERY slow mdreeling Linux - Networking 0 11-24-2004 04:51 AM
Samba is VERY VERY slow ludwig W Linux - Networking 25 09-20-2004 02:55 PM
Slow SAMBA gshok108 Linux - Networking 0 12-21-2003 06:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration