LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-08-2006, 02:40 AM   #1
DaveQB
Member
 
Registered: Oct 2003
Location: Sydney, Australia.
Distribution: PCLinuxOS 2010.12, Debian Lenny
Posts: 396

Rep: Reputation: 38
pppoe/rp-pppoe on Debian


Hi guys,
Moving from a Mandrake server to a Debian server.

With mandrake I simply did 'urpmi rp-pppoe'. Then ran adsl-config,
answered some questions and then adsl-start and its away.

With Debian I first tried the pppoe package (apt-get install pppoe
pppoeconf) and then ran pppoeconf. This fails, as it says it can't find
and Access Communicator (?) on either eth0 or eth1. So I tried to
manually edit the dsl-provider file and add my details. Then ran
'pppoe'. After a wait, it returns "timeout waiting for PADO". So then
grabbed the rp-pppoe source and compiled it and installed. Did the
pppoe-config, answered the question (much the same as on Mandrake) and
then attempted to start up again, this time with pppoe-start. Same
problem as before "timeout waiting for PADO".

I am suspecting this NIC isn't Linux compatible. But it is
detecting enough to be labeled eth1. There is no entries in
/etc/network/interfaces for eth1. I think thats right; there shouldn't
be any settings for the NIC used to initiate the pppoe connection.

Advice ?
 
Old 08-08-2006, 03:08 AM   #2
Ashrack
Member
 
Registered: Oct 2005
Distribution: Ubuntu - Edgy Eft
Posts: 173

Rep: Reputation: 30
I had a similar problem on UBUNTU! I solved it by changing the ADSL cable to the other NIC and on that on it found the access concentrator.
 
Old 08-08-2006, 03:12 AM   #3
DaveQB
Member
 
Registered: Oct 2003
Location: Sydney, Australia.
Distribution: PCLinuxOS 2010.12, Debian Lenny
Posts: 396

Original Poster
Rep: Reputation: 38
Was the NIC faulty or just not Linux compatible or just not ADSL compatible ?

To be honest I didnt check if the NIC was Linux compatible as I thought I got myself down to only having Linux compatible NIC's in my house (+ the fact the system registered it as eth1)

But I will try another NIC, thanks.
 
Old 08-08-2006, 03:46 AM   #4
Ashrack
Member
 
Registered: Oct 2005
Distribution: Ubuntu - Edgy Eft
Posts: 173

Rep: Reputation: 30
Well in my case I had 2indentical NICs in the computer. Both were working great on UBUNTU BREEZY! But after I did a clean install of UBUNTU DAPPER the NIC that was responsible for ADSL connection didnt find the ACCESS CONCENTRATOR! So then I put the UTP cable to the other NIC and ADSL started working.

ps. Did U try doing:
Code:
ifup eth1 ##where eth1 is you NIC for ADSL##
ifconfig eth1 192.168.0.1

At least in my case I have the NIC resposible for ADSL assigned an IP number

Last edited by Ashrack; 08-08-2006 at 03:47 AM.
 
Old 08-08-2006, 04:09 AM   #5
DaveQB
Member
 
Registered: Oct 2003
Location: Sydney, Australia.
Distribution: PCLinuxOS 2010.12, Debian Lenny
Posts: 396

Original Poster
Rep: Reputation: 38
Hmmm interesting...

I was always told not to bring up the NIC connected to the ADSL modem...
 
Old 08-08-2006, 05:02 AM   #6
deVas
LQ Newbie
 
Registered: Jun 2004
Posts: 14

Rep: Reputation: 0
Maybe you should check the pppoe options in /etc/ppp/options and /etc/ppp/peers/dsl-provider. Activate the debug option! Check plog.
I do not think it is a problem with the nic, however you can try nictools or ethtool to check it.
devas
 
Old 08-08-2006, 06:28 AM   #7
DaveQB
Member
 
Registered: Oct 2003
Location: Sydney, Australia.
Distribution: PCLinuxOS 2010.12, Debian Lenny
Posts: 396

Original Poster
Rep: Reputation: 38
deVas,
I did check those files, mainly dsl-providers (because the pppoeconf 'wizard' didn't work.

I didn't notice the debug option in options though, I will try that next..
 
Old 08-08-2006, 06:43 AM   #8
Ashrack
Member
 
Registered: Oct 2005
Distribution: Ubuntu - Edgy Eft
Posts: 173

Rep: Reputation: 30
Quote:
Originally Posted by DaveQB
Hmmm interesting...

I was always told not to bring up the NIC connected to the ADSL modem...
If I dont bring up the NIC connected to ADSL it definetly wont connect. Have the same behavior on 2computers
 
Old 08-10-2006, 09:22 AM   #9
DaveQB
Member
 
Registered: Oct 2003
Location: Sydney, Australia.
Distribution: PCLinuxOS 2010.12, Debian Lenny
Posts: 396

Original Poster
Rep: Reputation: 38
Hmmm that is odd. I have never brought up the ADSL nic on my server and I have re-installed a few versions of Mandrake on it over the years..

Must be a distro thing.
 
Old 10-12-2006, 08:31 PM   #10
DaveQB
Member
 
Registered: Oct 2003
Location: Sydney, Australia.
Distribution: PCLinuxOS 2010.12, Debian Lenny
Posts: 396

Original Poster
Rep: Reputation: 38
Tried this again last night.

I brought up eth1 before the adsl-start command, but it seems to no want to stay up

Code:
Oct 12 23:38:39 localhost kernel: eth1: link up, 10Mbps, half-duplex, lpa 0x0000
Oct 12 23:38:39 localhost kernel: eth1: link down
Oct 12 23:38:39 localhost kernel: eth1: link up, 10Mbps, half-duplex, lpa 0x0000
Oct 12 23:38:45 localhost kernel: NETDEV WATCHDOG: eth1: transmit timed out
Oct 12 23:38:45 localhost kernel: eth1: link up, 10Mbps, half-duplex, lpa 0x0000
Oct 12 23:38:56 localhost kernel: eth1: link up, 10Mbps, half-duplex, lpa 0x0000
Oct 12 23:39:03 localhost pppd[28425]: pppd 2.4.3 started by root, uid 0
Oct 12 23:39:03 localhost pppd[28425]: Using interface ppp0
Oct 12 23:39:03 localhost pppd[28425]: Connect: ppp0 <--> /dev/pts/0
Oct 12 23:39:08 localhost kernel: NETDEV WATCHDOG: eth1: transmit timed out
Oct 12 23:39:08 localhost kernel: eth1: link up, 10Mbps, half-duplex, lpa 0x0000
Oct 12 23:39:26 localhost kernel: NETDEV WATCHDOG: eth1: transmit timed out
Oct 12 23:39:26 localhost kernel: eth1: link up, 10Mbps, half-duplex, lpa 0x0000
Oct 12 23:39:34 localhost pppd[28425]: LCP: timeout sending Config-Requests
Oct 12 23:39:34 localhost pppd[28425]: Connection terminated.
Oct 12 23:39:35 localhost pppd[28425]: Using interface ppp0
Oct 12 23:39:35 localhost pppd[28425]: Connect: ppp0 <--> /dev/pts/1
Oct 12 23:39:40 localhost pppd[28425]: tcflush failed: Bad file descriptor
Oct 12 23:39:40 localhost pppd[28425]: Exit.

NB: I have nothing for eth1 in /etc/network/interfaces
 
Old 11-12-2006, 02:01 PM   #11
DaveQB
Member
 
Registered: Oct 2003
Location: Sydney, Australia.
Distribution: PCLinuxOS 2010.12, Debian Lenny
Posts: 396

Original Poster
Rep: Reputation: 38
Anyone have a clue for this ?

I might try Ubuntu Server edition, might work easier for PPPoE perhaps.
 
Old 01-03-2007, 12:53 AM   #12
DaveQB
Member
 
Registered: Oct 2003
Location: Sydney, Australia.
Distribution: PCLinuxOS 2010.12, Debian Lenny
Posts: 396

Original Poster
Rep: Reputation: 38
Quote:
Originally Posted by Ashrack
If I dont bring up the NIC connected to ADSL it definetly wont connect. Have the same behavior on 2computers
I think this is where I got that idea from.

http://www.linuxquestions.org/questi...423#post589423
 
Old 08-20-2007, 05:14 PM   #13
Krellan
LQ Newbie
 
Registered: Aug 2007
Posts: 3

Rep: Reputation: 0
As for bringing up your Ethernet card for PPPoE:

What you want to do is bring the card UP, but do NOT give it an IP address.

Let's say your Ethernet is eth0.

When you run PPPoE, it will create a new interface ppp0.

The ppp0 interface will have your real public IP address, via PPPoE.

The eth0 interface will just be up, and not have an IP address at all, even though it will be carrying packets.

This makes sense when you look at eth0 with Wireshark or another packet sniffer. What you will see is a lot of packets going back and forth, that are not IP at all. PPPoE is its own separate protocol, not IP. This is why eth0 must be up, in order to carry this protocol, but not have an IP address, since it is not IP at all.

Once you get this configuration working, then you can try giving eth0 an IP address anyway. Do not use eth0 for routing, but continue to use ppp0 as your gateway for your broadband connection. What this will allow you to do is talk to your modem on eth0, and use its Telnet or Web interface to gather statistics from it. This IP address on eth0 won't be used for your broadband connection, since that's the job of ppp0. Rather, this is just a convenient shortcut to accessing your modem for diagnostic purposes. This is somewhat advanced usage and not recommended until you are comfortable getting ppp0 set up and working.
 
  


Reply

Tags
adsl, debian, pppoe


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PPPOE/xDSL any alternatives for rp-pppoe package.. deepclutch Linux - Software 2 02-04-2006 09:59 PM
pppoe & pppoe-server warning (solved) ggalvan Slackware 0 02-04-2006 05:58 AM
is there rp-pppoe in debian? tenzan Debian 2 06-30-2005 09:07 AM
PPPOE in Debian during installation michael2574661 Debian 2 04-20-2004 03:12 AM
adsl-status can't read pppoe PID file with rp-pppoe program setup Smarvy Linux - Newbie 2 03-13-2004 11:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration