LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-02-2009, 08:08 PM   #1
Person_1873
Member
 
Registered: Sep 2007
Location: Australia
Distribution: Arch Linux
Posts: 496

Rep: Reputation: 40
eth1 interface doesnt start automatically ubuntu server 9.04


i've replaced my ethernet NIC in my ubuntu server and now it doesnt bring up the interface on boot, every time i reboot the system i need to be there to bring the interface up, how can i resolve this?

/etc/network/interfaces
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth1
iface eth1 inet 10.1.1.10
 
Old 08-02-2009, 08:29 PM   #2
Meson
Member
 
Registered: Oct 2007
Distribution: Arch x86_64
Posts: 606

Rep: Reputation: 67
Does your computer see it as eth0 now?
 
Old 08-02-2009, 08:35 PM   #3
Person_1873
Member
 
Registered: Sep 2007
Location: Australia
Distribution: Arch Linux
Posts: 496

Original Poster
Rep: Reputation: 40
no, the old interface was eth0, by replacing the device it has coined it as eth1
 
Old 08-02-2009, 08:41 PM   #4
Meson
Member
 
Registered: Oct 2007
Distribution: Arch x86_64
Posts: 606

Rep: Reputation: 67
But they're not both physically connected to the system? Do you have DHCP on your network? For kicks while you figure it out, why don't you just try
Code:
auto lo
iface lo inet loopback

auto eth0

auto eth1
 
Old 08-03-2009, 04:46 AM   #5
Person_1873
Member
 
Registered: Sep 2007
Location: Australia
Distribution: Arch Linux
Posts: 496

Original Poster
Rep: Reputation: 40
no, the old one is sitting on my desk, i plugged the new one into the old slot, the problem isnt dhcp related, that works perfectly once i bring the interface up, i'll try your suggestion of adding in the auto eth0 line, i wanna leave the server as a static IP though
 
Old 08-03-2009, 05:44 AM   #6
Person_1873
Member
 
Registered: Sep 2007
Location: Australia
Distribution: Arch Linux
Posts: 496

Original Poster
Rep: Reputation: 40
i tried your suggestion of having eth0 set to auto in there as well, this didn't do a thing, the interface still doesn't start.

i also set eth1 as auto with no specified IP, it still doesn't work, so the file basically looks like your example
 
Old 08-03-2009, 06:01 AM   #7
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
So, you have tried this;

Examples:
Code:
iface eth1 inet static
address 192.168.1.5
netmask 255.255.255.0
gateway 192.168.1.254
Code:
auto eth1
iface eth1 inet dhcp
 
Old 08-03-2009, 06:35 AM   #8
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 295

Rep: Reputation: 31
Are you sure it is eth1
The right format of the file is the one given by alan_ri
There is a file in ubuntu - /etc/udev/rules.d/70-persistent-net.rules where the numbers of the network interfaces are shown. You can edit those numbers in the manner you want. For example we can see this in the file:

Code:
# PCI device 0x14e4:0x170c (b44)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:19:b9:69:71:44", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x14e4:0x4311 (b43-pci-bridge)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:19:7e:01:58:a9", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

# PCI device 0x14e4:0x4311 (wl)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:19:7e:01:58:a9", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"
so you can safely remove the section for your previous card and to change the number from 1 to 0 for the new one. And also here you can see is really the new card with number 1.
 
Old 08-03-2009, 07:02 AM   #9
Meson
Member
 
Registered: Oct 2007
Distribution: Arch x86_64
Posts: 606

Rep: Reputation: 67
Thanks for that knowledge Ipolit
 
Old 08-03-2009, 11:13 PM   #10
Person_1873
Member
 
Registered: Sep 2007
Location: Australia
Distribution: Arch Linux
Posts: 496

Original Poster
Rep: Reputation: 40
yes i'm sure it's eth1

i've fixed it by letting all interfaces get an IP via DHCP and setting my DHCP server to distribute IP's based on the MAC
 
Old 12-20-2009, 07:19 AM   #11
Person_1873
Member
 
Registered: Sep 2007
Location: Australia
Distribution: Arch Linux
Posts: 496

Original Poster
Rep: Reputation: 40
i now have both cards connected and working, one is giving out IP's and the other is statically set on the network, i just had my interfaces file set wrongly, i forgot to specify it as
Code:
auto eth1
 iface inet static
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to start X server automatically? sureshot324 Debian 5 08-20-2007 03:52 PM
graphical user interface doesnt start i_gabr_2003 SUSE / openSUSE 4 10-02-2006 08:18 PM
Start a server automatically? timmyk0 Linux - General 8 06-24-2006 02:58 AM
eth1 interface does not start up automatically wprauchholz Linux - Newbie 1 10-24-2004 09:46 AM
eth1 interface does not start-up automatically wprauchholz Linux - Networking 1 10-24-2004 06:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration