LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-03-2001, 01:37 PM   #1
mantiev
LQ Newbie
 
Registered: May 2001
Posts: 16

Rep: Reputation: 0
Unhappy


I just updated my kernel 2.4.4 because I love abuse. Upon boot I get the error that Bringing up interface eth0 : failed...i have tried recompiling the kernel and even used my old config and it still doesnt work...also i am getting the error NFS lockdsvc failed....any help would be greatly appreciated....thanks
 
Old 05-03-2001, 04:35 PM   #2
billsabub
Member
 
Registered: Feb 2001
Posts: 108

Rep: Reputation: 15
Did you update your pppoe prior to compiling your kernel?

See /'kernelsource'/Documentation/Changes for dependencies.
 
Old 05-04-2001, 07:49 PM   #3
KevinJ
Member
 
Registered: Feb 2001
Location: Colorado Springs, CO
Distribution: Redhat v8.0 (soon to be Fedora? or maybe I will just go back to Slackware)
Posts: 857

Rep: Reputation: 30
compiling the kernel

when you say you 'recompiled the kernel'.. how much did you with the kernel config? The default kernel config does not include support for ANY cards other than Intel cards. You have to turn on support for other cards. Same goes for NFS.

 
Old 05-07-2001, 08:51 AM   #4
mantiev
LQ Newbie
 
Registered: May 2001
Posts: 16

Original Poster
Rep: Reputation: 0
Unhappy Eth0 is failing after updating to kernel 2.4.4

OK..I now have LAN access again. I configured the kernel to recognize my 3Com NIC. Now I am getting the follow error after configuring NFS: rpc.lockd: lockdsvc: Invalid argument...any ideas on what i need to do to change this ?
 
Old 05-07-2001, 08:56 AM   #5
KevinJ
Member
 
Registered: Feb 2001
Location: Colorado Springs, CO
Distribution: Redhat v8.0 (soon to be Fedora? or maybe I will just go back to Slackware)
Posts: 857

Rep: Reputation: 30
When you recompiled the kernel, did you allow "NFS" under the "filesystems" options? I think that is turned off by default as well.
 
Old 05-07-2001, 09:03 AM   #6
mantiev
LQ Newbie
 
Registered: May 2001
Posts: 16

Original Poster
Rep: Reputation: 0
Eth0 is failing after updating to kernel 2.4.4

Yes I did....i also selected the option to communicate with other/older versions....is there a way to check the configuration and change it ? or do i need to recompile the kernel again ? thanks for all the help btw....
 
Old 05-07-2001, 09:30 AM   #7
KevinJ
Member
 
Registered: Feb 2001
Location: Colorado Springs, CO
Distribution: Redhat v8.0 (soon to be Fedora? or maybe I will just go back to Slackware)
Posts: 857

Rep: Reputation: 30
When you compile a kernel, a good practice is to always save the config file to somewhere on your disk, like your home dir, and give it a unique name so you know what it is.

You can then always go back and open that config to see exactly what you have configured. Without that file, I personally don't know any way to see all the options configured in a current kernel.

try this as root: service nfs start
 
Old 05-07-2001, 09:46 AM   #8
mantiev
LQ Newbie
 
Registered: May 2001
Posts: 16

Original Poster
Rep: Reputation: 0
Eth0 is failing after updating to kernel 2.4.4

i tried that and i received the following

bash: service: command not found

however there is a service in my /sbin

i tried running from the /sbin directory and had the same message

what am i doing wrong ?
 
Old 05-07-2001, 02:21 PM   #9
KevinJ
Member
 
Registered: Feb 2001
Location: Colorado Springs, CO
Distribution: Redhat v8.0 (soon to be Fedora? or maybe I will just go back to Slackware)
Posts: 857

Rep: Reputation: 30
Lemme guess... you are root, but you 'su'd to root, right?

Try this... 'su -' instead of this 'su' when you go to 'root'.

Or just try '/sbin/service nfs start'

 
Old 05-07-2001, 02:42 PM   #10
mantiev
LQ Newbie
 
Registered: May 2001
Posts: 16

Original Poster
Rep: Reputation: 0
Eth0 is failing after updating to kernel 2.4.4

OK getting closer...I typed in that command and nothing happened...I then did a ps -aux and looked at the processes running and nfs is nowhere to be found...I must have it configured improperly and need to just recompile the kernel making sure that NFS is correctly setup in the kernel config....
 
Old 05-07-2001, 02:53 PM   #11
KevinJ
Member
 
Registered: Feb 2001
Location: Colorado Springs, CO
Distribution: Redhat v8.0 (soon to be Fedora? or maybe I will just go back to Slackware)
Posts: 857

Rep: Reputation: 30
Did NFS work before you upgraded kernel? If it did and it doesn't now.. I would say you are on the right track. Recompile with NFS support.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Recompiled kernel failing thelonewolf Debian 10 08-02-2005 11:10 PM
eth1 failing on boot, IEEE firewire card driver failing, help jackuss_169 Linux - Laptop and Netbook 5 03-05-2005 08:34 AM
eth0 failing to set up axon Linux - Networking 3 10-27-2004 05:58 AM
Runlevel5 services failing after updating to 2.6.4 c4_4ya Linux - General 2 03-24-2004 04:39 PM
LILO install failing, Boot failing, but Installation fine. sramelyk Slackware 9 08-23-2003 03:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration