LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-08-2005, 06:23 PM   #1
mjkelly93
LQ Newbie
 
Registered: Jul 2005
Location: Shenandoah PA
Distribution: Ubuntu 5.10
Posts: 26

Rep: Reputation: 15
dhclient shows IP, but internet including ping wont work


I was tinkering around with wi-fi radar and in the process disconnected my internet connection. Thinking that it must have messed up some setting, i opened up netword-admin and tried a bunch of different settings unsuccessfully. So i decided to erase all the settings then restart the comp thinking it would work. It didnt. After finally fixing /etc/hosts and /etc/hostname, manually, i finally got sudo to work and got dhclient to work. So heres where we are now:

dhclient shows an ip address. In network-admin, eth1, the correct card, is enabled and the default card. It found the DNS servers for my ISP. My /etc/hosts looks like this:
127.0.0.1 localhost.localdomain shendo
#which is correct and now works fine
my hostname looks like this:
shendo
my dhclient looks like this:
Internet Systems Consortium DHCP Client V3.0.2
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

sit0: unknown hardware address type 776
sit0: unknown hardware address type 776
Listening on LPF/sit0/
Sending on LPF/sit0/
Listening on LPF/eth0/00:04:5a:50:57:e2
Sending on LPF/eth0/00:04:5a:50:57:e2
Listening on LPF/lo/
Sending on LPF/lo/
Listening on LPF/eth1/00:e0:4c:b0:89:a9
Sending on LPF/eth1/00:e0:4c:b0:89:a9
Sending on Socket/fallback
DHCPDISCOVER on sit0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on lo to 255.255.255.255 port 67 interval 4
DHCPREQUEST on eth1 to 255.255.255.255 port 67
DHCPACK from 10.201.120.1
bound to 12.44.226.13 -- renewal in 33058 seconds.

my "ifconfig eth1"
eth1 Link encap:Ethernet HWaddr 00:E0:4C:B0:89:A9
inet addr:12.44.226.13 Bcast:255.255.255.255 Mask:255.255.254.0
inet6 addr: fe80::2e0:4cff:feb0:89a9/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1553 errors:0 dropped:0 overruns:0 frame:0
TX packets:59 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:101793 (99.4 KiB) TX bytes:5310 (5.1 KiB)
Interrupt:23 Base address:0xec00

my route -n:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
12.44.226.0 0.0.0.0 255.255.254.0 U 0 0 0 eth1
0.0.0.0 12.44.226.1 0.0.0.0 UG 0 0 0 eth1

my /etc/resolv.conf:
domain shenhgts.net
nameserver 65.83.241.181
nameserver 67.32.118.46

my /etc/iftab:
# This file assigns persistent names to network interfaces. See iftab(5).
eth0 mac 00:04:5a:50:57:e2
eth1 mac 00:e0:4c:b0:89:a9

my /etc/network/interfaces:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# This is a list of hotpluggable network interfaces.
# They will be activated automatically by the hotplug subsystem.
mapping hotplug
script grep
map eth1

# The primary network interface
iface eth1 inet dhcp

auto eth1

------------------------

Also, pinging the default gateway under route -n, returns a successful ping measuring in ms like it should. Pinging anything else fails with no return. Just timing out. So heres where i stand:
Before me tinkering it worked fine.
Im on windows now using the same connection
It connects under dhclient and obtains an IP address.
Nothing works except pinging the gateway.
Heres the link to the thread over at ubuntuforums:
http://www.ubuntuforums.org/showthread.php?t=73207

Also im using Ubuntu 5.10 and a cable connection with DHCP.
So thanks in advance i know you guys are the best here at lq.org.

Marty
 
Old 10-09-2005, 07:46 AM   #2
mjkelly93
LQ Newbie
 
Registered: Jul 2005
Location: Shenandoah PA
Distribution: Ubuntu 5.10
Posts: 26

Original Poster
Rep: Reputation: 15
Does anyone know what files that network-admin writes to?

Like when i started ubuntu, prolly during installation, it ran something to detect my network settings. It filled in all those tabs under network-admin. Including a bunch of settings that arent in there anymore. So i needa know what files network-admin writes to then compare it to someone else. Or id really like to know what program writes to network-admin.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet WONT work! :-( Damien295x Linux - General 8 11-01-2005 09:37 AM
dhclient wont set wlan0 AM1SHFURN1TURE Linux - Wireless Networking 5 07-26-2005 03:08 PM
Sharing Internet with two machines, ping doen't work sandrain Linux - Networking 7 02-24-2004 12:59 PM
why wont my internet work? jimthing2001 Linux - General 2 01-06-2004 08:14 AM
New server on my work lan, cannot ping to it on get on internet. leefarrant Linux - Networking 2 11-13-2003 11:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration