LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 09-05-2003, 02:54 AM   #1
Henry
Member
 
Registered: Dec 2002
Location: USA
Distribution: Slackware9.0, some SuSe8.0
Posts: 179

Rep: Reputation: 30
creating wlan0 device in slackware


I have Slackware9.0, and have wireless SMC2632W card. I have linux-wlan-ng and wireless_tools, but those doesn't let me create a new network interface device... wlan0
can someone please tell me how?

my cardctl info say:
root@labtop:/home/punkshark# cardctl info
PRODID_1="SMC"
PRODID_2="2632W"
PRODID_3=""
PRODID_4=""
MANFID=01bf,b301
FUNCID=6
 
Old 09-05-2003, 12:57 PM   #2
[NL]_Target
Member
 
Registered: Aug 2003
Distribution: Arch Linux 0.7
Posts: 81

Rep: Reputation: 15
sorry, i have no experience with wireless + linux. You could try finding the apropriate driver on the web, and then compiling your kernel again with that module. good luck.
 
Old 09-05-2003, 07:09 PM   #3
Henry
Member
 
Registered: Dec 2002
Location: USA
Distribution: Slackware9.0, some SuSe8.0
Posts: 179

Original Poster
Rep: Reputation: 30
hehe thanks, but i did that like 50 times already, i compile with/without PCMCIA support.. i did it both to try to see if it work... but wlan0 still won't show up... i just can't get wlan0 up.. if it goes up.. i'll be so happy!
 
Old 09-06-2003, 12:38 AM   #4
Henry
Member
 
Registered: Dec 2002
Location: USA
Distribution: Slackware9.0, some SuSe8.0
Posts: 179

Original Poster
Rep: Reputation: 30
ok....this is getting me mad... i been trying to get this card to work for like 5 days now... gonna put up what i have... and someone PLZ help me try to get wlan0 interface up. thanks!

root@labtop:/home/punkshark# lsmod
Module Size Used by Not tainted
prism2_cs 67248 0 (unused)
p80211 19864 0 [prism2_cs]
orinoco_cs 4660 0 (unused)


root@labtop:/home/punkshark# cardctl info
PRODID_1="SMC"
PRODID_2="2632W"
PRODID_3=""
PRODID_4=""
MANFID=01bf,b301
FUNCID=6


root@labtop:/etc# cat modules.conf
#options prism2_cs prism2_doreset=1
alias wlan0 prism2_cs
options i82365 irq_mode=0
keep


root@labtop:/etc/wlan# ls
shared shared.prism2 wlan.conf wlancfg-DEFAULT wlancfg-wlan0


root@labtop:/etc/wlan# cat wlan.conf
<skip comments>
WLAN_DEVICES="wlan0"
ChannelList="01:02:03:04:05:06:07:08:09:0a:0b:00:00:00"
ChannelMinTime=200
ChannelMaxTime=250
WLAN_SCAN=n
SSID_wlan0="wlan0"
ENABLE_wlan0=y
#SSID_wlan1=""
#ENABLE_wlan1=n
#SSID_wlan2=""
#ENABLE_wlan2=n



root@labtop:/etc/wlan# cat wlancfg-wlan0
#=======USER MIB SETTINGS=============================
#USER_MIBS="p2CnfRoamingMode=1 p2CnfShortPreamble=mixed"

#=======WEP===========================================
# [Dis/En]able WEP. Settings only matter if PrivacyInvoked is true
lnxreq_hostWEPEncrypt=true # true|false false
lnxreq_hostWEPDecrypt=true # true|false false
dot11PrivacyInvoked=true # true|false false
dot11WEPDefaultKeyID=0 # 0|1|2|3
dot11ExcludeUnencrypted=true # true|false, in AP this means WEP is required.

# If PRIV_GENSTR is not empty, use PRIV_GENTSTR to generate
# keys (just a convenience)
# add-ons/ in the tarball contains other key generators.
PRIV_GENERATOR=/sbin/nwepgen # nwepgen, Neesus compatible
PRIV_KEY128=false # keylength to generate
PRIV_GENSTR=""

# or set them explicitly. Set genstr or keys, not both.
dot11WEPDefaultKey0= # format: xx:xx:xx:xx:xx or
dot11WEPDefaultKey1= # xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx
dot11WEPDefaultKey2= # e.g. 01:20:03:40:05 or
dot11WEPDefaultKey3= # 01:02:03:04:05:06:07:08:09:0a:0b:0c:0d
#=======SELECT STATION MODE===================
IS_ADHOC=n # y|n, y - adhoc, n - infrastructure

#======= INFRASTRUCTURE STATION ===================
# What kind of authentication?
AuthType="opensystem" # opensystem | sharedkey (requires WEP)
DesiredSSID=""

#======= ADHOC STATION ============================
BCNINT=100 # Beacon interval (in Kus)
CHANNEL=6 # DS channel for BSS (1-14, depends
# on regulatory domain)
BASICRATES="2 4" # Rates for mgmt&ctl frames (in 500Kb/s)
OPRATES="2 4 11" #2 4 11 22 # Supported rates in BSS (in 500Kb/s)

DEVICE=wlan0
ONBOOT=yes
BOOTPROTO=dhcp #static
USERCTL=yes
DHCLIENT_SET_DOWN_LINK=yes
STARTMODE=hotplug
MODE="Managed"
UNIQUE=""



root@labtop:/proc/net# ifconfig -a
eth0 Link encap:Ethernet HWaddr 000:59:67:15:8F
inet addr:192.168.1.86 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:159 errors:0 dropped:0 overruns:0 frame:0
TX packets:176 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:80614 (78.7 Kb) TX bytes:27238 (26.5 Kb)
Interrupt:11

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:100 (100.0 b) TX bytes:100 (100.0 b)

root@labtop:/proc/net# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

<I also have /etc/wlan/*.conf and /etc/pcmcia/*.conf included in the /etc/pcmcia/config.>
root@labtop:/etc/pcmcia# ls
cis ftl ieee1394 network parport.opts serial.opts wlan-ng
config ftl.opts ieee1394.opts network.O scsi shared wlan-ng.O
config.O ide memory network.opts scsi.opts wireless wlan-ng.conf
config.opts ide.opts memory.opts parport serial wireless.opts wlan-ng.conf.O

root@labtop:/etc/rc.d# ./rc.pcmcia restart
Shutting down PCMCIA services: done.
Starting PCMCIA services: cardmgr[773]: watching 1 sockets
done.

root@labtop:/etc/rc.d# pidof cardmgr
774

root@labtop:/etc/rc.d# cardctl status
Socket 0:
3.3V 16-bit PC Card
function 0: [ready]
 
Old 09-06-2003, 02:38 AM   #5
[NL]_Target
Member
 
Registered: Aug 2003
Distribution: Arch Linux 0.7
Posts: 81

Rep: Reputation: 15
are you using red hat ? if so, you could try configuring it by using the gui, which is sometimes more clear. Your config files look allright, i was only wondering about this:

<quote>
DEVICE=wlan0
ONBOOT=yes
BOOTPROTO=dhcp #static
USERCTL=yes
DHCLIENT_SET_DOWN_LINK=yes
STARTMODE=hotplug
MODE="Managed"
UNIQUE="" <---------- dont you need to fill in something over there ?
</quote>

I also think that you could try using the gui of your distro. If you're using red hat for example, this works pretty handy.

You could also type ( in a xterm or other terminal )

dmesg | more

dmesg is the text you see at boot time, but this time you can control how fast it goes. Look in this text to find something like:
Bringing up interface wlan0, failed cause of ..... ????

If you know why it failed, you could maybe find out where its going wrong.

Good luck, and let me know if you get it working!
 
Old 09-06-2003, 02:55 AM   #6
Henry
Member
 
Registered: Dec 2002
Location: USA
Distribution: Slackware9.0, some SuSe8.0
Posts: 179

Original Poster
Rep: Reputation: 30
hehe, thanks, i didn't really find anything in dmesg.. only that i have a pc card (my wireless) that is not supported.. but the driver said it is.. and im using Slackware.... have to do everything myself...that's the downside of slackware. and the blank UNIQUE="" , the instruction said i could just put it blank so the comp will fill it up itself. heres my dmesg :

root@labtop:/etc/pcmcia# dmesg
Linux version 2.4.22 (root@labtop) (gcc version 3.2.2) #12 SMP Fri Sep 5 20:58:04 PD
T 2003
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000ea000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 00000000077f0000 (usable)
BIOS-e820: 00000000077f0000 - 00000000077ffc00 (ACPI data)
BIOS-e820: 00000000077ffc00 - 0000000007800000 (ACPI NVS)
BIOS-e820: 00000000fffe0000 - 0000000100000000 (reserved)
119MB LOWMEM available.
On node 0 totalpages: 30704
zone(0): 4096 pages.
zone(1): 26608 pages.
zone(2): 0 pages.
Kernel command line: BOOT_IMAGE=Linux ro root=303 apm=power-off
Local APIC disabled by BIOS -- reenabling.
Found and enabled local APIC!
Initializing CPU#0
Detected 797.050 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 1589.24 BogoMIPS
Memory: 117848k/122816k available (1990k kernel code, 4580k reserved, 678k data, 136
k init, 0k highmem)
Dentry cache hash table entries: 16384 (order: 5, 131072 bytes)
Inode cache hash table entries: 8192 (order: 4, 65536 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 4096 (order: 2, 16384 bytes)
Page-cache hash table entries: 32768 (order: 5, 131072 bytes)
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 256K
CPU serial number disabled.
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: After generic, caps: 0383fbff 00000000 00000000 00000000
CPU: Common caps: 0383fbff 00000000 00000000 00000000
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 256K
Intel machine check reporting enabled on CPU#0.
CPU: After generic, caps: 0383fbff 00000000 00000000 00000000
CPU: Common caps: 0383fbff 00000000 00000000 00000000
CPU0: Intel Pentium III (Coppermine) stepping 06
per-CPU timeslice cutoff: 731.12 usecs.
SMP motherboard not detected.
enabled ExtINT on CPU#0
ESR value before enabling vector: 00000000
ESR value after enabling vector: 00000000
Using local APIC timer interrupts.
calibrating APIC timer ...
..... CPU clock speed is 797.0680 MHz.
..... host bus clock speed is 99.6334 MHz.
cpu: 0, clocks: 996334, slice: 498167
CPU0<T0:996320,T1:498144,D:9,S:498167,C:996334>
Waiting on wait_init_idle (map = 0x0)
All processors have done init_idle
PCI: PCI BIOS revision 2.10 entry at 0xfd83e, last bus=1
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Probing PCI hardware (bus 00)
PCI: Address space collision on region 9 of device VIA Technologies, Inc. VT82C686 [
Apollo Super ACPI] [8080:808f]
PCI: Using IRQ router VIA [1106/0686] at 00:07.0
PCI: Found IRQ 11 for device 00:0a.0
PCI: Sharing IRQ 11 with 00:07.2
PCI: Disabling Via external APIC routing
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)
Starting kswapd
Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI ISAPNP
enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
PCI: Found IRQ 11 for device 00:09.1
PCI: Sharing IRQ 11 with 00:09.0
Redundant entry in serial pci_table. Please send the output of
lspci -vv, this message (11c1,045c,8086,2201)
and the manufacturer and name of serial board or modem board
to serial-pci-info@lists.sourceforge.net.
register_serial(): autoconfig failed
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
eepro100.c:v1.09j-t 9/29/99 Donald Becker http://www.scyld.com/network/eepro100.html
eepro100.c: $Revision: 1.36 $ 2000/11/17 Modified by Andrey V. Savochkin <saw@saw.sw
.com.sg> and others
PCI: Found IRQ 11 for device 00:09.0
PCI: Sharing IRQ 11 with 00:09.1
eth0: OEM i82557/i82558 10/100 Ethernet, 000:59:67:15:8F, IRQ 11.
Board assembly 980100-000, Physical connectors present: RJ45
Primary interface chip i82555 PHY #1.
General self-test: passed.
Serial sub-system self-test: passed.
Internal registers self-test: passed.
ROM checksum self-test: passed (0xdbd8681d).
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 86M
agpgart: Detected Via Apollo PLE133 chipset
agpgart: AGP aperture is 64M @ 0xf8000000
[drm] Initialized tdfx 1.0.0 20010216 on minor 0
[drm] AGP 0.99 on Unknown @ 0xf8000000 64MB
[drm] Initialized radeon 1.1.1 20010405 on minor 1
[drm] AGP 0.99 on Unknown @ 0xf8000000 64MB
[drm] Initialized i810 1.2.0 20010920 on minor 2
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
hda: TOSHIBA MK1016GAP, ATA DISK drive
hdc: QSI CD-ROM SCR-242, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 19640880 sectors (10056 MB), CHS=1222/255/63
hdc: attached ide-cdrom driver.
hdc: ATAPI 24X CD-ROM drive, 128kB Cache
Uniform CD-ROM driver Revision: 3.12
Partition check:
hda: hda1 hda2 hda3
SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
Via 686a/8233/8235 audio driver 1.9.1-ac3
PCI: Found IRQ 9 for device 00:07.5
PCI: Setting latency timer of device 00:07.5 to 64
ac97_codec: AC97 Audio codec, id: ADS72 (Analog Devices AD1881A)
via82cxxx: board #1 at 0x1000, IRQ 9
es1371: version v0.32 time 19:54:40 Sep 5 2003
Linux Kernel Card Services 3.1.22
options: [pci] [cardbus] [pm]
PCI: Enabling device 00:0a.0 (0000 -> 0002)
PCI: Found IRQ 11 for device 00:0a.0
PCI: Sharing IRQ 11 with 00:07.2
Intel PCIC probe: not found.
orinoco.c 0.13d (David Gibson <hermes@gibson.dropbear.id.au> and others)
hermes.c: 4 Dec 2002 David Gibson <hermes@gibson.dropbear.id.au>
usb.c: registered new driver hub
Yenta IRQ list 04b8, PCI irq11
Socket status: 30000010
host/uhci.c: USB Universal Host Controller Interface driver v1.1
PCI: Found IRQ 11 for device 00:07.2
PCI: Sharing IRQ 11 with 00:0a.0
host/uhci.c: USB UHCI at I/O 0x1440, IRQ 11
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
USB Mass Storage support registered.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 8192 bind 8192)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
reiserfs: found format "3.6" with standard journal
reiserfs: checking transaction log (device ide0(3,3)) ...
for (ide0(3,3))
ide0(3,3):Using r5 hash to sort names
VFS: Mounted root (reiserfs filesystem) readonly.
Freeing unused kernel memory: 136k freed
Adding Swap: 979956k swap-space (priority -1)
prism2_init: prism2_cs.o: 0.2.1-pre9 Loaded
prism2_init: dev_info is: prism2_cs
orinoco_cs.c 0.13d (David Gibson <hermes@gibson.dropbear.id.au> and others)
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0300-0x04ff: excluding 0x378-0x37f 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0xa0000000-0xa0ffffff: clean.
via_audio: ignoring drain playback error -11
Assertion failed! chan->is_active == sg_active(chan->iobase),via82cxxx_audio.c,via_c han_maybe_start,line=1388
via_audio: ignoring drain playback error -11
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0300-0x04ff: excluding 0x378-0x37f 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
prism2_cs.o: 0.2.1-pre9 Unloaded
p80211.o: 0.2.1-pre9 Unloaded
prism2_init: prism2_cs.o: 0.2.1-pre9 Loaded
prism2_init: dev_info is: prism2_cs
 
Old 09-06-2003, 06:42 AM   #7
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 59
The linux-wlan modules, as far as I remember, will only work with in-kernel pcmcia now. Slackware 9.0 comes with a pcmcia precompile that is oriented towards an in-kernel compile, so compiling it out won't do anything unless you compile pcmcia-cs from scratch as well. Regardless, there are two versions of that SMC card, and the later of them isn't a prism2 card covered by the www.linux-wlan.net modules. What's the output of:

/sbin/cardctl ident

Cheers,

Finegan
 
Old 09-06-2003, 02:18 PM   #8
Henry
Member
 
Registered: Dec 2002
Location: USA
Distribution: Slackware9.0, some SuSe8.0
Posts: 179

Original Poster
Rep: Reputation: 30
yea.. i was looking @ that earlier too, but i thought my card was just SMC2632W.. no verison .2,.3


root@labtop:/home/punkshark# cardctl ident
Socket 0:
product info: "SMC", "2632W", "", ""
manfid: 0x01bf, 0xb301
function: 6 (network)

thanks sooo much for helping

oh, and did compiled with PCMCIA and the i82365 with kernel 2.4.22, and any command i type that have to do with wireless, it doens't give me any error except no wlan0 device found.

Last edited by Henry; 09-06-2003 at 02:21 PM.
 
Old 09-06-2003, 04:25 PM   #9
Henry
Member
 
Registered: Dec 2002
Location: USA
Distribution: Slackware9.0, some SuSe8.0
Posts: 179

Original Poster
Rep: Reputation: 30
oh, and when i do:
root@labtop:/etc/rc.d# ./rc.pcmcia restart
Shutting down PCMCIA services: done.
Starting PCMCIA services: cardmgr[29226]: watching 1 sockets
done.

i heard 2 beebs, one high pitch, one low... but still no wlan0 interface... so my led light won't light up....
 
Old 09-06-2003, 05:37 PM   #10
[NL]_Target
Member
 
Registered: Aug 2003
Distribution: Arch Linux 0.7
Posts: 81

Rep: Reputation: 15
i dont want to say youre stupid ( honestly i dont ! ) but stupid things can happen. Do you have a multiboot system / other pc in which you can test your hardware ? cause it **could** be a hardware related problem. I cant provide you with any other help on this, since i dont have wireless stuff myself. But please -> check that everything in your box is properly connected / insterted. Can solve LOADS of problems Also, testing it in another pc ( preferably windows, cause driver instalation is easier on windows cause those drivers SHOULD have come with the hardware ... ) Good luck. And i hope someone else can provide you with any software related stuff, cause im out of ideas ...
 
Old 09-06-2003, 06:13 PM   #11
Satriani
Member
 
Registered: Mar 2003
Location: The Netherlands
Distribution: Red Hat 7.3, Red Hat 9, Solaris8, Slackware 10, Slax on USB, AIX, FreeBSD, WinXP, AIX, Ubuntu
Posts: 418

Rep: Reputation: 30
I use a laptop with a wireless card in it, and it works just fine.
Now, this is not to poke you in the eye or someting like that, but maybe I can help you out a bit with settings i have in my Redhat.

I also do not have a wlan0, but just a eth0 device. That is my wireless NIC (Netgear with orinico driver)

I've been messing with it quit some time to get it work.
Maybe if you search this forum for wireless and NETGEAR you will be pointed in the right direction. If not, let me know which files to take a look at and I will check my configuration and post it for you.

Sat
 
Old 09-06-2003, 06:24 PM   #12
Henry
Member
 
Registered: Dec 2002
Location: USA
Distribution: Slackware9.0, some SuSe8.0
Posts: 179

Original Poster
Rep: Reputation: 30
hehe.. i know this stupid card works... cuz this labtop was windows before.. and it works fine... and yes it's plugin properly.. that's like the only thing i know how to to properly, stick the card in.. hehe... but yea.. it should work.. my cardmgr -V says it's version 3.2.4, should work... but it just say not supported....err.. and i dunno if my smc card is just SMC2632W or version .2 or .3 or -B... i dunno how to check that.. cuz my card maunall doesn't say and on the box.. it doesn't say.... and i'll looked for wireless everywhere.. havn't look on netgear.. so i'll look under that, thanks, Satriani, i'll come back to u on that.. but my eth0 is already buildin netdevice.. wlan0 should be created when i do ./etc/rc.pcmcia restart or something... but i dunno.. but thanks for hellping!
 
Old 09-06-2003, 07:01 PM   #13
Henry
Member
 
Registered: Dec 2002
Location: USA
Distribution: Slackware9.0, some SuSe8.0
Posts: 179

Original Poster
Rep: Reputation: 30
ok.. i don't get what the person was doing in here:

Code:
 cd /etc/rc.d/rc3.d
ln –s ../init.d/rc.wlan S09wlan
and
Quote:
Finally, in the /etc/wlan.conf file, I set

DesiredSSID=”Wireless”
SSID=”Wireless”
y wireless?

other than that', other stuff they talk about, i already did it.
 
Old 09-06-2003, 07:05 PM   #14
Satriani
Member
 
Registered: Mar 2003
Location: The Netherlands
Distribution: Red Hat 7.3, Red Hat 9, Solaris8, Slackware 10, Slax on USB, AIX, FreeBSD, WinXP, AIX, Ubuntu
Posts: 418

Rep: Reputation: 30
Henry: The default ESSID usually is "wireless". Change it to whatever your ESSID is.

The ln -s thing is that a script called rc.wlan was created in the /etc/rc.d/init.d directory (where all your startup scripts are) and then he created a link to it from rc3.d (runlevel 3 startupscripts)
 
Old 09-06-2003, 07:10 PM   #15
Henry
Member
 
Registered: Dec 2002
Location: USA
Distribution: Slackware9.0, some SuSe8.0
Posts: 179

Original Poster
Rep: Reputation: 30
ehh, what is level 3? i have /etc/rc.d/rc.wlan, so is that good enough?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wlan0: device not found anarchyprevails Linux - Wireless Networking 1 09-13-2005 04:48 PM
Cannot bring up wlan0 device JayBox Linux - Wireless Networking 6 05-31-2005 04:59 PM
how do I create the wlan0 device? veritas Linux - Wireless Networking 6 08-09-2004 05:09 PM
SuSE not creating wlan0 Yoda_Oz Linux - Wireless Networking 2 07-28-2004 09:19 AM
Configuring a wlan0 device... GooPunch Linux - Wireless Networking 5 05-12-2004 08:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration