LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-28-2005, 04:06 PM   #1
neilcpp
Member
 
Registered: Jul 2003
Location: England
Distribution: Debian Jessie, FreeBSD 10.1 anything *nix to get my fix
Posts: 329

Rep: Reputation: Disabled
closing port 6000 in mandrake 10.1


my firewall shows that someone/thing keeps trying to connect to or probe port 6000 on my pc. This is the x windows port. a nmap scan of my pc shows that port 6000 /tcp x11 is in state open.

I am running mandrake 10.1 and have edited the file /usr/X11R6/bin/startx:

userclientrc=$HOME/.xinitrc
userserverrc=$HOME/.xserverrc
sysclientrc=/etc/X11/xinit/xinitrc
sysserverrc=/etc/X11/xinit/xserverrc
defaultclientargs=""
defaultserverargs=""
clientargs=""

serverargs= -nolisten tcp
i tried rebooting and still get the message from a scan that port 6000 is open, despite the serverargs. Can anyone please tell me what to do as i am afraid that sooner or later someone is going to exploit this.

thanks

Last edited by neilcpp; 08-28-2005 at 04:12 PM.
 
Old 08-28-2005, 05:23 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983
you need to quote the value, and not have a space in it: serverargs="-nolisten tcp"
 
Old 08-29-2005, 10:55 AM   #3
neilcpp
Member
 
Registered: Jul 2003
Location: England
Distribution: Debian Jessie, FreeBSD 10.1 anything *nix to get my fix
Posts: 329

Original Poster
Rep: Reputation: Disabled
I did put the value in quote but the result is still the same. i even followed some directions i saw on this site for creating a special file x11 rc as root, that would be read each time the system starts. This was supposed to do the same thing and stop the server from listening.

in my case, nothing has made a difference and the port is still open. I have tried re-booting the machine several times.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to close port 6000? WilliamS Slackware 12 03-02-2005 12:27 PM
Disable port 6000 hegrunt Linux - Software 4 09-08-2003 12:49 PM
port 6000 pottsie Linux - Security 6 04-23-2003 04:06 AM
Port 6000 sitrus Linux - Security 4 12-15-2001 03:25 AM
Port 6000 an xwindows saavik Linux - Networking 8 11-09-2001 12:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration