LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-20-2017, 05:53 AM   #1
visuharsha
LQ Newbie
 
Registered: Jul 2017
Posts: 13

Rep: Reputation: Disabled
Can't ping or ssh to the cirros instance of the openstack instance


I've Configured openstack-newton using packstack, everything went well.... i've configured the routers, external network, internal network along with the subnets and the router settings....

I've launched an instance with cirros image and assigned an floating ip to it too, but the problem here is i'm unable to ping the ip-address of the instance or connect to the instance using ssh, the machine is getting connected if i'm using

" ip netns exec qrouter-4fc37274-fac5-42fa-bf70-916bbaa842c4 ping 192.168.13.54 " ==> for pinging
" ip netns exec qrouter-4fc37274-fac5-42fa-bf70-916bbaa842c4 ssh cirros@192.168.13.54 " ===> for ssh

I've configured the security groups to allow icmp and ssh

my br-ex file is

TYPE=OVSBridge PROXY_METHOD=none
BROWSER_ONLY=no BOOTPROTO=no
DEFROUTE=yes IPV4_FAILURE_FATAL=no
IPV6INIT=no IPV6_AUTOCONF=no
IPV6_DEFROUTE=no
IPV6_FAILURE_FATAL=no
IPV6_ADDR_GEN_MODE=stable-privacy
NAME=br-ex
UUID=44d7e1a6-22db-36da-9fa4-ecff7a149caa
DEVICE="br-ex" DEVICETYPE="ovs"
IPADDR=192.168.12.74
NETMASK=255.255.252.0
GATEWAY="192.168.12.2"
DNS1="8.8.8.8"

my ifcfg-enp0s3

TYPE=OVSPort
DEVICETYPE="ovs"
OVS_BRIDGE="br-ex"
PROXY_METHOD=none
BROWSER_ONLY=no
BOOTPROTO=no
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=no
IPV6_AUTOCONF=no
IPV6_DEFROUTE=no
IPV6_FAILURE_FATAL=no
IPV6_ADDR_GEN_MODE=stable-privacy
NAME=enp0s3
DEVICE=enp0s3
UUID=44d7e1a6-22db-36da-9fa4-ecff7a149caa
ONBOOT=yes
AUTOCONNECT_PRIORITY=-999

Public ip of the instance is 192.168.13.54
Private ip of the instance is 10.10.2.8

ovs-vsctl file is

27ff38a8-c4a9-4cd4-98cd-2e89c0d92f27
Manager "ptcp:6640:127.0.0.1"
is_connected: true
Bridge br-ex
Controller "tcp:127.0.0.1:6633"
is_connected: true
fail_mode: secure
Port phy-br-ex
Interface phy-br-ex
type: patch
options: {peer=int-br-ex}
Port br-ex
Interface br-ex
type: internal
Port "enp0s3"
Interface "enp0s3"
Bridge br-tun
Controller "tcp:127.0.0.1:6633"
is_connected: true
fail_mode: secure
Port patch-int
Interface patch-int
type: patch
options: {peer=patch-tun}
Port br-tun
Interface br-tun
type: internal
Bridge br-int
Controller "tcp:127.0.0.1:6633"
is_connected: true
fail_mode: secure
Port "tap8d8059c0-d6"
tag: 5
Interface "tap8d8059c0-d6"
type: internal
Port patch-tun
Interface patch-tun
type: patch
options: {peer=patch-int}
Port int-br-ex
Interface int-br-ex
type: patch
options: {peer=phy-br-ex}
Port "qvof36eda0a-02"
tag: 5
Interface "qvof36eda0a-02"
Port "qvoe60174b6-72"
tag: 1
Interface "qvoe60174b6-72"
Port "tapb5d2b750-ed"
tag: 1
Interface "tapb5d2b750-ed"
type: internal
Port "tap7a19b05a-02"
tag: 3
Interface "tap7a19b05a-02"
type: internal
Port "qr-6699743b-3d"
tag: 1
Interface "qr-6699743b-3d"
type: internal
Port "qg-7999c2fc-f7"
tag: 3
Interface "qg-7999c2fc-f7"
type: internal
Port "qg-81e47a12-7c"
tag: 4
Interface "qg-81e47a12-7c"
type: internal
Port "tapf24f2e69-60"
tag: 2
Interface "tapf24f2e69-60"
type: internal
Port "qg-1a80e610-9d"
tag: 6
Interface "qg-1a80e610-9d"
type: internal
Port br-int
Interface br-int
type: internal
Port "qr-954c980c-9c"
tag: 5
Interface "qr-954c980c-9c"
type: internal
Port "qr-3bd23302-c4"
tag: 2
Interface "qr-3bd23302-c4"
type: internal
ovs_version: "2.6.1"

need help from you guys, thanks in advance
 
  


Reply

Tags
netwoking, openstack


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix multiple instance only default instance work Dante K Linux - Server 0 09-05-2017 10:45 AM
LXer: Get an OpenStack Instance Up and Running in 40 Minutes or Less LXer Syndicated Linux News 0 07-20-2017 09:03 PM
LXer: Tips for instance configuration, creating a new project, and more OpenStack news LXer Syndicated Linux News 0 01-24-2017 06:11 AM
instance openstack kilo shivani1694@gmail.com Linux - Newbie 2 03-24-2016 02:07 AM
[SOLVED] Switch to instance instead of creating a new instance of a program javascriptninja Linux - Newbie 8 01-28-2012 04:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration