LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-15-2019, 12:53 PM   #1
jmgibson1981
Member
 
Registered: Jun 2015
Location: Tucson, AZ USA
Distribution: Debian
Posts: 361

Rep: Reputation: Disabled
Can't autofs mount a samba share for backups.


Trying to set up to pull backups from my Windows computer to my server.

Autofs configs


Code:
root@megalith:~# tail -n 1 /etc/auto.master
/srv/familydesktop /etc/auto.family --timeout=30
Code:
root@megalith:~# tail -n 1 /etc/auto.family
jason -fstype=cifs,credentials=/etc/jason.creds ://family.mylan.home/jason
Error

Code:
Aug 15 10:49:58 megalith kernel: [3016410.975386] CIFS VFS: cifs_mount failed w/return code = -112
I was able to manually mount by specifying the vers=2.0 option on the command line however that option just causes an error -13 for the autofs cifs mount fail. This is on Windows 10 Home and Ubuntu Xenial LTS.

How can I get this to work, or force autofs to use version 2.0 of samba by default?
 
Old 08-16-2019, 03:17 AM   #2
lpwevers
Member
 
Registered: Apr 2005
Location: The Netherlands
Distribution: SuSE, CentOS
Posts: 156

Rep: Reputation: 20
Error -13 means permission denied. So you may want to check if you made a typo in your credentials file. Also check the permissions on it. They should be 600.

If that fails you may want to try and add the option sec=ntlmv2 to your mount options.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] autofs passing username to autofs mounts Timothy Miller Linux - General 3 08-27-2018 06:24 PM
[SOLVED] How to use autofs to mount a NFS share apimente.br Mageia 3 06-30-2017 07:37 AM
[SOLVED] any autofs experts here? how to get autofs and WebDAV to play nice? zippydan Linux - General 2 09-05-2016 07:13 PM
[SOLVED] Mount samba share on Slackware: mount error(6) from mount.cifs frushiyama Slackware 11 01-22-2015 07:12 PM
Using Autofs to mount CIFS share and busy files? wernox Linux - Server 5 04-30-2010 04:39 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration