LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-02-2002, 05:11 PM   #1
nfisk
Member
 
Registered: Jul 2002
Location: Stockholm, Sweden
Distribution: Kubuntu, Fedora
Posts: 45

Rep: Reputation: 15
Unhappy Boot hangs at "starting pcmcia"


Suddenly, my Dell Inspiron laptop can't boot into Linux (Red Hat 7.3) anymore. It consistently hangs at the "starting pcmcia" entry, and I haven't been able to figure out how to get past that point. I've tried choosing "interactive startup," but it appears that the pcmcia module is loaded before the startup actually becomes interactive (it never asks me, it just goes ahead and loads it). It doesn't matter if the actual cards are in or out.

How do I skip this entry in the startup sequence? And, once I've done that, how do I troubleshoot for the problem?

--nfisk

PS: Thanks to all who responded with suggestions for how to solve my problem with the WLAN adapter. I don't know if this problem could be related to that one; they are, of course, both related to pcmcia. I did read your replies but didn't really get a chance to try them before this happened.
 
Old 12-02-2002, 05:27 PM   #2
bax
Member
 
Registered: Dec 2001
Location: NoVA
Distribution: Ubuntu, Solaris, OpenBSD
Posts: 492

Rep: Reputation: 30
Try hitting Cntrol C when it trys to start PCMCIA. Or upgrade to 8.0. Works great on my Inspiron 8100 even w/ wireless!
 
Old 12-02-2002, 06:38 PM   #3
balam
Member
 
Registered: Nov 2002
Location: us
Distribution: red hat
Posts: 143

Rep: Reputation: 15
right, this happens to when you have set to dhcp, so the system is actually looking for a dhcp to get a lease, and if yoo do not have one abaliable so keeps looking,

solution try to make a static ip. ex 192.168.1.8

hope this helps
 
Old 12-04-2002, 05:00 AM   #4
nfisk
Member
 
Registered: Jul 2002
Location: Stockholm, Sweden
Distribution: Kubuntu, Fedora
Posts: 45

Original Poster
Rep: Reputation: 15
Thanks for the suggestions, but...

bax: I had already tried Ctrl-C, and it does nothing; I forgot to mention this. The only thing that has any effect once the machine is hung is Ctrl-Alt-Del.

balam: I can't figure out how to change network parameters since I can't get past the pcmcia step in the startup sequence. Besides, if dhcp were the problem, wouldn't it help to simply remove the card (the network adapter is a PCMCIA card)? It doesn't.

The machine still boots just fine into Windoze 98.

--nfisk
 
Old 12-04-2002, 09:26 AM   #5
KevinJ
Member
 
Registered: Feb 2001
Location: Colorado Springs, CO
Distribution: Redhat v8.0 (soon to be Fedora? or maybe I will just go back to Slackware)
Posts: 857

Rep: Reputation: 30
Have you tried booting into single user mode?

Are you using grub or lilo? Graphical or text login screen?

-KevinJ
 
Old 12-04-2002, 09:41 AM   #6
nfisk
Member
 
Registered: Jul 2002
Location: Stockholm, Sweden
Distribution: Kubuntu, Fedora
Posts: 45

Original Poster
Rep: Reputation: 15
Trying again, I did manage to bypass the pcmcia step by using "interactive startup." When everything was up, I started pcmcia manually. It hung, and I could see that ifdown was using a lot of CPU. Unlike while booting, I could now press Ctrl-C -- which got me the normal beeps and a working network connection. I was subsequently able to stop and restart the pcmcia service at will without any problems. Haven't tried a reboot though.

Thanks,
--nfisk

Last edited by nfisk; 12-04-2002 at 01:29 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RH 7.1 boot hangs after "Starting kswapd ..." Nicanor Linux - Software 10 11-17-2005 02:09 AM
Boot hangs at "kjournald starting..." Emericanadian Linux - Newbie 5 08-22-2005 11:10 PM
Boot hangs for 3 minutes at "Starting syslogd daemons" DaneM Slackware 4 06-29-2005 11:52 PM
Boot hangs at "Starting resource manager" robintw SUSE / openSUSE 0 01-13-2005 03:43 PM
Fedora Core 3 hangs, freezes on "Starting sshd" ayrton Fedora 2 12-09-2004 10:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration