LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Mobile
User Name
Password
Linux - Mobile This forum is for the discussion of all topics relating to Mobile Linux. This includes Android, Tizen, Firefox OS, Sailfish OS, Maemo, MeeGo, Ubuntu Mobile, WebOS, Open Mobile Alliance and other similar projects and products.
A reminder that LQ now has a dedicated Android sister site: AndroidQuestions.org

Notices


Reply
  Search this Thread
Old 10-01-2017, 08:42 PM   #1
orestisfra
LQ Newbie
 
Registered: Jan 2017
Distribution: linux mint 17.3 KDE edition
Posts: 8

Rep: Reputation: Disabled
OEM command not working on Fastboot mode, Android 4.4.2 / Linux Mint 17.3


Hello forum,

I try to unlock the bootloader on my android phone (4.4.2 android, MLS iQ1055 model same idVendor as HTC, mt6582 processor) but when I try to execute any of the oem commands, the command doesn't seem to execute. It get stuck with 3 dots in the terminal and doesn't move. Also the phone does nothing. I have to either reboot the device manually or Ctrl+C + unplug the device and plug it in again to fix this.

I tried: changing the cable, changing the usb port, reinstalling ADB, using the ADB drivers given from my operating system's repositories, using the ADB drivers offered by google, running everything as root, creating a new rule in /etc/udev/rules.d/, adding my user to plugdev group, restarting udev.

What works: every ADB command. When my device is on Fastboot mode works everything except oem commands.

What doesn't work:
Code:
fastboot oem device-info
and
Code:
fastboot oem unlock
they give this output
Code:
...
and I can do nothing.

I use linux mint 17.3. Please tell me if you need more information about my setup or the issue. I have read a ton of tutorials on this topic none of them worked. I can give the links if you want but I don't want to make this topic huge.

Thank you in advance


EDIT:

I tried the same commands on another device (Xiaomi RedMi Note 4):
Code:
fastboot oem device-info
gave this output:
Code:
...
FAILED (remote: unknown command)
finished. total time: 0.002s
So are the oem commands no longer working?
Code:
fastboot getvar all
is working and says the bootloader is locked as it should do but I don't wanna mess up this phone so i didn't try anything else.

I got into fastboot of the other device again (MLS phone) and tried:
Code:
fastboot flashing get_unlock_ability
,
Code:
fastboot flashing get_unlock_bootloader_nonce
the output was:
Code:
...
then typed:
Code:
fastboot flashing unlock_critical
and got:
Code:
...
FAILED (command write failed (Success))
finished. total time: 0.000s
this statement contradicts itself and nothing happened on the phone. Then i tried
Code:
fastboot flashing unlock
with output:
Code:
...
FAILED (status read failed (Protocol error))
finished. total time: 5.032s
nothing on the phone but at least it gives an output now...

EDIT 2:
Code:
fastboot flashing getvar all
didn't say if the bootloader is unlocked or not.

Last edited by orestisfra; 10-02-2017 at 07:03 AM.
 
Old 10-11-2017, 01:43 PM   #2
orestisfra
LQ Newbie
 
Registered: Jan 2017
Distribution: linux mint 17.3 KDE edition
Posts: 8

Original Poster
Rep: Reputation: Disabled
sorry for the double post but i wanted to inform you that i don't have the phone anymore and to warn everyone NOT TO USE KINGROOT ONE CLICK ROOT APP OR ANY ONE CLICK ROOT APP ON YOUR PHONE! it's better to take your time back up what you need, reset and root properly through a computer (any operating system).

if someone has the same phone (MLS iQTalk color 1055) you can find a stock rom here: https://www.needrom.com/download/mls...-color-iq1055/ but any stock rom for any mt6582 phone will work, if you don't want the MLS applications that come preinstalled with the phone.

this is not solved but there is no need to reply. something went wrong when i tried to use the app mentioned above in the past.

Last edited by orestisfra; 10-11-2017 at 01:46 PM.
 
Old 10-11-2017, 04:31 PM   #3
X-LFS-2010
Member
 
Registered: Apr 2016
Posts: 90

Rep: Reputation: Disabled
Return for refund and get one that works. Succeeded!
 
  


Reply

Tags
android, fastboot, linux, oem


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
linux mint 18.1 oem problem black-clover Linux - Newbie 4 06-13-2017 10:42 AM
LXer: Linux Mint 17.2 OEM images available LXer Syndicated Linux News 0 07-26-2015 02:03 PM
[SOLVED] fastboot problems Android-sdk Gee Man Slackware 2 09-18-2012 06:44 PM
LXer: Install ADB And Fastboot Android Tools In Ubuntu Via PPA LXer Syndicated Linux News 0 09-01-2012 04:10 PM
LXer: Kernel 2.6.29 Arrives: Btrfs, Fastboot, WiMAX and Mode Setting LXer Syndicated Linux News 0 03-25-2009 07:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Mobile

All times are GMT -5. The time now is 02:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration