LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Mint
User Name
Password
Linux Mint This forum is for the discussion of Linux Mint.

Notices

Reply
 
LinkBack Search this Thread
Old 12-06-2011, 03:27 PM   #1
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Rep: Reputation: 48
No sound: Mint 12 on a LG M1 Express Dual laptop PC


Hello:

I have no sound.

I have: Mint 12 on a LG M1 Express Dual laptop PC

Alsamixer reports:
Card: HDA Intel
Chip: Realtex ALC880

Sound is not muted.

Any ideas how I can get the sound to work?

Thanks,

Last edited by Robert.Thompson; 12-06-2011 at 03:28 PM.
 
Old 12-06-2011, 08:48 PM   #2
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 6,888

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Are you referring to speakers, headphone, line out, or all three?
 
Old 12-07-2011, 10:48 AM   #3
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Original Poster
Rep: Reputation: 48
Quote:
Originally Posted by frankbell View Post
Are you referring to speakers, headphone, line out, or all three?
Hi Frank:

I had not tried headphones, when I did, they did work.

The speakers do not work.

I do not know what 'line out' is.

Thanks,
 
Old 12-08-2011, 11:56 AM   #4
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Original Poster
Rep: Reputation: 48
Anyone got a suggestion on how to get my speakers to work?

Thanks,
 
Old 12-08-2011, 01:52 PM   #5
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Original Poster
Rep: Reputation: 48
Hello:

'oobetimer' gave me the solution on the Mint Forum:

Code:
Solution:

You need to edit this file /etc/modprobe.d/alsa-base.conf and then add a line in its end. Use the following commands:
sudo gedit /etc/modprobe.d/alsa-base.conf

Now add the following line at its end:
options snd-hda-intel model=generic

Now reboot your computer. It should solve your problem. If the solution doesn’t work then try the Further Troubleshoot.
Further Troubleshoot:

The term model = generic may not work in all the cases as sometimes it depends on the model of your sound card. Find your sound card here.

You can try replacing the word generic by the following words depending upon your laptop:

Acer
options snd-hda-intel model=ACER

Asus F3J
options snd-hda-intel model=uniwill-m31

Dell 6400 laptop
options snd-hda-intel model=dell

Dell Inspiron
options snd-hda-intel model=ref

Dell Dimension 9150
options snd-hda-intel model=ref

Fujitsu Siemens Amilo XI 1526
options snd-hda-intel model=fujitsu

Gateway laptops with a sigmatel audio device
options snd-hda-intel probe_mask=1

or
options snd-hda-intel model=test enable-msi=1 probe-mask=1

Lenovo:
options snd-hda-intel model=laptop-eapd

LG P1 Express Dual (ALC880 chip)
options snd-hda-intel model=lg

LG P1 with CMI9880 chip
options snd-hda-intel model=minimal

Toshiba Satellite a135-s2386
options snd-hda-intel probe_mask=8 model=3stack

Toshiba Tecra A8-103
options snd-hda-intel probe_mask=8 model=fujitsu

or
options snd-hda-intel probe_mask=8 model=fujitsu
For my PC, the following worked:

G P1 Express Dual (ALC880 chip)
options snd-hda-intel model=lg


Marking as solved.
 
Old 12-22-2013, 03:51 AM   #6
JessNieto
LQ Newbie
 
Registered: Dec 2013
Location: Ville de Luxembourg, Europe
Distribution: MInt 16 XFCE
Posts: 1

Rep: Reputation: Disabled
Talking Solved: no sound at all after fresh Mint 16! Thanjs

Laptop with HDA Intel sound card got no sound at all after installing Mint 16.
Card was recognised, sound monitor was showing activity but no way...
I tried all I found online (ALSA, Pulseaudio...) and finally the easy recipe above solved in a minute:
"
1) sudo gedit /etc/modprobe.d/alsa-base.conf
add the following line at its end:
options snd-hda-intel model=generic

2) reboot
"
Thanks to 'oobetimer' and to Robert.Thompson

Jess Nieto
Luxembourg
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



All times are GMT -5. The time now is 07:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration