Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).


  Search this Thread
Old 09-17-2006, 09:30 PM   #1
Registered: Aug 2004
Location: Windsor Ontario
Distribution: Ubuntu, Debian, Redhat
Posts: 44

Rep: Reputation: 15
Question Wifi problem on Mayhem G3 (Kubuntu)

I have this laptop, its a Mayhem G3, by ABS computers (
the model I've got is about 2 years old. I've decided to set it up for Kubuntu. Everything went fine, but for the life of me I don't know how to install the wireless network card on this laptop :|

All other drivers detect fine and I have full (from what I tested) functionality so far on the Mayhem G3.

Link to the specs (in case needed):

Basically, wifi is integrated: (updated)
WLAN AR5001X+ Wireless Network Adapter

Now I've tried setting this up before (probly 3 months ago). I kinda gave up on it from that point on. I had someone help me, but I don't recall what I did, other than something about downloading madwifi drivers (?): madwifi-ng-r1634-20060608

Well now if i ifconfig I get:
root@mayhammy:/etc# ifconfig
eth0 Link encap:Ethernet HWaddr 00:03:0D:18:02:73
inet addr: Bcast: Mask:
inet6 addr: fe80::203:dff:fe18:273/64 Scope:Link
RX packets:17630 errors:0 dropped:0 overruns:0 frame:0
TX packets:11439 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:23842508 (22.7 MiB) TX bytes:1098279 (1.0 MiB)
Interrupt:209 Base address:0xd800

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wifi0 Link encap:UNSPEC HWaddr 00-02-6F-21-F8-C5-00-00-00-00-00-00-00-00-00-00
RX packets:598109 errors:0 dropped:0 overruns:0 frame:51817
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:63997767 (61.0 MiB) TX bytes:0 (0.0 b)
Interrupt:209 Memory:ffffc200000e0000-ffffc200000f0000
I'm thinking maybe I spoofed the interface somehow? How do i check which chipset I have? or at least what can I do to get on the right track. I've been trying to do this an its driving me mad

Sorry I'm a n00b when it comes to troubleshooting hardware probs

Appreciate any and all help

EDIT: I dual booted to check the WIFI type (from windows.. since I'm more 'capable' of doing that there) and the type of wifi (integrated card) that I got (as reported by windows):
WLAN AR5001X+ Wireless Network Adapter
MAC Address reported on it: 00 02 6F 21 F8 C5 (which seems to match the wifi0 MAC (?)

Thanks.. figured that might help..

Last edited by JakeX; 09-17-2006 at 09:53 PM.
Old 01-18-2008, 05:07 PM   #2
LQ Newbie
Registered: Jan 2008
Posts: 3

Rep: Reputation: 0
Maybe this will work

Next Post ...........

Last edited by crodriguezuribe; 01-18-2008 at 05:09 PM.
Old 01-18-2008, 05:08 PM   #3
LQ Newbie
Registered: Jan 2008
Posts: 3

Rep: Reputation: 0
I have a (Mayhem g3...). It worked for me on kubuntu dapper and edgy, but chenge over to debian and didn't at first i had to follow this steps to make it work. (rt2x00_serialmonkey_com/wiki/)

Originally Posted by crodriguezuribe View Post

Debian rt2500 Howto

From Rt2x00Wiki

This HOWTO details using an rt2500 card with Debian.

Preparing the Compilation Environment

Debian provides a tool named module-assistant which automates the process of installing out-of-kernel modules onto your Debian system. To prepare your system to install the rt2500 driver, you will need to install module-assistant and instruct it to prepare itself. This preparation includes automatically installing the kernel headers for your kernel, if they're not already present.

# apt-get install module-assistant
# module-assistant prepare

Obtaining the Driver

The rt2500 driver source is contained in the rt2500-source package. This package is in the Debian repositories for the testing ("Etch") and unstable ("Sid") branches. It is not in the stable (3.1 aka "Sarge") repository.

For Etch or Sid, simply:

# apt-get install rt2500-source

For Sarge, you will have to download one of the available versions of rt2500-source and install it with:

# dpkg --install rt2500-source-*.deb

With the source package installed, we can now use module-assistant to compile the driver for us.

Compiling the Driver

To compile the driver, simply type:

# module-assistant auto-install rt2500-source

This will compile the driver against the kernel headers matching the kernel you're currently using, put the compiled driver module in the right place to be used by your kernel, and load the module for you. Your rt2500-based card should now show up with:

# ifconfig -a

NB: In future, the rt2500 kernel module should be loaded automatically on boot. If it isn't, append the module name to /etc/modules with:

# echo rt2500 >> /etc/modules

Tip: ifrename

NB: This section is entirely optional, but may make your life easier.

Your rt2500 card should show up on your system with a name such as eth1. The number is assigned incrementally by the kernel in the order in which interfaces are discovered. This means that changing your system, by compiling other network card drivers or upgrading your kernel, can change the identifier which is assigned to your card. This can be a nonobvious bug to track down when it occurs.

The ifrename utility can be used to assign names to interfaces using a variety of techniques, overriding the kernel's naming scheme. Most usefully for us, we can give a particular name for an interface based on its MAC address, a unique identifier. To install the ifrename package:

# apt-get install ifrename

To get the MAC address of your rt2500 device, assuming it is named eth1:

# ifconfig eth1

The MAC address is on the first line, indicated by HWaddr:. To tell ifrename to use a different name (such as eth-wifi for the interface with this MAC address, we need to create a /etc/iftab file. This is documented in man iftab, but for a quick setup:

# echo -e 'eth-wifi\t\tmac 00:00:00:00:00:00

Replace 00:00:00:00:00:00 with the MAC address of your device. To double-check that ifrename will do what you expect it to do:

# ifrename -DV

If it's not working as expected, try tweaking the configuration file. If it is:

# ifrename

This will automatically be performed on boot, so from now on you can treat your wireless card as having the name you've chosen.

Of course, if you need your wireless working to install ifrename, you can delay this step. However, don't forget to change anything you put in /etc/network/interfaces (see "Automate It") to match your new interface name.

Configure the Card

Download the wireless-tools package if it's not already installed.

# apt-get install wireless-tools

wireless-tools provides you with the iwconfig and iwpriv commands. Along with ifconfig command, these should be enough to get your card working. Check the manpages for details; you probably don't need iwpriv unless you're using WPA.
Using WPA

WPA isn't directly supported by the Linux Wireless Tools API, so you need to use iwpriv to enable functionality directly on the card:

# ifconfig eth-wifi up
# iwconfig eth-wifi channel 5
# iwconfig eth-wifi essid youressidname
# iwpriv eth-wifi set AuthMode=WPAPSK
# iwpriv eth-wifi set EncrypType=TKIP
# iwpriv eth-wifi set WPAPSK="wireless password"
# ifconfig eth-wifi

Note how ifconfig is being used to control the interface state and IP configuration, iwconfig for general wireless configuration, and iwpriv for WPA-specific options.

Automate It

Once everything is working, you probably want the card to activate on startup. In Debian, the file /etc/network/interfaces contains settings for network interfaces, and is documented in man 5 interfaces. Integration of the iwconfig commands is described in /usr/share/doc/wireless-tools/README.Debian.

Add something similar to these lines somewhere in the file:

auto eth-wifi
iface eth-wifi inet dhcp
wireless-essid MyESSID
wireless-key 12345678

The "auto" line means it will be brought up automatically during the boot sequence. Replace MyESSID with your ESSID and 12345678 with your WEP key if you have one. Don't put dashes in your WEP key. If you don't have a WEP key, which is bad, then comment out that line by putting a # in front of it.

This will use DHCP. For static IP addressing, see the manpage for the configuration file. Note that for static IP addressing, you will need to put your DNS information into /etc/resolv.conf by hand, unless you use the resolvconf package (see "Tip: resolvconf" below).

You can now bring your wireless interface down and up by hand with the following commands:

# ifdown eth-wifi
# ifup eth-wifi

If you wish to use WPA then add the lines below in addition to those above

pre-up ifconfig eth-wifi up
pre-up iwpriv eth-wifi set AuthMode=WPAPSK
pre-up iwpriv eth-wifi set EncrypType=TKIP
pre-up iwconfig eth-wifi essid youressidname
pre-up iwpriv eth-wifi set WPAPSK=”wireless password”

Tip: resolvconf

The resolvconf package allows other packages to update the /etc/resolv.conf file automatically. It allows you to put DNS server information in the interface stanzas in /etc/network/interfaces, so you don't have to edit two files. Install it with:

# apt-get install resolvconf

Once installed, you can add lines like the following to your interface stanza:

dns-nameservers x.x.x.x
dns-search yourdomainname


This is an example of a working configuration using WEP:

auto eth-wifi
iface eth-wifi inet static
wireless_mode ad-hoc
wireless_channel 7
wireless_essid mynetwork
wireless_keymode restricted
wireless_key1 55d317375c1ce6f0aa0f0d3aef

This is the configuration from a firewall machine, which is why it has no gateway option. Note that this machine probably should be run as an access point, but the rt2500 driver does not support this, so it's an ad-hoc network. Ad-hoc 802.11g networks are limited to 11Mbps by the 802.11g spec, though this can be violated with an iwpriv command.

wireless_keymode restricted will stop any non-WEP-encrypted traffic being received by the firewall, which is a sensible precaution if you're relying on the limited security that WEP provides.
Old 01-18-2008, 05:12 PM   #4
LQ Newbie
Registered: Jan 2008
Posts: 3

Rep: Reputation: 0
url is



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kubuntu Wpa wifi issue DigitalBlue Ubuntu 13 04-14-2007 07:59 PM
Picking up my wifi with kubuntu??? supertunaman Linux - Wireless Networking 3 09-12-2006 03:23 PM
Agere / Lucent wifi card under kubuntu Turok Linux - Wireless Networking 2 12-15-2005 02:14 AM
Kubuntu install dwl-650+ wifi card issue esteeven Ubuntu 6 11-27-2005 02:45 PM
Sound mayhem laurentbon Slackware 11 10-22-2003 04:30 PM > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 04:03 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration