LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 09-07-2003, 02:19 PM   #1
BashTin
Member
 
Registered: May 2003
Location: West Midlands, United Kingdom.
Distribution: Slackware 14.1, Centos 7
Posts: 278

Rep: Reputation: 32
Angry Panasonic CF t1, X server & 256 colours


Hi all.
Have installed Mandrake 9.1, kernel 2.4.21-0.13mdksmp, XFree86 4.3.0 with KDE3.1 on my Panasonic Toughbook t1. It has a 12" TFT panel display with an Intel 82830m graphics controller. It all works fine (except software modem not supported) but I want to run it at 256/8bit colour depth so I can run that old classic Doom. However when I change the default depth in XF86Config to 8 and startx all I get is a blue screen, it makes attempts to put windows and menus on the screen but they disappear when clicked on.. well it just is all to pot. Any body any advise please? I have run XFdrake without any joy and it works fine at colour depth of 24. I have attached my XF86Config file. All help much appreciated.

Bash_Tin

****Part****** File generated by XFdrake.

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "Flat Panel 1024x768"
HorizSync 31.5-48.5
VertRefresh 40-70

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync

-vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "Intel Corporation"
BoardName "Intel 830"
Driver "i810"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection
 
Old 09-07-2003, 06:32 PM   #2
enyawix
Member
 
Registered: Sep 2003
Location: ky
Distribution: gentoo
Posts: 408

Rep: Reputation: 32
Lightbulb this will get u going

make shure agpgart is installed see man insmod.
than as root type xf86config.
 
Old 09-08-2003, 09:00 AM   #3
BashTin
Member
 
Registered: May 2003
Location: West Midlands, United Kingdom.
Distribution: Slackware 14.1, Centos 7
Posts: 278

Original Poster
Rep: Reputation: 32
Hi enyawix,
thanks for the reply. Tried that with same result. It works fine in 16 and 24 bit depths. In 8 bit it still comes up with only the wallpaper and the window that tells you the start up progress of KDE appears only for a brief second as a grey box. Also when I click on where any menus should be a blank window appears briefly on screen and core is dumped. Not sure what for.. I assume its the app trying to start. Any other pointers?

BashTin.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How many visitors on server with 1024/256 kbit/s klemen Slackware 1 06-19-2005 11:36 AM
B&W colours when playing DVDs Patsy Linux - Software 0 07-25-2004 01:28 PM
Fedora X-server not supporting "millions of colours" harsha_vardhan Linux - Newbie 5 01-23-2004 12:08 PM
tft panel and 256 colours BashTin Linux - Newbie 0 09-09-2003 06:34 PM
Low rez and only 256 colours allowed on RH 8.0....... sodapop Linux - Newbie 5 05-29-2003 04:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 08:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration