LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices


Reply
  Search this Thread
Old 11-04-2013, 06:58 AM   #1
peterdbj
LQ Newbie
 
Registered: Oct 2013
Posts: 10

Rep: Reputation: Disabled
grub cannot mount raid1 wheezy


I have created 2 raid1 partitation
/dev/md1 ext4 and /dev/md2 swap

/ is on /dev/md1

I have tried using
http://sysadmin.compxtreme.ro/how-to...oftware-raid1/
to create my raid1 .
I did

update-grub
update-initramfs -u

After copying all files from / on my sda1 parttation to /mnt/md1
and after doing

grub-install /dev/sda
grub-install /dev/sdb

and then reboot. The outcome is that the grub loader starts, I can choose between some linux-os but hereafter the loader is not able to mount /dev/md1 and I end with an initramfs prompt.

With a rescue disk I am able to mount /dev/md1 and when I run
mdadm --examine --scan
I get UUID which is different from what I find under
/dev/disk/by-uuid
why? Is that the problem?
What should I do?
 
Old 11-04-2013, 11:34 AM   #2
peterdbj
LQ Newbie
 
Registered: Oct 2013
Posts: 10

Original Poster
Rep: Reputation: Disabled
/etc/default/mdadm

The problem was that the ramdisk during boot didn't assemble the array
After modifying the /etc/default/mdadm with
INITRDSTART='all'

and

AUTOSTART=true

and then
update-initramfs
it worked
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] cant mount partitioms in wheezy kde desktop, they mount ok with xfce Daveb3 Debian 3 07-31-2013 03:19 PM
Grub error (raid1) circus78 Debian 10 04-25-2013 07:14 PM
GRUB and raid1 devices circus78 Linux - Server 7 04-16-2012 03:57 AM
Grub will not install - Wheezy + RAID1- HELP PLEASE!!! debian newbie Linux - Server 1 02-25-2012 04:33 AM
Grub, RAID1 and a spare theooze Linux - General 3 10-15-2008 10:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel

All times are GMT -5. The time now is 06:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration