LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 06-05-2008, 05:14 PM   #31
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,039

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373

Woah!

zibme posted a solution (thank you )

This is Linux Questions (and hopefully, Answers), so please quit squabbling: it serves no useful purpose.
Thank you.
 
Old 06-05-2008, 05:21 PM   #32
Emerson
Senior Member
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~
Posts: 3,187

Rep: Reputation: Disabled
Agreed.
I tend to go into biting mode when someone starts preaching stupidity and laziness. I'm gone now.
 
Old 06-08-2008, 04:08 AM   #33
SuperSparky
LQ Newbie
 
Registered: Apr 2008
Location: San Diego, California
Distribution: Ubuntu
Posts: 11

Rep: Reputation: 2
You have inserted more of your own assumptions into what was once a simple thread. Not a flame, but an amusing observation.

What I find incredible, and perhaps you failed to recognize the irony in it. Out of all of the "change your kernel" responses, I never once found the "what to change" being given. Out of all of the it's just an "installing or removing drivers" things, not once was there a "this is what you need to do" instruction/answer given. All were generalities, not solutions.

I never said I didn't know how to compile a new kernel. In fact, I didn't start this thread. However, I did notice that the default kernel in Fedora 8 had this issue, and found out some other kernel packages did as well (from others posting). I have 4G RAM and 64 megs lost is nothing to me, but an annoying curiosity. TO some others it was a problem, and a 64 bit only problem at that.

Anyone that has used the RPM and YUM system that Fedora and RedHat uses knows that when you compile a new kernel you generally hose the rest of the kernel dependent packages as well. If you install external kernel module packages (KMDL's etc), one knows that they have a specific kernel dependency. If you change the kernel from other than what is installed that they were compiled against as well, you hose the whole installation. The way to "fix" it is to go and manually compile all of the dependent modules as well to match, otherwise they refuse to attach themselves to the modified kernel. That is a pain in the neck. If you are a tar fanatic, then this isn't an issue, but if you like the ease of version tracking and upgrades via Yum, then don't bother trying to upgrade without reinstalling the old kernel to upgrade to a new. An unnecessary waste of time and effort.

As to hiring a professional. I've been a linux admin for years. There's just some things I don't care to do that waste my valuable time and these are usually things I shouldn't have to do. The end-all-be-all of solutions isn't recompiling or modifying the kernel. It's making sure the system is configured properly in the first place, and all of that nifty kernel code is written properly in the first place. Most of today's packaged modular kernels are even sufficient for the enterprise and are designed to be the most compatible configuration. Maybe not the absolute fastest, but the safest.

What I find as the epitome of amusing is that despite all of the so-called "experts" here, only one gave a clear and concise solution to the problem, and it didn't involve editing the kernel config. Just a simple addition to the kernel command line was all that was necessary to disable the error. Hopefully, the permanent solution is to have AGP kernel code smart enough to realize when there is no AGP hardware.

Linux isn't a club nor religion. If someone has a question, and you know the answer, then answer it. Life is so much easier with direct answers to questions, rather than emotional tirades of who should and should not be doing this or that. I chalk such talk off to fanaticism, and not constructive use. Instead of "you should know this" (once again forgetting the name of the web site), tell them the answer and they will know it. You've turned ignorance into knowledge and everyone wins.

Quote:
Originally Posted by Emerson View Post
Plain wrong. You get the exact sources for your running kernel and use .config file supplied in /boot or in /proc/config.gz.

See above.

Desktop? I was thinking we had a server problem here. If you refuse to use the power of Linux in professional environment then better hire a sysadmin who can.

Running make menuconfig, making one change, running make, copying it to /boot. Takes 1-2 minutes of human time depending on your finger speed and a little more machine time. If this effort is too much for you ... I refrain from saying what I think.

http://linux.oneandoneis2.org/LNW.htm

So installing/removing drivers is not an essential skill? Regardless what OS is used? As always, if you can't do it yourself, hire somebody who can. Don't whine.

Last edited by SuperSparky; 06-08-2008 at 04:12 AM.
 
Old 11-18-2008, 04:52 AM   #34
Moomtaz
LQ Newbie
 
Registered: Jun 2008
Posts: 9

Rep: Reputation: 0
Goodnight! The arrogance of this problem. If I am a user who barely knows how to check my email but ardently want to make the switch to linux these types of attitudes would be a problem. Well super Sparky let me ask you this question. you did the kernel=noaperature thing and it worked for you I need to know exactly where and exactly how you did it. I see it as a solution I just don't know where to drop the line. I am still trying to figure this linux beast out. I can almost find the files that launch applications that aren't listed in the little search box.
 
Old 11-18-2008, 06:19 AM   #35
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,039

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
You need to add iommu=noaperture ( not "kernel=noaperture" ) to your kernel bootline.
Depending on your distro (and you haven't told us that) your kernel boot line will probably be found in the file /boot/grub/menu.lst

You need to edit that file as root.
Scroll down to the part like this (this is mine, yours will be a bit different):
Code:
## ## End Default Options ##

title		Ubuntu 8.04.1, kernel 2.6.24-21-generic
root		(hd0,5)
kernel		/boot/vmlinuz-2.6.24-21-generic root=UUID=7591fe5b-8907-407f-854e-321684957104 ro vga=normal 
initrd		/boot/initrd.img-2.6.24-21-generic
quiet

title		Ubuntu 8.04.1, kernel 2.6.24-21-generic (recovery mode)
root		(hd0,5)
kernel		/boot/vmlinuz-2.6.24-21-generic root=UUID=7591fe5b-8907-407f-854e-321684957104 ro vga=normal single
initrd		/boot/initrd.img-2.6.24-21-generic
Add the kernel boot option to the end of the kernel boot line, so it now looks like this:

Code:
## ## End Default Options ##

title		Ubuntu 8.04.1, kernel 2.6.24-21-generic
root		(hd0,5)
kernel		/boot/vmlinuz-2.6.24-21-generic root=UUID=7591fe5b-8907-407f-854e-321684957104 ro vga=normal iommu=noaperture
initrd		/boot/initrd.img-2.6.24-21-generic
quiet

title		Ubuntu 8.04.1, kernel 2.6.24-21-generic (recovery mode)
root		(hd0,5)
kernel		/boot/vmlinuz-2.6.24-21-generic root=UUID=7591fe5b-8907-407f-854e-321684957104 ro vga=normal single iommu=noaperture
initrd		/boot/initrd.img-2.6.24-21-generic
Be very careful not to change anything else, or you may not be able to boot.
Save the changes.
Then reboot.

Last edited by tredegar; 07-12-2011 at 07:30 AM. Reason: Spelling corrected
 
Old 11-18-2008, 08:46 AM   #36
AuroraCA
Member
 
Registered: Jul 2008
Location: Northern CA USA
Distribution: Ubuntu, Slackware, Gentoo, Fedora, Red Hat, Puppy Linux
Posts: 370

Rep: Reputation: 35
Quote:
You need to add iommu=noaperature ( not "kernel=noaperature" ) to your kernel bootline.
Depending on your distro (and you haven't told us that) your kernel boot line will probably be found in the file /boot/grub/menu.lst
Finally a useful post in this thread.

Thank you to Zibme and Tredegar.
 
Old 11-18-2008, 11:25 PM   #37
Moomtaz
LQ Newbie
 
Registered: Jun 2008
Posts: 9

Rep: Reputation: 0
Thank you so very much it is indeed a useful Post I really appreciate it. Sorry about not mentioning my distro (Kubuntu 8.10) I am still working on that telepathy thing I almost had it down but then I started trying to get my Linux to work the way I want it to and got distracted.
I'm marking off my problems one by one.
1. Wifi with Atheros card Check up and running.
2. iommu=noaperature message should check after applying this patch.
3. Webcam working when I want to ~ Only in cheese and in Kopete and YouTube in the config mode and not in Canorama or Ekiga at all.
4. Sync Palm to evolution still in progress
5. ATI Radeon X1250 card enabled still in progress
6. Sync Windows CE 2003 Ipaq to evolutioon still in progress.
7. Run Windows apps in Wine haven't tried yet.
If all howtos where this thought out and expressed as your answer was then I am sure I wouldn't have a problem, but we are all human and as such will have communication problems.

I am hoping to resolve all of these issuess and then I will have a Zen moment and probably move all the way over to Linux.

Last edited by Moomtaz; 11-18-2008 at 11:26 PM. Reason: Forgot something
 
Old 11-19-2008, 07:41 AM   #38
SuperSparky
LQ Newbie
 
Registered: Apr 2008
Location: San Diego, California
Distribution: Ubuntu
Posts: 11

Rep: Reputation: 2
Woah there my friend. I was in your shoes and just as frustrated and begging for help. All I got was condescending arrogance as responses. They kept telling me to do something that was impossible with my hardware configuration. Seriously, why would a system without AGP hardware have BIOS settings for an AGP aperture? Many people had this issue and all they got was the wall of arrogance and condescendment. There was, thankfully, one kind-hearted soul that did answer plainly and mentioned the "iommu=noaperature" solution. Another also said "iommu=noagp". I do not recall which one worked, but one did.

Since I see "tredegar" has elaborated on how to do this I won't, unless you ask me to. In which case, I'd be happy to.

Nevertheless, it has been quite a long time since I had this problem, as I now use Ubuntu 8.10 instead of Fedora. Ubuntu uses a generic kernel and lo and behold it seems the kernel programmers have actually fixed this issue by having the kernel automatically recognize the environment it is running in and turn off the aperture issue itself. This something I suggested back then as a final solution.


Quote:
Originally Posted by Moomtaz View Post
Goodnight! The arrogance of this problem. If I am a user who barely knows how to check my email but ardently want to make the switch to linux these types of attitudes would be a problem. Well super Sparky let me ask you this question. you did the kernel=noaperature thing and it worked for you I need to know exactly where and exactly how you did it. I see it as a solution I just don't know where to drop the line. I am still trying to figure this linux beast out. I can almost find the files that launch applications that aren't listed in the little search box.
 
Old 11-19-2008, 09:13 AM   #39
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279Reputation: 1279
I'm not sure what you all mean by arrogance or who was being arrogant. If you mean me, then I sincerely apologize, that was not my intention. All I wanted to know is if the OP had tried to enable IOMMU in the BIOS. Since the OP did not post much info on what they tried, I did not know whether on not they tried this, or if this was even an option in the BIOS. I did then post a link that contained two possible solutions "iommu=noagp" and "iommu=memaper=3". I think Emerson also posted a reasonable solution, simply disable AGP in the kernel. Then zibme posted a solution not mentioned, probably the best one. It was SuperSparky that was being very mean, inconsiderate, and actually arrogant.

Now, can we get over it and move on.
 
Old 11-19-2008, 02:03 PM   #40
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,258

Rep: Reputation: 189Reputation: 189
Quote:
Originally Posted by zibme View Post
From what I've gathered, you do not need aperture space when you only have PCIe
Sorry for going off topic, but does that also mean aperture space is completely useless for pci-e even if it's available?

Last edited by jens; 11-19-2008 at 10:53 PM.
 
Old 11-24-2008, 03:06 PM   #41
Moomtaz
LQ Newbie
 
Registered: Jun 2008
Posts: 9

Rep: Reputation: 0
Question Thinking of doing a clean install

My Progress: the "iommu=noaperature" solution didn't work so I think I will try the "iommu=noagp" or the "iommu=memaper=3" but I am on kubuntu 8.10 just like the other guy. What I seriously think is going on with my distro is that there are key elements of my last distro 8.04 mixing with this distro. Like all of those options and versions in my menu screen. I don't remember exactly what kernel 8.04 was but they like have the current one and then several others as well. Silly things happened on this install like my camera works on some "default" setting but not when I set it to the "chicony" camera that it is. So some programs look for the default in one mode and the Chicony camera in normal mode. Camorama doesn't work at all, but cheese works. Kopete works when it is in configuration mode, but if I invite someone to video chat it doesn't work. Ekiga doesn't work at all.

My flxgr whatever driver for my ATI card comes up on the restricted hardware option thing, but it refuses to enable and it isn't listed in the installed modules. For Gspci driver it won't compile or install. My cmake won't Make to get to the gspci.ko nor can I make synCE either. So I am seriously thinking of wiping the whole thing and reinstalling everything. This is still a fresh install so I don't have much invested yet. When I installed this version I thought I did a clean install but all of my files and my file folders were in their places after the system came up. So I don't know what really happened there.


What do you all think? Reformatting tonight unless clearer heads say otherwise.
 
Old 11-24-2008, 03:48 PM   #42
AuroraCA
Member
 
Registered: Jul 2008
Location: Northern CA USA
Distribution: Ubuntu, Slackware, Gentoo, Fedora, Red Hat, Puppy Linux
Posts: 370

Rep: Reputation: 35
Aperture is misspelled. Try this:

Code:
iommu=noaperture
 
Old 11-24-2008, 06:12 PM   #43
Moomtaz
LQ Newbie
 
Registered: Jun 2008
Posts: 9

Rep: Reputation: 0
Cool

Quote:
Originally Posted by AuroraCA View Post
Aperture is misspelled. Try this:

Code:
iommu=noaperture
Yep that was it. It flashed some other bios bug but it was too fast to read. My computer boots so fast now Loving the non-constant spin of my poor harddrive. Ok on to my other problems I will call that one solved but I will have to start new Threads linux-heads are so thread disciplined. LOL
 
Old 11-25-2008, 02:21 AM   #44
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,039

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Quote:
Aperture is misspelled. Try this:
Thank you. Corrected.
 
Old 12-13-2008, 06:19 PM   #45
digital8doug
Member
 
Registered: Aug 2006
Location: Near Binghamton, NY-the recent FLOOD zone
Distribution: Sabayon 351, Mepis8, oSuse11.3, Kubuntu8.1, Fed10, Slack12.1 #426299 RLU
Posts: 145
Blog Entries: 1

Rep: Reputation: 15
Lightbulb ath9k 0000:07.00.0 PCI-DMA Out of IOMMU space for 4096 bytes

I am getting error listed in Updated SUBJ line. x86-64 distros; Fedora10, Kubuntu 8.1, Mandriva 2009, maybe also with Mepis 8 b6 & Sabayon 3.5.1 all of which use fairly recent kernels. Will try
Quote:
Originally Posted by tredegar View Post
SNPD/Edtd Add iommu=noaperture ( not "kernel=noaperature" ) to your kernel boot line.
Depending on your distro your kernel boot line will probably be found in the file /boot/grub/menu.lst
You need to edit that file as root.
I lose WiFi connection in about 5 minutes, must reboot to regain it again , then it is gone. Hopefully passing command to kernel will correct entire difficulty on Asus G2k-A1 W/ AR 5418 WiFi chipset.
btw, There is some excellent info in this thread even though the OP changed distro & left, I learned a lot TY to all.

Last edited by digital8doug; 12-23-2008 at 03:41 PM. Reason: DID NOT HAVE PROBLEM W/ OPENSUSE OR W/ ABOVE DISTROS WITH THE KERNEL OPTION
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Are PHP session variables held in memory when you leave a PHP site? Locura Programming 11 11-16-2008 08:37 PM
request_mem_region kernel function and 15-16M memory hole trifola Linux - Kernel 0 01-04-2008 02:16 AM
Asus K8N-DL no memory hole --> no boot! Basileus Romaion Linux - Hardware 2 07-04-2007 11:49 AM
FC5, the memory black hole seimour Fedora 3 04-17-2006 04:30 PM
Memory hole/leak in RH9? mrogers Linux - Newbie 2 09-23-2003 08:07 PM


All times are GMT -5. The time now is 01:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration