LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 07-04-2007, 05:25 AM   #1
Basileus Romaion
LQ Newbie
 
Registered: May 2006
Posts: 5

Rep: Reputation: 0
Asus K8N-DL no memory hole --> no boot!


Hi to all,

I have the following problem, maybe common to others even if I was not able to find a solution in the forum:

We had a dual dual-core opteron (opteron 275) computer with Asus K8N-DL motherboard (Phenix BIOS) and 6 Gb of RAM (6x1, bought in april 2006). It has a linux partion (suse 10.0) and a small windows partition (30Gb, mainly for "safety" reason, essentially never used).

Now memory had been upgraded to 12 Gb (6x2Gb) but it is not possible to boot linux.
Suse freezes and only gives a black screen.

I tried to upgrade to Suse 10.2 or install Fedora 6 (they had been installed without problems in similar workstations...) but Suse does not install (black screen) and FC6 gives a problem:


Checking aperture...
CPU 0: aperture @ 12000000 size 32 MB
Aperture from northbridge cpu 0 too small (32 MB)
No AGP bridge found
Your BIOS doesn't leave a aperture memory hole
Please enable the IOMMU option in the BIOS setup
This costs you 64 MB of RAM
Mapping aperture over 12817793024 KB of RAM @ 1288490188

...but then nothing

(I hope to have copied all correctly (maybe some error in the numbers).)

I tried to boot the installed version of suse 10.0 with some options: for example

iommu_debug=y mem=4096M

gives:

CPU0: Machine check exception
TSC 2b054d55b6
kernel panic -not syncy: Machine check

I tried also

iommu=65536

or

iommu=soft swiotlb=65536

but no result (system freezes with a black screen). (in tried the same options installing FC6 but no improvement)

So, the question:

1) How can I set the memory hole? I did not found any such option in the BIOS!
2) there is a boot option to correct it?

Thanks a lot in advance for your help.
 
Old 07-04-2007, 11:19 AM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,698

Rep: Reputation: 287Reputation: 287Reputation: 287
This document might help with the "memory hole" issue:
http://www.debian.org/releases/stabl...h03s06.html.en
 
Old 07-04-2007, 11:49 AM   #3
Basileus Romaion
LQ Newbie
 
Registered: May 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks, the problem is maybe that there is no memory hole configuration in my BIOS... so that I cannot disable it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Asus K8N-E or MSI Neo3-F? DonBarredora Linux - Hardware 3 02-26-2006 03:50 AM
Install Problems SLES9 on ASUS K8N-E aliebel Linux - Newbie 11 02-13-2006 07:52 PM
nforce3 and asus k8n temperature sensors? anarhistu Linux - Hardware 2 02-21-2005 07:59 AM
asus k8n-e-deluxe necrophage Linux - Software 1 01-30-2005 01:40 AM
Onboard Sound on Asus K8N-E Chebyshev Linux - Hardware 3 08-09-2004 06:41 PM


All times are GMT -5. The time now is 07:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration